8.х значение не объектного типа

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 8"", создана пользователем csusha, 27 фев 2011.

  1. TopicStarter Overlay
    csusha
    Offline

    csusha

    Регистрация:
    7 фев 2011
    Сообщения:
    19
    Симпатии:
    0
    Баллы:
    1
    Подскажите пожалуйста где нужно изменить значение, чтобы оно стала значением объектного типа(Я работаю с командной строкой с кнопкой Поиск). А вот и сам листинг

    используйте функции форума, ибо нечитаемо
    Код:
    Процедура ПриОткрытии()
    КС=Новый КвалификаторыСтроки(10,ДопустимаяДлина.Фиксированная);
    КЧ=Новый КвалификаторыЧисла(6,2,ДопустимыйЗнак.Неотрицательный);
    КД=Новый КвалификаторыДаты(ЧастиДаты.Дата);
    М=Новый Массив();
    М.Добавить(Тип("Строка"));
    ОписанТиповС=Новый ОписаниеТипов(М,КС);
    ТабЗн.Колонки.Добавить("Должность",ОписанТиповС,"Должность");
    ТабЗн.Колонки.Добавить("ФИО",ОписанТиповС,"Фамилия сотрудника");
    М.Очистить();
    М.Добавить(Тип("Число"));
    ОписанТиповЧ=Новый ОписаниеТипов(М,КЧ);
    ТабЗн.Колонки.Добавить("Оклад",ОписанТиповЧ,"Оклад");
    М.Очистить();
    М.Добавить(Тип("Дата"));
    ОписанТиповД=Новый ОписаниеТипов(М,КД);
    ТабЗн.Колонки.Добавить("Дата",ОписаниеТиповД,"Дата приема на работу");
    СтрТ=ТабЗн.Добавить();
    СтрТ.Должность="Менеджер";
    СтрТ.ФИО="Иванов";
    СтрТ.Оклад=5600.78;
    СтрТ.Дата='20081201';
    Если СтрТ["Дата"]=Дата(1,1,1) Тогда
    Сообщить("Пустая дата!");
    КонецЕсли;
    Если НЕ ЗначениеЗаполнено (СтрТ["Дата"]) Тогда
    Сообщить("Значение незаполнено");
    КонецЕсли;    
    ЭлементыФормы.Добавить(Тип("ТабличноеПоле"),"ТС",Истина);
    ЭлементыФормы.ТС.Верх=15;
    ЭлементыФормы.ТС.Лево=5;
    ЭлементыФормы.ТС.Ширина=ЭтаФорма.Ширина-5;
    ЭлементыФормы.ТС.Высота=250;
    ЭлементыФормы.ТС.Значение=ТабЗн;
    ЭлементыФормы.ТС.СоздатьКолонки();
    КонецПроцедуры
    
    
    В результате выдается сообщение:

    Значение не является значением объектного типа (Колонки)
    ТабЗн.Колонки.Добавить("Должность",ОписанТиповС,"Должность");
  2. mialord
    Offline

    mialord Модераторы Команда форума Модератор

    Регистрация:
    31 июл 2009
    Сообщения:
    5.398
    Симпатии:
    40
    Баллы:
    54
    Здраствуйте!
    ТабЗн у Вас откуда, какого типа? Это видимо не таблица значений.
    Пока не вижу откуда у Вас взялась данная переменная порекомендую её неявно объявить перед использованием.
    Код:
    ОписанТиповС=Новый ОписаниеТипов(М,КС);
    ТабЗн = Новый ТаблицаЗначений
    ТабЗн.Колонки.Добавить("Должность",ОписанТиповС,"Должность");
    ТабЗн.Колонки.Добавить("ФИО",ОписанТиповС,"Фамилия сотрудника");
    
Похожие темы
  1. abaz
    Ответов:
    1
    Просмотров:
    1.249
Загрузка...

Поделиться этой страницей