[РЕШЕНО] Значение не является значением объектного типа (подключиться)

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 8"", создана пользователем AUBalan, 4 апр 2014.

  1. TopicStarter Overlay
    AUBalan
    Offline

    AUBalan

    Регистрация:
    25 мар 2014
    Сообщения:
    24
    Симпатии:
    0
    Баллы:
    1
    Добрый день, Уважаемые!
    Вот такая вот ошибка:
    Рисунок1.png
    Код - отправка сообщения:

    Код:
    Профиль = Новый ИнтернетПочтовыйПрофиль;
        Профиль.АдресСервераSMTP = "smtp.mail.ru";
        Профиль.ПортSMTP = 25;
        Профиль.Пользователь = "aubalan@bk.ru";
        Профиль.Пароль = "";
        Профиль.АутентификацияSMTP = СпособSMTPАутентификации.Login;
        Профиль.ПарольSMTP = "";
        Профиль.ПользовательSMTP = "aubalan@bk.ru";
      
        Почта = Новый ИнтернетПочта;
        Попытка
            Почта.Подключиться(Профиль);
          
        Исключение
            Сообщить("Ошибка при подключении к серверу" + ОписаниеОшибки());
            Возврат;
        КонецПопытки;
      
        Сообщение = Новый ИнтернетПочтовоеСообщение;
        Сообщение.Отправитель = "aubalan@bk.ru";
        Сообщение.Получатели.Добавить("aubalan69@gmail.com");
        Сообщение.Тема = "Привет! Привет! Привет!";
        Сообщение.Тексты.Добавить("Сообщение отправлено с 1С",ТипТекстаПочтовогоСообщения.HTML);
        Почта.Послать(Сообщение);
        Почта.Отключиться();
    
    В обработке все работает.
    Вписал в документ и вот... Помогите разобраться!
    Заранее спасибо!
  2. alexburn
    Offline

    alexburn Модераторы Команда форума Модератор

    Регистрация:
    5 янв 2009
    Сообщения:
    14.781
    Симпатии:
    509
    Баллы:
    204
    Код в студию. И на какой стороне идет выполнение.
  3. TopicStarter Overlay
    AUBalan
    Offline

    AUBalan

    Регистрация:
    25 мар 2014
    Сообщения:
    24
    Симпатии:
    0
    Баллы:
    1
    Форма:
    Код:
    
    &НаСервере
    Процедура ПриСозданииНаСервере(Отказ, СтандартнаяОбработка)
        Если Объект.Ссылка.Пустая() Тогда
        Объект.ДатаНачала = ТекущаяДата();
        Объект.КрайнийСрок = ТекущаяДата();
        Объект.КемСоздана = ПользователиИнформационнойБазы.ТекущийПользователь();
        КонецЕсли;
        Объект.ТекущийПользователь = ПользователиИнформационнойБазы.ТекущийПользователь();
    
    КонецПроцедуры
    
    &НаКлиенте
    Процедура ДобавитьКомментарий(Команда)
    Объект.Комментарий = Объект.Комментарий + Символы.ПС + Объект.ТекущийПользователь + ": " + Объект.ПолеВвода;
    ОбновитьОтображениеДанных();
    Объект.ПолеВвода = "";
    
    КонецПроцедуры
    
    &НаКлиенте
    Процедура Команда1(Команда)
        Профиль = Новый ИнтернетПочтовыйПрофиль;
        Профиль.АдресСервераSMTP = "smtp.mail.ru";
        Профиль.ПортSMTP = 25;
        Профиль.Пользователь = "aubalan@bk.ru";
        Профиль.Пароль = "";
        Профиль.АутентификацияSMTP = СпособSMTPАутентификации.Login;
        Профиль.ПарольSMTP = "";
        Профиль.ПользовательSMTP = "aubalan@bk.ru";
    
        Почта = Новый ИнтернетПочта;
        Попытка
            Почта.Подключиться(Профиль);
      
        Исключение
            Сообщить("Ошибка при подключении к серверу" + ОписаниеОшибки());
            Возврат;
        КонецПопытки;
    
        Сообщение = Новый ИнтернетПочтовоеСообщение;
        Сообщение.Отправитель = "aubalan@bk.ru";
        Сообщение.Получатели.Добавить("aubalan69@gmail.com");
        Сообщение.Тема = "Привет! Привет! Привет!";
        Сообщение.Тексты.Добавить("Сообщение отправлено с 1С",ТипТекстаПочтовогоСообщения.HTML);
        Почта.Послать(Сообщение);
        Почта.Отключиться();
    
        Сообщить("Сообщение отправлено")
    КонецПроцедуры
    Последнее редактирование: 4 апр 2014
  4. Tiger86
    Offline

    Tiger86 Модераторы Команда форума Модератор

    Регистрация:
    24 мар 2011
    Сообщения:
    6.407
    Симпатии:
    108
    Баллы:
    104
    AUBalan, оформляйте код...
  5. alexburn
    Offline

    alexburn Модераторы Команда форума Модератор

    Регистрация:
    5 янв 2009
    Сообщения:
    14.781
    Симпатии:
    509
    Баллы:
    204
    И что вписали в документ ? Этот код ???
  6. TopicStarter Overlay
    AUBalan
    Offline

    AUBalan

    Регистрация:
    25 мар 2014
    Сообщения:
    24
    Симпатии:
    0
    Баллы:
    1
    Это код в форме документа. В самой форме кнопка с командой "Команда1". Вот она не работает. Ошибка вышеописанная выскакивает.
  7. alexburn
    Offline

    alexburn Модераторы Команда форума Модератор

    Регистрация:
    5 янв 2009
    Сообщения:
    14.781
    Симпатии:
    509
    Баллы:
    204
    На сервер попробуйте перенести.
  8. TopicStarter Overlay
    AUBalan
    Offline

    AUBalan

    Регистрация:
    25 мар 2014
    Сообщения:
    24
    Симпатии:
    0
    Баллы:
    1
    Пробовал. Тоже самое...
  9. alexburn
    Offline

    alexburn Модераторы Команда форума Модератор

    Регистрация:
    5 янв 2009
    Сообщения:
    14.781
    Симпатии:
    509
    Баллы:
    204
    Может из-за того что файловая не работает ? Так-то в клиент-серверном такой метод отрабатывает.
  10. Tiger86
    Offline

    Tiger86 Модераторы Команда форума Модератор

    Регистрация:
    24 мар 2011
    Сообщения:
    6.407
    Симпатии:
    108
    Баллы:
    104
    Алекс, у меня и в файловой работает... правда процедуру с формированием Почты я вынесла в модуль с галочкой вызова Сервер. Но вариант базы файловый и все работает
    --- Объединение сообщений, 4 апр 2014 ---
    надо просто отладчиком посмотреть что там в переменной Почта
  11. alexburn
    Offline

    alexburn Модераторы Команда форума Модератор

    Регистрация:
    5 янв 2009
    Сообщения:
    14.781
    Симпатии:
    509
    Баллы:
    204
    Да я тоже думаю что в файловой должно работать. Может глюк какой. Отладчик что по этому поводу говорит ???
  12. TopicStarter Overlay
    AUBalan
    Offline

    AUBalan

    Регистрация:
    25 мар 2014
    Сообщения:
    24
    Симпатии:
    0
    Баллы:
    1
    Спасибо всем! В общем я так и не понял. Что-то с формой было. Сделал новую форму и все заработало.

Поделиться этой страницей