7.7 ЗиК рел.308 имущественные вычеты просто беда

Тема в разделе "Типовые решения "1С:Предприятие 7.7"", создана пользователем DmGreen, 28 мар 2011.

  1. TopicStarter Overlay
    DmGreen
    Offline

    DmGreen

    Регистрация:
    28 авг 2009
    Сообщения:
    24
    Симпатии:
    0
    Баллы:
    1
    ЗиК релиз 308 имущественные вычеты . Открываешь справку 1-НДФЛ выскакивает ошибка если дата вычета 01.01.11. Если кто решил проблему отпишитесь.
  2. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.523
    Симпатии:
    407
    Баллы:
    104
    Приведите скриншот ошибки...
    Для справки: 1-НДФЛ с 2011 года утратила свою силу.
    Форма теперь произвольная
  3. TopicStarter Overlay
    DmGreen
    Offline

    DmGreen

    Регистрация:
    28 авг 2009
    Сообщения:
    24
    Симпатии:
    0
    Баллы:
    1
    Дело даже не в форме 1-НДФЛ. При расчете НДФЛ исчисленного в журнале расчетов выскакивает ошибка.
    Просто наверное при формировании справки 1-НДФЛ, расчете НДФЛ используется Функция глСобратьДанныеДляНДФЛ2011 ошибка вот здесь
    Если (Сч > 1) и (Сч >= МесяцНачалаПримененияВычета) Тогда
    БазаДляИмВычетов = БазаБезУчетаИмущВычетов
    - ДоходыВычетыНалогиСотрудников.ПолучитьЗначение(НомерСтрокиСотрудника + МесяцНачалаПримененияВычета-1,3).ПолучитьЗначение(2);
    КонецЕсли;

    Если вычет с 01.01.11 тогда получить естественно 0 . Место нашел но запутался как исправить ошибку.
  4. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.523
    Симпатии:
    407
    Баллы:
    104
    приведите текст ошибки дословно
  5. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.523
    Симпатии:
    407
    Баллы:
    104
    Думаю собака здесь "порылась"...

    В соответствии с новой редакцией статьи 220 имущественный налоговый вычет предоставляется по доходам сотрудника, полученным начиная с месяца представления сотрудником заявления о получении такого вычета (а также подтверждения права на имущественный налоговый вычет, выданного налоговым органом).

    Т.е. вычет предоставляется НЕ РАНЕЕ даты подтвержления из ГНИ (справки). А эта справка выдается ТОЛЬКО после проверки 3-НДФЛ. Таким образом вы НИКАК не можете предоставить вычет сотруднику с 01.01.2011года.

    Поэтому код
    Код:
    НомерСтрокиСотрудника + МесяцНачалаПримененияВычета-1
    //где МесяцНачалаПримененияВычета = ДатаМесяц(ДатаНачалаВычета)
    
    
    
    править нет необходимости. Нужно внимательнее читать законодательство и следовать букве закона.
  6. TopicStarter Overlay
    DmGreen
    Offline

    DmGreen

    Регистрация:
    28 авг 2009
    Сообщения:
    24
    Симпатии:
    0
    Баллы:
    1
    Втом то и дело, что справки принесли в январе 2011г. До 308 все нормально, а вот после беда.
    Вот описание ошибки
    БазаДляИмВычетов = БазаБезУчетаИмущВычетов
    {Глобальный модуль(31547)}: Номер за пределами значения!
  7. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.523
    Симпатии:
    407
    Баллы:
    104
    В том числе и из налоговой???????????????

    К томуже судя по номеру строки у вас база не типовая (в типовой по этому номеру совершенно другая строка)....
  8. TopicStarter Overlay
    DmGreen
    Offline

    DmGreen

    Регистрация:
    28 авг 2009
    Сообщения:
    24
    Симпатии:
    0
    Баллы:
    1
    Да принесли уведомление на имущественные вычеты(311) и на вычеты по процентам(312).
    глобальная функция без изменений не переписывал. Вот полная строка БазаДляИмВычетов = БазаБезУчетаИмущВычетов
    - ДоходыВычетыНалогиСотрудников.ПолучитьЗначение(НомерСтрокиСотрудника + МесяцНачалаПримененияВычета-1,3).ПолучитьЗначение(2);


    вот кусок из функции
    Код:
    // 311
    БазаДляИмВычетов = 0;
    
    Вычет311 = СписокВычетовСотра.Получить("311");    
    Если ПустоеЗначение(Вычет311) = 0 Тогда
    
    ДатаНачалаВычета         = Вычет311.ПолучитьЗначение(1);
    ДатаОкончанияВычета      = Вычет311.ПолучитьЗначение(2);
    МесяцНачалаПримененияВычета = ДатаМесяц(ДатаНачалаВычета);
    Если (ДатаНачалаВычета <= КП) и (ДатаНачалаВычета >= НачГода(КП)) 
    и ((ДатаОкончанияВычета >= НП) или (ПустоеЗначение(ДатаОкончанияВычета) = 1))  Тогда
    РазмерВычетаНачальный311 = Вычет311.ПолучитьЗначение(3);
    Иначе
    РазмерВычетаНачальный311 = 0;
    КонецЕсли;
    Если (Сч > 1) и (Сч >= МесяцНачалаПримененияВычета) Тогда 
    БазаДляИмВычетов = БазаБезУчетаИмущВычетов
    - ДоходыВычетыНалогиСотрудников.ПолучитьЗначение(НомерСтрокиСотрудника + МесяцНачалаПримененияВычета-1,3).ПолучитьЗначение(2);
    КонецЕсли;
    
    Иначе
    РазмерВычетаНачальный311 = 0;
    КонецЕсли; 
    ПредоставленоИмущНаНачалоГода311 = Макс(РазмерВычетаНачальный311,0); 
    ИтогоПрименено311 = Мин(БазаДляИмВычетов,  ПредоставленоИмущНаНачалоГода311);
    ОстатокИмущественныхВычетов311 = Макс(РазмерВычетаНачальный311 - ИтогоПрименено311,0);
    
  9. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.523
    Симпатии:
    407
    Баллы:
    104
    Исправить можно так:
    Код:
    БазаДляИмВычетов = БазаБезУчетаИмущВычетов
    - ДоходыВычетыНалогиСотрудников.ПолучитьЗначение(НомерСтрокиСотрудника + ?(МесяцНачалаПримененияВычета=1,1,МесяцНачалаПримененияВычета-1),3).ПолучитьЗначение(2);
    
    
  10. TopicStarter Overlay
    DmGreen
    Offline

    DmGreen

    Регистрация:
    28 авг 2009
    Сообщения:
    24
    Симпатии:
    0
    Баллы:
    1
    Не прокатит пробовал немного по другому но суть одна. Если посмотреть в 1-НДФЛ январь месяц, не учитывается НДФЛ НАЧИСЛЕННЫЙ И НДФЛ УДЕРЖАННЫЙ соответственно все косит
  11. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.523
    Симпатии:
    407
    Баллы:
    104
    Да... Согласен был не прав. Значение д.б. нулевым.... Но опять же: Значит НомерСтрокиСотрудника=0 (когда выскакивает ошибка).
    0-1-1=0.
    Проверьте этот вариант (добавьте стрчкой выше "сообщить")

Поделиться этой страницей