7.7 ЗиК. Бригадный наряд.

Тема в разделе "Типовые решения "1С:Предприятие 7.7"", создана пользователем Santex, 7 окт 2009.

  1. TopicStarter Overlay
    Santex
    Offline

    Santex

    Регистрация:
    7 окт 2009
    Сообщения:
    1
    Симпатии:
    0
    Баллы:
    1
    Друзья, подскажите.

    Есть код:
    Код:
    Функция ЗаполнитьИтоговыйНаряд()
    Если Бригада.Выбран()=0 Тогда
    Предупреждение("Не выбрана бригада!");
    Возврат 0;
    КонецЕсли;
    
    ТЗ=СоздатьОбъект("ТаблицаЗначений");
    ТЗ.НоваяКолонка("Сотрудник","Справочник.Сотрудники");
    ТЗ.НоваяКолонка("Часы","Число",6,2);
    
    СуммаПоНаряду=0;
    УдалитьСтроки();
    
    Док=СоздатьОбъект("Документ.НарядБригадный");
    Док.ВыбратьДокументы();
    Пока Док.ПолучитьДокумент()=1 Цикл
    Если (Док.Проведен()=1) И (Док.Предварительный<>0) И (Док.Бригада=Бригада) Тогда
    СуммаПоНаряду=СуммаПоНаряду+Док.СуммаПоНаряду;
    Док.ВыбратьСтроки();
    Пока Док.ПолучитьСтроку()=1 Цикл
    ТЗ.НоваяСтрока();
    ТЗ.Сотрудник=Док.Сотрудник;
    ТЗ.Часы=Док.Часы;
    КонецЦикла;
    КонецЕсли;    
    КонецЦикла;
    ТЗ.Свернуть("Сотрудник","Часы");
    ТЗ.Сортировать("Сотрудник");
    ЗагрузитьТабличнуюЧасть(ТЗ);
    Возврат 0;
    КонецФункции
    
    
    
    Функция забирает все наряды что есть. Почему? он же должен забирать наряды только текущего периода расчеты зарплаты.

    [warn="Внимание!"]Пользуемся тегами....[/warn]
  2. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
    1) ЗиК у вас явно не стандартная, т.к. в нем присутствуют реквизиты Бригада и Предварительный
    2) Вы выбираете документы ЗА ВЕСЬ период:
    Код:
    Док.ВыбратьДокументы();
    
    
    нужно использовать:
    Код:
    Док.ВыбратьДокументы(НачДата,КонДата);
    
    
    но и этот подход не совсем верный, т.к. могут сущестовать записи сторнирования, перерасчета, расчета в другом периоде за указанный.

    Выбирайте данные из ЖурналаРасчета по ВидуРасчета в таблицу значений (документ создавший запись если нужно можно получить) - так вы точно получите правильный результат

Поделиться этой страницей