7.7 ЗиК 7.7 Расчет страховых взносов

Тема в разделе "Типовые решения "1С:Предприятие 7.7"", создана пользователем rumper, 7 фев 2014.

  1. TopicStarter Overlay
    rumper
    Offline

    rumper

    Регистрация:
    7 фев 2014
    Сообщения:
    5
    Симпатии:
    0
    Баллы:
    1
    Здравствуйте!

    релиз 343.

    за 2013 так :

    [​IMG]
    а вот за 2014 уже меню из печати пропало, собственно как вернуть?

    Заранее спасибо за ответы!
  2. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
    Обработка.РасчетСтраховыхВзносов
    строка 11385
    Код:
      
    //Если Год = 2014 Тогда
    //  ПечатьНачислениеВзносов2014();
    // Иначе
    
    МенюПечати = СоздатьОбъект("СписокЗначений");
    МенюПечати.ДобавитьЗначение("НачислениеВзносов","Начисленные страховые взносы за месяц");
    МенюПечати.ДобавитьЗначение("РСВ","Расчет страховых взносов"); 
    ИмяОтчета = "";
    Пункт = "";
    Если МенюПечати.ВыбратьЗначение(ИмяОтчета,,Пункт,,1) = 1 Тогда
    Если ИмяОтчета = "НачислениеВзносов" Тогда
    Если Год >=2014  Тогда
    ПечатьНачислениеВзносов2014();
    ИначеЕсли Год = 2011 Тогда
    ПечатьНачислениеВзносов2011();
    Иначе
    ПечатьНачислениеВзносов2012();
    КонецЕсли;
    Иначе
    Если Год = 2011 Тогда
    Печать2011();		
    ИначеЕсли Год = 2012 Тогда
    Печать2012();
    Иначе
    Печать2013();
    КонецЕсли;
    КонецЕсли;
    Иначе
    Возврат
    КонецЕсли;
    
    //  КонецЕсли;
    
    kajabaras нравится это.
  3. TopicStarter Overlay
    rumper
    Offline

    rumper

    Регистрация:
    7 фев 2014
    Сообщения:
    5
    Симпатии:
    0
    Баллы:
    1
    Большое спасибо!!! :n27:
  4. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
    Не за что. Обращайтесь
  5. TopicStarter Overlay
    rumper
    Offline

    rumper

    Регистрация:
    7 фев 2014
    Сообщения:
    5
    Симпатии:
    0
    Баллы:
    1
    поспешил... сейчас не считает и пишет "не указана дата рождения, невозможно получить ставку взносов в ПФР", хотя все даты есть.
  6. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
    приведите скрин или точный текст сообщения
  7. TopicStarter Overlay
    rumper
    Offline

    rumper

    Регистрация:
    7 фев 2014
    Сообщения:
    5
    Симпатии:
    0
    Баллы:
    1
  8. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
    ГМ. строка 17545

    Код:
    ДоходыВычетыНалогиСотрудников.НоваяКолонка("НомерШкалыВзносовПФР","Число",1,0); // не используется с 2014 года
    
    А в 13м это обязательное условие... Теперь же нет деления на страховую и накопительную. Значит и нет шкалы.
    А в 13м году это ошибка.
    Код:
       Если НомерШкалыВзносов = 0 Тогда
    глДобавитьСообщение(глОбработчикСообщений, СокрЛП(Сотрудник.Наименование)+": не указана дата рождения, невозможно получить ставку взносов в ПФР!", , Сотрудник, "ДатаРождения");
    Продолжить;
    ИначеЕсли НомерШкалыВзносов < 0 Тогда
    глДобавитьСообщение(глОбработчикСообщений, СокрЛП(Сотрудник.Наименование)+": неправильно указана дата рождения, невозможно получить ставку взносов в ПФР!", , Сотрудник, "ДатаРождения");
    Продолжить;
    КонецЕсли;
    
    Поэтому то и не пропускает. Разработчики не зря заглушку поставили... Нужно ждать новой РСВшки.
    kajabaras нравится это.
  9. TopicStarter Overlay
    rumper
    Offline

    rumper

    Регистрация:
    7 фев 2014
    Сообщения:
    5
    Симпатии:
    0
    Баллы:
    1
    Еще раз спасибо! будем ждать тогда нового релиза...
  10. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
    Не за что... Сам изначально тупанул про страховую/накопительную. Да и не думаю что 1Сники разродятся на что-то новое в ближайшем будущем.
  11. ny4ulo
    Offline

    ny4ulo

    Регистрация:
    10 фев 2014
    Сообщения:
    2
    Симпатии:
    0
    Баллы:
    1
    Извините, но что с этим делать то?? А то у бухов не работает и они паникуют =(
  12. ny4ulo
    Offline

    ny4ulo

    Регистрация:
    10 фев 2014
    Сообщения:
    2
    Симпатии:
    0
    Баллы:
    1
    Все сам разобрался =) Пере провел документ по начислению страховых взносов и все норм
  13. SkyMind
    Offline

    SkyMind

    Регистрация:
    11 май 2012
    Сообщения:
    16
    Симпатии:
    0
    Баллы:
    1
    А это не связано с тем, что какая-то новая форма должна быть, где всё вместе - и страховые взносы, и стаж?
    А то мне звонят, спрашивают насчет неё, а я что-то и не вижу ничего похожего. Знаете что-нибудь насчет этого?
  14. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
    Там же где и раньше. Расчет страховых взносов кн. печать
    kajabaras нравится это.
  15. aidx
    Offline

    aidx

    Регистрация:
    2 апр 2014
    Сообщения:
    3
    Симпатии:
    0
    Баллы:
    1
    А можно поподробнее для чайника - куда пихать второй код?

    В главном модуле строку 17545 нашел, а куда второй кусок кода воткнуть, чтобы 1с 77 не ругался на дни рождения - не знаю...
  16. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
    Ничего никуда пихать не нужно. Отчет работает верно
    aidx нравится это.
  17. aidx
    Offline

    aidx

    Регистрация:
    2 апр 2014
    Сообщения:
    3
    Симпатии:
    0
    Баллы:
    1
    я скрин могу показать, что не работает отчет, ругается на дни рождения....

    один в один как у автора темы румпера было... не знаю как победить...

    в итоге пустой отчет показывает, нет цифр...
  18. SkyMind
    Offline

    SkyMind

    Регистрация:
    11 май 2012
    Сообщения:
    16
    Симпатии:
    0
    Баллы:
    1
    Запустил "демо" релиза 7.70.344. Начислил там какие-то суммы за период "Январь 2014", страховые взносы насчитал.
    Открыл обработку "Расчет страховых взносов", нажал "Печать". Ничего не больше спросило, напечатало вот такую форму (скрин прикрепляю).
    Это что-то не то, просто суммы, без всяких распределений.
    Что я не так делаю?
    Скрин.jpg
  19. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
    Судя по писанию - все вы то делаете... Какое вам нужно распределение? Вы новую форму РСВ-1 хоть одним глазком видели?
    kajabaras нравится это.
  20. SkyMind
    Offline

    SkyMind

    Регистрация:
    11 май 2012
    Сообщения:
    16
    Симпатии:
    0
    Баллы:
    1
    Я вообще не знаю что за форма. Мне позвонили бухгалтера и сказали что надо будет сдавать отчет, в котором страховые взносы и стаж объеденены. Какая-то новая форма. Я потыкался в этой демке, ничего похожего нигде не нашел, вот и решил спросить здесь о чем вообще речь. Где искать эту форму. Или может ждать её надо, нет ещё.
    Но судя по всему есть, "РСВ-1", да? А где она формируется?

Поделиться этой страницей