7.7 Журнал

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 7.7"", создана пользователем Kugelfangg, 17 апр 2008.

  1. TopicStarter Overlay
    Kugelfangg
    Offline

    Kugelfangg Опытный в 1С

    Регистрация:
    13 фев 2008
    Сообщения:
    71
    Симпатии:
    0
    Баллы:
    26
    Здравствуйте.
    помогите пожалуйста разобратся где ошибка.
    описание:
    создал общий журнал с выборкой Посмотреть вложение 858
    выборка работает только по контрагенту,пытаюсь 2й день сделать по аналогии менеджера,не получается=(
    Код:
    Перем КонтрагентДляОтбора,МенеджерДляОтбора,АвторДляОтбора;
    Перем ДокументОснованиеЖурнала; 
    Перем ЗначениеВВидеСтроки;
    //////////////////////////////////////////////////////////
    Функция ПолучитьВремяДокументаЧислом(Док)
    Перем Ч,М,С;  
    Док.ПолучитьВремя(Ч,М,С);
    Возврат 3600*Ч+60*М+С;
    КонецФункции
    //////////////////////////////////////////////////////////
    Процедура УстановитьВремяДокументаЧислом(Док, Сек)
    Перем Ч,М,С;
    Ч=Цел(Сек/3600);
    Сек=Сек-Ч*3600;
    М=Цел(Сек/60);
    С=Сек-М*60;
    Док.УстановитьВремя(Ч,М,С);
    КонецПроцедуры 
    //////////////////////////////////////////////////////////  
    Процедура РедактироватьРеквизиты()
    
    ОткрытьФорму("Отчет.РедактированиеРеквизитовДокумента#" + ЗначениеВСтрокуВнутр(ТекущийДокумент), ТекущийДокумент);
    
    КонецПроцедуры 
    
    //////////////////////////////////////////////////////////
    Процедура ПриВыбореКонтрагента()   
    
    Если КонтрагентДляОтбора.Выбран()>0 Тогда
    УстановитьОтбор("Контр", КонтрагентДляОтбора);
    КонтрагентДляОтбора = КонтрагентДляОтбора.ТекущийЭлемент();
    Иначе
    УстановитьОтбор("ЗаявкаПокупателя");
    КонецЕсли;                                 
    
    КонецПроцедуры
    //////////////////////////////////////////////////////////
    Процедура ПриВыбореАвтора()  
    
    Если АвторДляОтбора.Выбран()>0 Тогда
    УстановитьОтбор("Автор", АвторДляОтбора);
    АвторДляОтбора = АвторДляОтбора.ТекущийЭлемент();
    
    Иначе
    УстановитьОтбор("ЗаявкаПокупателя");
    КонецЕсли;
    
    КонецПроцедуры   
    //////////////////////////////////////////////////////////
    Процедура ПриВыбореМенеджера()   
    
    Если МенеджерДляОтбора.Выбран()>0 Тогда
    УстановитьОтбор("Менеджер", МенеджерДляОтбора);
    МенеджерДляОтбора = МенеджерДляОтбора.ТекущийЭлемент();  
    
    Иначе
    УстановитьОтбор("ЗаявкаПокупателя");
    КонецЕсли;
    
    КонецПроцедуры      
    //////////////////////////////////////////////////////////
    Процедура ПриУстановкеБыстрогоОтбора()
    Перем ТекущДок;  
    
    Если ПустоеЗначение(ДокументОснованиеЖурнала) = 0  Тогда
    Возврат;
    КонецЕсли; 
    
    ТекущДок = ТекущийДокумент;
    ОтборПо  = ВидОтбора.ПолучитьЗначение(ВидОтбора.ТекущаяСтрока());
    
    
    Если ВидОтбора.ТекущаяСтрока() = 1 Тогда	// нет быстрого отбора
    
    ЗначениеВВидеСтроки = "";
    Форма.кнЗначение.Доступность(0);
    
    УстановитьОтбор("");
    ВидыОтбора("*");
    
    Иначе	// есть быстрый отбор
    
    Форма.кнЗначение.Доступность(1);
    
    Если ОтборПо = "по контрагенту" Тогда   
    ПриВыбореКонтрагента();
    ЗначениеВВидеСтроки=Строка(КонтрагентДляОтбора);
    
    ИначеЕсли ОтборПо = "по автору" Тогда
    ПриВыбореАвтора();                          
    ЗначениеВВидеСтроки=Строка(АвторДляОтбора);	
    
    ИначеЕсли ОтборПо = "по менеджеру" Тогда   
    ПриВыбореМенеджера();
    ЗначениеВВидеСтроки=Строка(МенеджерДляОтбора);
    
    КонецЕсли;
    
    ВидыОтбора("");
    
    КонецЕсли;    
    
    Попытка
    АктивизироватьОбъект(ТекущДок);
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/исключение')">	Исключение	</span>
    Сообщить(ОписаниеОшибки(),"!");
    КонецПопытки;	
    
    КонецПроцедуры   
    
    
    
    Процедура ПоКнопкеЗначение()  
    Перем ЗначениеИзменилось,СтароеЗначение,ВыбЗначение;
    
    
    ЗначениеИзменилось=0;     
    ОтборПо = ВидОтбора.ПолучитьЗначение(ВидОтбора.ТекущаяСтрока());
    
    
    Если ОтборПо = "по контрагенту" Тогда
    СтароеЗначение=КонтрагентДляОтбора;
    ВыбЗначение = СоздатьОбъект("Справочник.Контрагенты");
    Если ВыбЗначение.Выбрать("Выбор контрагента","Форма списка")=1 Тогда
    КонтрагентДляОтбора = ВыбЗначение;
    Если ВыбЗначение<>СтароеЗначение Тогда
    ЗначениеИзменилось=1;    
    КонецЕсли;	
    КонецЕсли;
    
    ИначеЕсли ОтборПо = "по менеджеру" Тогда
    СтароеЗначение=КонтрагентДляОтбора;
    ВыбЗначение = СоздатьОбъект("Справочник.Сотрудники");
    Если ВыбЗначение.Выбрать("Выбор менеджера","Форма списка")=1 Тогда
    КонтрагентДляОтбора = ВыбЗначение;
    Если ВыбЗначение<>СтароеЗначение Тогда
    ЗначениеИзменилось=1;    
    КонецЕсли;	
    КонецЕсли;
    
    ИначеЕсли ОтборПо = "по автору" Тогда
    СтароеЗначение=АвторДляОтбора;
    ВыбЗначение = СоздатьОбъект("Справочник.Сотрудники");
    Если ВыбЗначение.Выбрать("Выбор автора","Форма списка")=1 Тогда
    АвторДляОтбора = ВыбЗначение;
    Если ВыбЗначение<>СтароеЗначение Тогда
    ЗначениеИзменилось=1;    
    КонецЕсли;	
    КонецЕсли;
    КонецЕсли;
    
    Если ЗначениеИзменилось=1 Тогда
    ПриУстановкеБыстрогоОтбора();
    КонецЕсли;	
    
    КонецПроцедуры          
    
    Процедура ПриОбычномОткрытииЖурнала()
    
    КонтрагентДляОтбора =ВосстановитьЗначение("КонтрагентОтбораЖурнала");
    КонтрагентДляОтбора= ?(ПустоеЗначение(КонтрагентДляОтбора)=1, ПолучитьПустоеЗначение("Справочник.Контрагенты"), КонтрагентДляОтбора);
    
    АвторДляОтбора = ВосстановитьЗначение("АвторДляОтбораЖурнала");
    АвторДляОтбора= ?(ПустоеЗначение(АвторДляОтбора)=1, ПолучитьПустоеЗначение("Справочник.Сотрудники"), АвторДляОтбора);
    
    МенеджерДляОтбора =ВосстановитьЗначение("МенеджерОтбораЖурнала");
    МенеджерДляОтбора= ?(ПустоеЗначение(МенеджерДляОтбора)=1, ПолучитьПустоеЗначение("Справочник.Сотрудники"), МенеджерДляОтбора);
    
    
    КонецПроцедуры
    
    СписокДействий = СоздатьОбъект("СписокЗначений");
    СписокВидовДокументов = СоздатьОбъект("СписокЗначений");
    
    Для Счетчик = 1 по Метаданные.Документ() Цикл
    СписокВидовДокументов.ДобавитьЗначение(Метаданные.Документ(Счетчик).Идентификатор, Метаданные.Документ(Счетчик).Представление());
    КонецЦикла;
    СписокВидовДокументов.СортироватьПоПредставлению();    
    
    ВидОтбора.ДобавитьЗначение(" < отсутствует > "); 
    ВидОтбора.ДобавитьЗначение("по контрагенту");     
    ВидОтбора.ДобавитьЗначение("по автору");
    ВидОтбора.ДобавитьЗначение("по менеджеру");    
    
    КонтрагентДляОтбора = СоздатьОбъект("Справочник.Контрагенты");    
    АвторДляОтбора 		= СоздатьОбъект("Справочник.Сотрудники");
    МенеджерДляОтбора 	= СоздатьОбъект("Справочник.Сотрудники");
    
    

    Вложения:

    • жур.bmp
      Размер файла:
      788,4 КБ
      Просмотров:
      118
Похожие темы
  1. SCtYL
    Ответов:
    1
    Просмотров:
    368
Загрузка...

Поделиться этой страницей