8.х Журнал регистрации

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 8"", создана пользователем Svb, 20 ноя 2014.

  1. TopicStarter Overlay
    Svb
    Offline

    Svb Опытный в 1С Команда форума

    Регистрация:
    12 янв 2011
    Сообщения:
    980
    Симпатии:
    19
    Баллы:
    29
    Добрый день.
    Не могу понять как настроить журнал регистрации.
    Хочу, для начала, что в ЖР попадали только события о записи счета.
    Для этого использую две процедуры. Первую при начале работы системы - устанавливаю параметры ЖР, с помощью второй программно пишу запись в ЖР.
    Код:
    // Процедура осуществляет настройку параметров записи в журнал регистрации, с тем чтобы туда не писался всякий мусор,
    // а только нужные нам записи
    Процедура ИнициализироватьПараметрыЖурналаРегистрации() Экспорт
        // Настройки можно выполнить только с административными правами,
        // поэтому если прав нет, то пытаться даже не будем   
        Если РольДоступна("Администрирование") ИЛИ РольДоступна("ПолныеПрава") Тогда
       
            // Включим
            ИспользованиеСобытия = Новый ИспользованиеСобытияЖурналаРегистрации;
            ИспользованиеСобытия.Использование = Истина;
           
           
            УстановитьИспользованиеСобытияЖурналаРегистрации("_$Session$_.Finish",             ИспользованиеСобытия);
            УстановитьИспользованиеСобытияЖурналаРегистрации("_$Session$_.Start",             ИспользованиеСобытия);   
            УстановитьИспользованиеСобытияЖурналаРегистрации("_$Transaction$_.Rollback",    ИспользованиеСобытия);
           
           
            // Это вЫключим
            ИспользованиеСобытия = Новый ИспользованиеСобытияЖурналаРегистрации;
            ИспользованиеСобытия.Использование = Ложь;
            УстановитьИспользованиеСобытияЖурналаРегистрации("_$Session$_.Authentication",     ИспользованиеСобытия);
            УстановитьИспользованиеСобытияЖурналаРегистрации("_$Transaction$_.Begin",         ИспользованиеСобытия);
            УстановитьИспользованиеСобытияЖурналаРегистрации("_$Transaction$_.Commit",         ИспользованиеСобытия);
            УстановитьИспользованиеСобытияЖурналаРегистрации("_$Data$_.Post",                 ИспользованиеСобытия);
            УстановитьИспользованиеСобытияЖурналаРегистрации("_$Data$_.Update",             ИспользованиеСобытия);
           
        КонецЕсли;
     
    КонецПроцедуры
    
    Процедура ЗафиксироватьВЖурналеРегистрации(ОписаниеСобытия, ЭтотОбъект) Экспорт
       
            ЗаписьЖурналаРегистрации(
                ОписаниеСобытия + " " + ЭтотОбъект.Метаданные().Имя,
                УровеньЖурналаРегистрации.Информация,
                ЭтотОбъект.Метаданные(),
                ЭтотОбъект.Ссылка,
                "" + ЭтотОбъект.Контрагент.Наименование + "/" + ЭтотОбъект.Товары.Количество() + "/" + ЭтотОбъект.Товары.Итог("Количество") + "/" + ЭтотОбъект.Товары.Итог("СуммаСНДС"),
        );
    
    КонецПроцедуры
    
    Прилагаю скриншот настроек ЖР из конфигуратора.
    Снимок2.JPG
    Но в итоге в ЖР регистрации все-равно лезут записи транзакциях. Как их отключить?
    Снимок.JPG
  2. nomad_irk
    Offline

    nomad_irk Гуру в 1С

    Регистрация:
    20 окт 2008
    Сообщения:
    7.581
    Симпатии:
    717
    Баллы:
    204
    из СП:
    Svb нравится это.
  3. TopicStarter Overlay
    Svb
    Offline

    Svb Опытный в 1С Команда форума

    Регистрация:
    12 янв 2011
    Сообщения:
    980
    Симпатии:
    19
    Баллы:
    29
    Что-то не такого в СП у меня... А каким методом можно отключить это "барахло"? Зачем мне в ЖР регистрации инфа об этих транзакциях....
    --- Объединение сообщений, 21 ноя 2014 ---
    Запустил конфигуратор для платформы 8.3, там это ограничение упоминается. Но не написано как отключить.
  4. nomad_irk
    Offline

    nomad_irk Гуру в 1С

    Регистрация:
    20 окт 2008
    Сообщения:
    7.581
    Симпатии:
    717
    Баллы:
    204
    видимо никак, информация о номерах транзакций должна быть, предполагаю, что для потранзакционного восстановления данных.
  5. TopicStarter Overlay
    Svb
    Offline

    Svb Опытный в 1С Команда форума

    Регистрация:
    12 янв 2011
    Сообщения:
    980
    Симпатии:
    19
    Баллы:
    29
    Мне кажется 1С тут нашкодила... :)

Поделиться этой страницей