7.7 Журнал Расчетов!?

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 7.7"", создана пользователем alp, 25 янв 2010.

  1. TopicStarter Overlay
    alp
    Offline

    alp Опытный в 1С

    Регистрация:
    8 янв 2009
    Сообщения:
    432
    Симпатии:
    0
    Баллы:
    26
    Может ли запись журнала расчетов быть самостоятельная , без документа ?
  2. TopicStarter Overlay
    alp
    Offline

    alp Опытный в 1С

    Регистрация:
    8 янв 2009
    Сообщения:
    432
    Симпатии:
    0
    Баллы:
    26
    :unsure: То есть можно ли зделать запись из обработки , а не из Документа?
    Вот код
    Код:
    Процедура ЗагрузитьЗаписьЖР(Анализатор)
    ЖР=СоздатьОбъект("ЖурналРасчетов.Зарплата");
    ЖР.Новая();
    Для Сч=1 По Анализатор.КоличествоПодчиненных() цикл
    Узел=Анализатор.ПолучитьПодчиненныйПоНомеру(Сч);
    
    Если Узел.ПолучитьАтрибут("Имя")="Объект" Тогда
    Загрузить(Узел);
    Ссылка=Узел.ПолучитьАтрибут("Ссылка");
    ЖР.УстановитьРеквизит("Объект",СписокОбъектов.ПолучитьЗначение(Ссылка));
    ИначеЕсли Узел.ПолучитьАтрибут("Имя")="ДатаНачала" Тогда
    ЖР.УстановитьРеквизит("ДатаНачала",Узел.ПолучитьАтрибут("Значение"));
    ИначеЕсли Узел.ПолучитьАтрибут("Имя")="ДатаОкончания" Тогда
    ЖР.УстановитьРеквизит("ДатаОкончания",Узел.ПолучитьАтрибут("Значение"));	
    ИначеЕсли Узел.ПолучитьАтрибут("Имя")="Результат" Тогда
    ЖР.УстановитьРеквизит("Результат",Узел.ПолучитьАтрибут("Значение"));	
    КонецЕсли;
    КонецЦикла;
    ЖР.УстановитьРеквизит("ВидРасч",ВидРасчета.НачальноеСальдоОкругления);
    ЖР.УстановитьРеквизит("Фиксирована", 1);
    ЖР.УстановитьРеквизит("Рассчитана", 1);
    ЖР.Записать();
    
    КонецПроцедуры
    
    
    выдает такую ошибку:
    Не все обязательные реквизиты установлены при вводе новой записи журнала расчетов
    Помогите разобраться .
    :smile:
  3. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
    Список ОБЯЗАТЕЛЬНЫХ реквизитов для ЖР
    1. Объект (элемент справочника),для которого произведен расчет
    2 вид расчета
    3 докумнент , на основании которого введен расчет
    4 результат расчета
    5 время действия расчета
    6 период регистрации расчета в ЖР

    Так что из обработки заполнить МОЖНО, но должен быть какой-то "козел отпущения". Как вариант - заведите служебный документ

Поделиться этой страницей