7.7 Журнал книги покупок

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 7.7"", создана пользователем anton, 6 ноя 2009.

  1. TopicStarter Overlay
    anton
    Offline

    anton Опытный в 1С

    Регистрация:
    3 авг 2009
    Сообщения:
    187
    Симпатии:
    0
    Баллы:
    26
    Добрый день ребята подскажите куда как можно подставить вот это условие в процедуру всю голову сломал!!!

    Код:
    |Условие (((Экспорт = 1) и (Экспортные=1) и (Обычные=0))  или ((Экспорт = 0) и (Экспортные=0) и (Обычные=1))  или ((Экспортные=1) и (Обычные=1)));";
    
    пытался поставить в основной текст запроса а он мне ошибку выдает


    Код:
    Процедура ЖурналУчета()
    
    Таб.ИсходнаяТаблица("ЖурналУчета");
    УстановленныйОтбор = "";
    Если СтандартнаяФорма = 0 Тогда
    Если ВыбКонтрагент.Выбран() = 1 Тогда
    УстановленныйОтбор = "Установлен отбор по контрагенту: "+СокрЛП(ВыбКонтрагент.Наименование);
    КонецЕсли;
    КонецЕсли;
    Таб.ВывестиСекцию("Шапка");
    
    ТекстЗапроса = "Период с ДатаНачала по ДатаКонца;
    |ОбрабатыватьДокументы Все;
    |Обрабатывать НеПомеченныеНаУдаление;
    |Док = Документ.СчетФактураПолученный.ТекущийДокумент,
    |               Документ.ПоступлениеТоваров.ТекущийДокумент,
    |               Документ.ПоступлениеМатериалов.ТекущийДокумент,
    |               Документ.ПоступлениеОборудования.ТекущийДокумент,
    |               Документ.ПоступлениеОС.ТекущийДокумент,
    |               Документ.ПоступлениеНМА.ТекущийДокумент,
    |               Документ.УслугиСтороннихОрганизаций.ТекущийДокумент;		
    |ДокументОснование = Документ.СчетФактураПолученный.ДокументОприходования,
    |                    Документ.ПоступлениеТоваров.ТекущийДокумент,
    |                    Документ.ПоступлениеМатериалов.ТекущийДокумент,
    |	                 Документ.ПоступлениеОборудования.ТекущийДокумент,
    |                    Документ.ПоступлениеОС.ТекущийДокумент,
    |                    Документ.ПоступлениеНМА.ТекущийДокумент,
    |                    Документ.УслугиСтороннихОрганизаций.ТекущийДокумент;
    |Контрагент = Документ.СчетФактураПолученный.Контрагент,
    |             Документ.ПоступлениеТоваров.Контрагент,
    |             Документ.ПоступлениеМатериалов.Контрагент,
    |             Документ.ПоступлениеОборудования.Контрагент,
    |             Документ.ПоступлениеОС.Контрагент,
    |             Документ.ПоступлениеНМА.Контрагент,
    |             Документ.УслугиСтороннихОрганизаций.Контрагент;
    |Валюта = Документ.СчетФактураПолученный.Договор.ВалютаДоговора,
    |         Документ.ПоступлениеТоваров.Договор.ВалютаДоговора,
    |         Документ.ПоступлениеМатериалов.Договор.ВалютаДоговора,
    |         Документ.ПоступлениеОборудования.Договор.ВалютаДоговора,
    |         Документ.ПоступлениеОС.Договор.ВалютаДоговора,
    |         Документ.ПоступлениеНМА.Договор.ВалютаДоговора,
    |         Документ.УслугиСтороннихОрганизаций.Договор.ВалютаДоговора;
    |ДатаНомер = Документ.СчетФактураПолученный.ДатаНомерСчетаФактуры,
    |            Документ.ПоступлениеТоваров.ДатаНомерСчетаФактуры,
    |            Документ.ПоступлениеМатериалов.ДатаНомерСчетаФактуры,
    |            Документ.ПоступлениеОборудования.ДатаНомерСчетаФактуры,
    |            Документ.ПоступлениеОС.ДатаНомерСчетаФактуры,
    |            Документ.ПоступлениеНМА.ДатаНомерСчетаФактуры,
    |            Документ.УслугиСтороннихОрганизаций.ДатаНомерСчетаФактуры;
    |Всего = Документ.СчетФактураПолученный.Всего,
    |        Документ.ПоступлениеТоваров.Всего,
    |        Документ.ПоступлениеМатериалов.Всего,
    |        Документ.ПоступлениеОборудования.Всего,
    |        Документ.ПоступлениеОС.Всего,
    |        Документ.ПоступлениеНМА.Всего,
    |        Документ.УслугиСтороннихОрганизаций.Всего;";
    Если СтандартнаяФорма = 0 Тогда
    Если ГруппироватьПоКонтрагентам = 1 Тогда
    ТекстЗапроса = ТекстЗапроса + "
    |Группировка Контрагент;";
    КонецЕсли;
    КонецЕсли;
    ТекстЗапроса = ТекстЗапроса + "
    |Группировка Док;
    |Функция ВсегоПокупок = Сумма(Всего);";
    Если СтандартнаяФорма = 0 <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/тогда')">Тогда			</span>    
    Если ВыбКонтрагент.Выбран() = 1 Тогда
    ТекстЗапроса = ТекстЗапроса + "
    |Условие (Контрагент в ВыбКонтрагент);";
    КонецЕсли;
    КонецЕсли;
    ТекстЗапроса = ТекстЗапроса + "  
    |Условие (ПустоеЗначение(ДатаНомер) = 0);";	
    Запрос = СоздатьОбъект("Запрос");
    Если Запрос.Выполнить(ТекстЗапроса) = 0 Тогда
    Предупреждение("Невозможно выполнить запрос");
    Возврат;
    КонецЕсли;
    
    Ном = 1;
    Пока Запрос.Группировка(1) = 1 Цикл
    Если (СтандартнаяФорма = 1) или (ГруппироватьПоКонтрагентам = 0) Тогда
    Таб.ВывестиСекцию("Строка");
    Ном = Ном + 1;
    
    ИначеЕсли ГруппироватьПоКонтрагентам = 1 Тогда
    Если Запрос.Контрагент.ЭтоГруппа() = 1 Тогда
    Продолжить;
    КонецЕсли;
    Таб.ВывестиСекцию("Контрагент");
    Пока Запрос.Группировка(2) = 1 Цикл
    Таб.ВывестиСекцию("Строка");
    Ном = Ном + 1;
    КонецЦикла;
    КонецЕсли;
    КонецЦикла;
    
    ВерхнийКолонтитул = "Журнал учета полученных счетов-фактур ("+ПериодСтр(ДатаНачала, ДатаКонца)+")";
    НижнийКолонтитул = "Отчет сформирован "+ТекущаяДата()+" "+ТекущееВремя()+?(ПустоеЗначение(ИмяПользователя())=0,"  Пользователь: "+ИмяПользователя(),"");
    
    Таб.Опции(0,0,6,0, "Параметры печати журналы полученных счетов-фактур" );
    Таб.ОбластьПечати(2);
    Таб.ПовторятьПриПечатиСтроки(6, 6);
    Таб.ПараметрыСтраницы(1,,,,,,,,,1);
    Таб.ТолькоПросмотр(1);
    Таб.Показать("Журнал учета полученных счетов-фактур",""); 
    
    КонецПроцедуры // ЖурналУчета()
    
    
    Зарание огромное спасибо!
  2. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
    Выкладывай саму обработку - совершенно непонятно что за переменные и за что отвечают.
  3. TopicStarter Overlay
    anton
    Offline

    anton Опытный в 1С

    Регистрация:
    3 авг 2009
    Сообщения:
    187
    Симпатии:
    0
    Баллы:
    26
    Нужно что бы заработало условие отбора экспортные фактуры во время построение журнала!!!!

    А куда вставить условие ни как не допетрю..

    Вложения:

  4. TopicStarter Overlay
    anton
    Offline

    anton Опытный в 1С

    Регистрация:
    3 авг 2009
    Сообщения:
    187
    Симпатии:
    0
    Баллы:
    26
    парни ну что ни кто не подскажет как это реализовать просто у меня опыту общения с 1с маловать поэтому еще многого не понимаю как сделать, ... Может я вопрс как то не правельно задал????

Поделиться этой страницей