7.7 Журнал кассовых ордеров не выводит приход

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 7.7"", создана пользователем AD1986, 9 май 2012.

  1. TopicStarter Overlay
    AD1986
    Offline

    AD1986 Опытный в 1С

    Регистрация:
    8 фев 2011
    Сообщения:
    138
    Симпатии:
    0
    Баллы:
    26
    В журнале кассовых ордеров не вывод прход хотя расход выводит, в чем проблема не могу понять модуль прилогаеться, если не сложно подскажите..... Конфиг 1с Бухгалтерия юкола
    Код:
    //*******************************************
    // Процедура генерации запроса Сформировать.
    //
    Процедура Сформировать()
    Перем Запрос, ТекстЗапроса, Таб;
    //Создание объекта типа Запрос
    
    ТЗ = СоздатьОбъект("ТаблицаЗначений");
    ТЗ.НоваяКолонка("Назначение");
    ТЗ.НоваяКолонка("Сумма");
    
    Запрос = СоздатьОбъект("Запрос");
    Таб = СоздатьОбъект("Таблица");
    ТекстЗапроса =
    "//{{ЗАПРОС(Сформировать)
    |Период с ВыбНачПериода по ВыбКонПериода;";
    Если Приход=1 тогда
    Таб.ИсходнаяТаблица("Приход");
    
    ТекстЗапроса = ТекстЗапроса+"
    |Док = Документ.ПриходныйОрдер.ТекущийДокумент;
    |ФИО = Документ.ПриходныйОрдер.ПринятоОТ;";
    
    ИначеЕсли Приход=2 тогда
    Таб.ИсходнаяТаблица("Расход");
    
    ТекстЗапроса = ТекстЗапроса+"
    |Док = Документ.РасходныйОрдер.ТекущийДокумент;
    |ФИО = Документ.РасходныйОрдер.Выдать;";
    
    КонецЕсли;
    ТекстЗапроса = ТекстЗапроса+"
    |Группировка Док;
    |"//}}ЗАПРОС
    ;
    Если Запрос.Выполнить(ТекстЗапроса) = 0 Тогда
    Возврат;
    КонецЕсли;
    Пока Запрос.Группировка(1)=1 цикл
    Док=Запрос.Док;
    Если Док.КоличествоСтрок()=0 Тогда
    Если Док.Сумма=0 тогда
    Продолжить;
    КонецЕсли;
    Тз.НоваяСтрока();
    ТЗ.Назначение=Док.Назначение;
    ТЗ.Сумма=Док.Сумма;
    Иначе
    Док.ВыбратьСтроки();
    Пока Док.ПолучитьСтроку()=1 Цикл
    Если Док.СуммаНазн=0 тогда
    Продолжить;
    КонецЕсли;
    Тз.НоваяСтрока();
    ТЗ.Назначение=Док.ЦелНазн;
    ТЗ.Сумма=Док.СуммаНазн;
    КонецЦикла;
    КонецЕсли;
    КонецЦикла;
    
    ТЗ.Свернуть("Назначение","Сумма");
    
    Состояние("Заполнение выходной таблицы...");
    Таб.ВывестиСекцию("Шапка|Начало");
    ТЗ.ВыбратьСтроки();
    Пока ТЗ.ПолучитьСтроку()=1 цикл
    ВидОплаты=ТЗ.Назначение;
    Таб.ПрисоединитьСекцию("Шапка|ВидОплаты");
    КонецЦикла;
    Таб.ПрисоединитьСекцию("Шапка|Итог");
    обл=Таб.Область(3,1,3,3+ТЗ.КоличествоСтрок()+2);
    Обл.Объединить();
    обл=Таб.Область(4,1,4,3+ТЗ.КоличествоСтрок()+2);
    Обл.Объединить();
    обл=Таб.Область(6,3,6,3+ТЗ.КоличествоСтрок());
    Обл.Объединить();
    
    Пока Запрос.Группировка(1) = 1 Цикл
    Док=Запрос.Док;
    
    Таб.ВывестиСекцию("Строка|Начало");
    ТЗ.ВыбратьСтроки();
    Пока ТЗ.ПолучитьСтроку()=1 цикл
    Сумма1=0;
    Если (Док.КоличествоСтрок()=0) и (Док.Назначение=ТЗ.Назначение) Тогда
    Сумма1=Док.Сумма;
    Иначе
    Док.ВыбратьСтроки();
    Пока Док.ПОлучитьСтроку()=1 Цикл
    Если Док.ЦелНазн=ТЗ.Назначение Тогда
    Сумма1=Док.СуммаНазн;
    КонецЕсли;
    КонецЦикла;
    КонецЕсли;
    Таб.ПрисоединитьСекцию("Строка|ВидОплаты");
    КонецЦикла;
    ИтогоКО=Док.Сумма;
    Таб.ПрисоединитьСекцию("Строка|Итог");
    КонецЦикла;
    Таб.ВывестиСекцию("Итого|Начало");
    ТЗ.ВыбратьСтроки();
    Пока ТЗ.ПолучитьСтроку()=1 цикл
    Сумма1=ТЗ.Сумма;
    Таб.ПрисоединитьСекцию("Итого|ВидОплаты");
    КонецЦикла;
    ИтогоКО = ТЗ.Итог("Сумма");
    Таб.ПрисоединитьСекцию("Итого|Итог");
    // Вывод заполненной формы
    Таб.ТолькоПросмотр(1);
    Таб.Показать("Журнал "+?(Приход=1,"приходных","расходных")+" кассовых ордеров", "");
    КонецПроцедуры
    ВыбНачПериода=НачГода(НачалоПериодаБИ());
    ВыбКонПериода=КонецПериодаБИ();
    Приход=1;
  2. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
    Считаю что этого не достаточно. Выложите сам отчет

Поделиться этой страницей