7.7 Журнал Документов

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 7.7"", создана пользователем Natasha, 10 сен 2007.

  1. TopicStarter Overlay
    Natasha
    Offline

    Natasha

    Регистрация:
    6 сен 2007
    Сообщения:
    9
    Симпатии:
    0
    Баллы:
    1
    Журнал . Содержит документы Накладная и Счет-фактура. Реализовать в журнале «Накладные» отбор только тех документов, где присутствует выбранный в журнале Контрагент(справочник). Если Контрагент не указан – разные виды документов располагаются в журнале на разных слоях и переключение между слоями осуществляется с помощью закладок.
    Впрос : Как сделать выбор в основном слое?и как что бы при открытии журнала многострочная часть была пустой.
    В основном слое я сдклала -поле ввода "ВыбКонтрагент" (Справочник.Контрагент) и формула ПриВыбКонт()

    И в модуле:
    Процедура ПриОткрытии()
    Форма.ИспользоватьЗакладки(1);
    Форма.Закладки.ДобавитьЗначение("Основной");
    Форма.Закладки.ДобавитьЗначение("СчФактура");
    Форма.Закладки.ДобавитьЗначение("Накладная");
    КонецПроцедуры

    Процедура ПриВыбореЗакладки(Ном,Зн)
    Если Зн="Основной" Тогда
    //???
    ИначеЕсли Зн="СчФактура" Тогда
    УстановитьОтбор("СчётФактура");
    ИначеЕсли Зн="Накладная" Тогда
    УстановитьОтбор("Накладная");
    КонецЕсли;
    КонецПроцедуры
    Процедура ПриВыбКонт()
    Если ВыбКонтрагент = 0 Тогда
    УстановитьОтбор(?)//пустая форма
    Иначе
    УстановитьОтбор(?)//только тех документов, где присутствует выбранный в журнале Контрагент
    КонецПроцедуры
  2. рамиль
    Offline

    рамиль Опытный в 1С

    Регистрация:
    12 мар 2006
    Сообщения:
    595
    Симпатии:
    0
    Баллы:
    26

Поделиться этой страницей