8.х Журнал документов

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 8"", создана пользователем andrey-kkk, 16 июл 2007.

  1. TopicStarter Overlay
    andrey-kkk
    Offline

    andrey-kkk

    Регистрация:
    19 апр 2007
    Сообщения:
    12
    Симпатии:
    0
    Баллы:
    1
    День добрый, господа!

    Подскажите пожалуйста как определить количество строк т.е. документов в журнале документов?
    Элемент формы - табличное поле (ЖурналДокументовСписок).
  2. x_under
    Offline

    x_under Модераторы Команда форума Модератор

    Регистрация:
    25 апр 2007
    Сообщения:
    2.576
    Симпатии:
    13
    Баллы:
    29
    Наверное прийдется только через запрос. Выбирать все документы из журнала. а потом смотреть количество
  3. TopicStarter Overlay
    andrey-kkk
    Offline

    andrey-kkk

    Регистрация:
    19 апр 2007
    Сообщения:
    12
    Симпатии:
    0
    Баллы:
    1
    Необходимо, чтобы в форме показывалось количество документов в журнале, и изменялось при включении отбора по разным полям.
  4. 1010011010
    Offline

    1010011010 [1cworld]

    Регистрация:
    1 авг 2006
    Сообщения:
    582
    Симпатии:
    0
    Баллы:
    26
    в событии ПриВыводеСтроки(
    счетчик строк сделай и выводи
  5. TopicStarter Overlay
    andrey-kkk
    Offline

    andrey-kkk

    Регистрация:
    19 апр 2007
    Сообщения:
    12
    Симпатии:
    0
    Баллы:
    1
    А как мне определить, что строка последняя?
  6. dend
    Offline

    dend Опытный в 1С

    Регистрация:
    9 апр 2007
    Сообщения:
    175
    Симпатии:
    0
    Баллы:
    26
    Формируй запрос по отборам при обновлении отборов.
  7. TopicStarter Overlay
    andrey-kkk
    Offline

    andrey-kkk

    Регистрация:
    19 апр 2007
    Сообщения:
    12
    Симпатии:
    0
    Баллы:
    1
    т.е. все значения отбора подставлять в запрос?
  8. Эмин
    Offline

    Эмин Руководитель проектов

    Регистрация:
    25 май 2007
    Сообщения:
    1.178
    Симпатии:
    1
    Баллы:
    26
    На мой взгляд самый правильный вариант.

    Когда каждая строка выведется у счетчика будет финальное значение.

    Сделать так можно:
    ПриОткрытии - обнуление счетчика (сам счетчик - какая нибудь переменная, можно в модуле объявить как экспортную). Обнуление приджется сделать еще в нескольких процедурах.

    ПриВыводеСтроки()

    Код:
    Счетчик = Счетчик + 1;
    
    Заметим, что при выводе строки вызовется только по одному разу для каждой строки.
  9. TopicStarter Overlay
    andrey-kkk
    Offline

    andrey-kkk

    Регистрация:
    19 апр 2007
    Сообщения:
    12
    Симпатии:
    0
    Баллы:
    1
    Как определить, что оно "финальное"?
    Так же, мне надо определять количество строк при изменении отбора!
  10. Эмин
    Offline

    Эмин Руководитель проектов

    Регистрация:
    25 май 2007
    Сообщения:
    1.178
    Симпатии:
    1
    Баллы:
    26
    Зачем вам определять что оно финальное? Чтобы обновить счетчик? Выводите информацию о его изменении с каждой строкой.

    При изменении отбора метод автоматически сработает, вам нужно будет лишь обнулить счетчик (вот это можно будет попробовать сделать в ПриВыводеСтроки, если она первая).
  11. TopicStarter Overlay
    andrey-kkk
    Offline

    andrey-kkk

    Регистрация:
    19 апр 2007
    Сообщения:
    12
    Симпатии:
    0
    Баллы:
    1
    Совершенно верно...
    Где (при вызове какой процедуры) мне обнулять счетчик?
    .. или опять же как опрделить, что она первая?
    т.е. какое событие или вызов какой процедуры происходит между выводом последней строки и началом вывода снова первой при обновлении отбора скажем?
  12. Эмин
    Offline

    Эмин Руководитель проектов

    Регистрация:
    25 май 2007
    Сообщения:
    1.178
    Симпатии:
    1
    Баллы:
    26
    А отладчик вам на что - посмотрите по шагам какие процедуры вызываются и чем первая строка отличается от других.

    Вполне вероятно, что при выводе строки можно оценить сколько строк уже выведено через какой-нибудь метод Количество() и если Количество() = 0, то и обнулять.
  13. TopicStarter Overlay
    andrey-kkk
    Offline

    andrey-kkk

    Регистрация:
    19 апр 2007
    Сообщения:
    12
    Симпатии:
    0
    Баллы:
    1
    Если бы у объекта ТабличноеПоле было бы свойство или метод для определения количества строк - я бы вопрос не задавал. :unsure:
  14. Эмин
    Offline

    Эмин Руководитель проектов

    Регистрация:
    25 май 2007
    Сообщения:
    1.178
    Симпатии:
    1
    Баллы:
    26
    Тогда попробуйте запихнуть обнуление в событие ОбновлениеОтображения, кажется так.
  15. dend
    Offline

    dend Опытный в 1С

    Регистрация:
    9 апр 2007
    Сообщения:
    175
    Симпатии:
    0
    Баллы:
    26
    Афтор
    Вот тебе готовый код.
    Прикрути сюда еще критерии отбора...

    Процедура СообщитьКоличествоДокументовВСпискеПоОтборам(Кнопка)
    // Вставить содержимое обработчика.
    Запрос = Новый Запрос;

    УсловиеОтбора = "";
    Документ = СтрЗаменить(Строка(ТабличноеПоле1),"ДокументСписок.","");
    ФлагПервого = Истина;
    Индекс = 1;
    Для Каждого ЭлементОтбора Из ТабличноеПоле1.Отбор Цикл
    Если ЭлементОтбора.Использование Тогда
    Если НЕ ФлагПервого Тогда
    УсловиеОтбора = УсловиеОтбора + " И ";
    КонецЕсли;
    Индекс = Индекс + 1;
    УсловиеОтбора = УсловиеОтбора + ВернутьСтрокуВидаСравнения(ЭлементОтбора.ВидСравнения,ЭлементОтбора.Имя,ЭлементОтбора.Значение,ЭлементОтбора.ЗначениеС,ЭлементОтбора.ЗначениеПо,Индекс,Документ);
    Если СтрЧислоВхождений(Строка(ЭлементОтбора.ВидСравнения),"Интервал") > 0 Тогда

    ЛеваяГраница = ЭлементОтбора.ЗначениеС;
    ПраваяГраница = ЭлементОтбора.ЗначениеПо;

    Запрос.УстановитьПараметр("ЛеваяГраница" + Индекс,ЛеваяГраница);
    Запрос.УстановитьПараметр("ПраваяГраница" + Индекс,ПраваяГраница);

    Иначе
    Запрос.УстановитьПараметр("Параметр"+Индекс,ЭлементОтбора.Значение);
    КонецЕСли;

    ФлагПервого = Ложь;

    КонецЕсли;
    КонецЦикла;

    Запрос.Текст = "ВЫБРАТЬ
    | КОЛИЧЕСТВО(*) Как Количество
    |ИЗ
    | Документ." + Документ + " КАК Документ" +
    ?(УсловиеОтбора="",""," ГДЕ " + УсловиеОтбора);

    Выборка = Запрос.Выполнить().Выбрать();
    Выборка.Следующий();
    Сообщить(""+Выборка.Количество);
    Сообщить(Запрос.Текст);

    КонецПроцедуры

    Функция ВернутьСтрокуВидаСравнения(лВидСравнения,Наименование,Значение,ЗначениеС,ЗначениеПО,Индекс,Документ)

    Если лВидСравнения = ВидСравнения.Больше Тогда
    СтрокаСравнения = ""+Наименование +" > " + "&Параметр" + Индекс;

    ИначеЕсли лВидСравнения = ВидСравнения.БольшеИлиРавно Тогда
    СтрокаСравнения = ""+Наименование +" >= " + "&Параметр" + Индекс;

    ИначеЕсли лВидСравнения = ВидСравнения.ВИерархии Тогда
    СтрокаСравнения = ""+Наименование +" В ИЕРАРХИИ ("+"&Параметр" + Индекс + ")";

    ИначеЕсли лВидСравнения = ВидСравнения.ВСписке Тогда
    СтрокаСравнения = ""+Наименование +" В ("+"&Параметр" + Индекс+")";

    ИначеЕсли лВидСравнения = ВидСравнения.ВСпискеПоИерархии Тогда
    СтрокаСравнения = ""+Наименование +" В ИЕРАРХИИ ("+"&Параметр" + Индекс+")";

    ИначеЕсли лВидСравнения = ВидСравнения.Интервал Тогда
    СтрокаСравнения = "" + Наименование + " > " + "&ЛеваяГраница" + Индекс + " И " +
    Наименование + " < " + "&ПраваяГраница" + Индекс;


    ИначеЕсли лВидСравнения = ВидСравнения.ИнтервалВключаяГраницы Тогда

    СтрокаСравнения = "" + Наименование +" >= " + "&ЛеваяГраница" + Индекс + " И " +
    Наименование + " <= " + "&ПраваяГраница" + Индекс;

    ИначеЕсли лВидСравнения = ВидСравнения.ИнтервалВключаяНачало Тогда
    СтрокаСравнения = "" + Наименование+ " >= " + "&ЛеваяГраница" + Индекс + " И " +
    Наименование + " < " + "&ПраваяГраница" + Индекс;

    ИначеЕсли лВидСравнения = ВидСравнения.ИнтервалВключаяОкончание Тогда
    СтрокаСравнения = "" + Наименование + " > " + "&ЛеваяГраница" + Индекс + " И " +
    Наименование +" <= " + "&ПраваяГраница" + Индекс;

    ИначеЕсли лВидСравнения = ВидСравнения.Меньше Тогда
    СтрокаСравнения = ""+Наименование +" < " + "&Параметр" + Индекс;

    ИначеЕсли лВидСравнения = ВидСравнения.МеньшеИлиРавно Тогда
    СтрокаСравнения = ""+Наименование +" <= " + "&Параметр" + Индекс;

    ИначеЕсли лВидСравнения = ВидСравнения.НеВИерархии Тогда
    СтрокаСравнения = ""+Наименование +"НЕ В ИЕРАРХИИ ("+"&Параметр" + Индекс+")";

    ИначеЕсли лВидСравнения = ВидСравнения.НеВСписке Тогда
    СтрокаСравнения = ""+Наименование +"НЕ В ("+ "&Параметр" + Индекс+")";

    ИначеЕсли лВидСравнения = ВидСравнения.НеВСпискеПоИерархии Тогда
    СтрокаСравнения = ""+Наименование +"НЕ В ИЕРАРХИИ("+"&Параметр" + Индекс+")";

    ИначеЕсли лВидСравнения = ВидСравнения.НеРавно Тогда
    СтрокаСравнения = ""+Наименование +" <> " + "&Параметр" + Индекс;

    ИначеЕсли лВидСравнения = ВидСравнения.НеСодержит Тогда

    СтрокаСравнения = ""+Наименование +" НЕ ПОДОБНО %" + "&Параметр" + Индекс+"%";

    ИначеЕсли лВидСравнения = ВидСравнения.Равно Тогда
    СтрокаСравнения = ""+Наименование +" = " + "&Параметр" + Индекс

    ИначеЕсли лВидСравнения = ВидСравнения.Содержит Тогда
    СтрокаСравнения = ""+Наименование +" ПОДОБНО % "+"&Параметр" + Индекс + "%";

    КонецЕсли;

    Возврат СтрокаСравнения;

    КонецФункции


    В восьмерке есть язык запросов и его, по-возможности, всегда нужно использовать.
    Кроме того, этот механизм можно использовать для любого списка.
  16. TopicStarter Overlay
    andrey-kkk
    Offline

    andrey-kkk

    Регистрация:
    19 апр 2007
    Сообщения:
    12
    Симпатии:
    0
    Баллы:
    1
    Спаибо.... но у меня не список, а журнал документов, соответственно не один тип. Так что код на 100% не подходит. B)
    Но все равно спасибо. Я уже разобрался. :unsure:

    Вот мой код:

    Код:
        Запрос1 = Новый Запрос();
    
    ТекстОтбора = "";
    
    нп = 0;
    Для Каждого ЭлементНастройкиОтбора Из ЭлементыФормы.ЖурналДокументовСписок.НастройкаОтбора Цикл
    
    Если ЖурналДокументовСписок.Отбор[ЭлементНастройкиОтбора.Имя].Использование Тогда
    
    ВидСравненияЭлементаОтбора = ЖурналДокументовСписок.Отбор[ЭлементНастройкиОтбора.Имя].ВидСравнения;
    
    Если ВидСравненияЭлементаОтбора = ВидСравнения.Больше Тогда
    ТекстОтбора = ТекстОтбора + Символы.ПС + "    И угпЖурналТекущееСостояние." + ЭлементНастройкиОтбора.Имя + " > &ЗначениеПараметра" + Строка(нп);
    Запрос1.УстановитьПараметр("ЗначениеПараметра" + Строка(нп), ЖурналДокументовСписок.Отбор[ЭлементНастройкиОтбора.Имя].Значение);
    нп = нп + 1;
    ИначеЕсли ВидСравненияЭлементаОтбора = ВидСравнения.БольшеИлиРавно Тогда
    ТекстОтбора = ТекстОтбора + Символы.ПС + "    И угпЖурналТекущееСостояние." + ЭлементНастройкиОтбора.Имя + " >= &ЗначениеПараметра" + Строка(нп);
    Запрос1.УстановитьПараметр("ЗначениеПараметра" + Строка(нп), ЖурналДокументовСписок.Отбор[ЭлементНастройкиОтбора.Имя].Значение);
    нп = нп + 1;
    ИначеЕсли ВидСравненияЭлементаОтбора = ВидСравнения.ВИерархии Тогда
    ТекстОтбора = ТекстОтбора + Символы.ПС + "    И угпЖурналТекущееСостояние." + ЭлементНастройкиОтбора.Имя + " В ИЕРАРХИИ(&ЗначениеПараметра" + Строка(нп) + ")";
    Запрос1.УстановитьПараметр("ЗначениеПараметра" + Строка(нп), ЖурналДокументовСписок.Отбор[ЭлементНастройкиОтбора.Имя].Значение);
    нп = нп + 1;
    ИначеЕсли ВидСравненияЭлементаОтбора = ВидСравнения.ВСписке Тогда
    ТекстОтбора = ТекстОтбора + Символы.ПС + "    И угпЖурналТекущееСостояние." + ЭлементНастройкиОтбора.Имя + " В (&ЗначениеПараметра" + Строка(нп) + ")";
    Запрос1.УстановитьПараметр("ЗначениеПараметра" + Строка(нп), ЖурналДокументовСписок.Отбор[ЭлементНастройкиОтбора.Имя].Значение);
    нп = нп + 1;
    ИначеЕсли ВидСравненияЭлементаОтбора = ВидСравнения.ВСпискеПоИерархии Тогда
    ТекстОтбора = ТекстОтбора + Символы.ПС + "    И угпЖурналТекущееСостояние." + ЭлементНастройкиОтбора.Имя + " В ИЕРАРХИИ(&ЗначениеПараметра" + Строка(нп) + ")";
    Запрос1.УстановитьПараметр("ЗначениеПараметра" + Строка(нп), ЖурналДокументовСписок.Отбор[ЭлементНастройкиОтбора.Имя].Значение);
    нп = нп + 1;
    ИначеЕсли ВидСравненияЭлементаОтбора = ВидСравнения.Интервал Тогда
    ТекстОтбора = ТекстОтбора + Символы.ПС + "    И угпЖурналТекущееСостояние." + ЭлементНастройкиОтбора.Имя + " > &ЗначениеПараметра" + Строка(нп);
    ТекстОтбора = ТекстОтбора + Символы.ПС + "    И угпЖурналТекущееСостояние." + ЭлементНастройкиОтбора.Имя + " < &ЗначениеПараметра" + Строка(нп);
    Запрос1.УстановитьПараметр("ЗначениеПараметра" + Строка(нп), ЖурналДокументовСписок.Отбор[ЭлементНастройкиОтбора.Имя].ЗначениеС);
    Запрос1.УстановитьПараметр("ЗначениеПараметра" + Строка(нп), ЖурналДокументовСписок.Отбор[ЭлементНастройкиОтбора.Имя].ЗначениеПо);
    нп = нп + 1;
    ИначеЕсли ВидСравненияЭлементаОтбора = ВидСравнения.ИнтервалВключаяГраницы Тогда
    ТекстОтбора = ТекстОтбора + Символы.ПС + "    И угпЖурналТекущееСостояние." + ЭлементНастройкиОтбора.Имя + " >= &ЗначениеПараметра" + Строка(нп);
    ТекстОтбора = ТекстОтбора + Символы.ПС + "    И угпЖурналТекущееСостояние." + ЭлементНастройкиОтбора.Имя + " <= &ЗначениеПараметра" + Строка(нп);
    Запрос1.УстановитьПараметр("ЗначениеПараметра" + Строка(нп), ЖурналДокументовСписок.Отбор[ЭлементНастройкиОтбора.Имя].ЗначениеС);
    Запрос1.УстановитьПараметр("ЗначениеПараметра" + Строка(нп), ЖурналДокументовСписок.Отбор[ЭлементНастройкиОтбора.Имя].ЗначениеПо);
    нп = нп + 1;
    ИначеЕсли ВидСравненияЭлементаОтбора = ВидСравнения.ИнтервалВключаяНачало Тогда
    ТекстОтбора = ТекстОтбора + Символы.ПС + "    И угпЖурналТекущееСостояние." + ЭлементНастройкиОтбора.Имя + " >= &ЗначениеПараметра" + Строка(нп);
    ТекстОтбора = ТекстОтбора + Символы.ПС + "    И угпЖурналТекущееСостояние." + ЭлементНастройкиОтбора.Имя + " < &ЗначениеПараметра" + Строка(нп);
    Запрос1.УстановитьПараметр("ЗначениеПараметра" + Строка(нп), ЖурналДокументовСписок.Отбор[ЭлементНастройкиОтбора.Имя].ЗначениеС);
    Запрос1.УстановитьПараметр("ЗначениеПараметра" + Строка(нп), ЖурналДокументовСписок.Отбор[ЭлементНастройкиОтбора.Имя].ЗначениеПо);
    нп = нп + 1;
    ИначеЕсли ВидСравненияЭлементаОтбора = ВидСравнения.ИнтервалВключаяОкончание Тогда
    ТекстОтбора = ТекстОтбора + Символы.ПС + "    И угпЖурналТекущееСостояние." + ЭлементНастройкиОтбора.Имя + " > &ЗначениеПараметра" + Строка(нп);
    ТекстОтбора = ТекстОтбора + Символы.ПС + "    И угпЖурналТекущееСостояние." + ЭлементНастройкиОтбора.Имя + " <= &ЗначениеПараметра" + Строка(нп);
    Запрос1.УстановитьПараметр("ЗначениеПараметра" + Строка(нп), ЖурналДокументовСписок.Отбор[ЭлементНастройкиОтбора.Имя].ЗначениеС);
    Запрос1.УстановитьПараметр("ЗначениеПараметра" + Строка(нп), ЖурналДокументовСписок.Отбор[ЭлементНастройкиОтбора.Имя].ЗначениеПо);
    нп = нп + 1;
    ИначеЕсли ВидСравненияЭлементаОтбора = ВидСравнения.Меньше Тогда
    ТекстОтбора = ТекстОтбора + Символы.ПС + "    И угпЖурналТекущееСостояние." + ЭлементНастройкиОтбора.Имя + " < &ЗначениеПараметра" + Строка(нп);
    Запрос1.УстановитьПараметр("ЗначениеПараметра" + Строка(нп), ЖурналДокументовСписок.Отбор[ЭлементНастройкиОтбора.Имя].Значение);
    нп = нп + 1;
    ИначеЕсли ВидСравненияЭлементаОтбора = ВидСравнения.МеньшеИлиРавно Тогда
    ТекстОтбора = ТекстОтбора + Символы.ПС + "    И угпЖурналТекущееСостояние." + ЭлементНастройкиОтбора.Имя + " <= &ЗначениеПараметра" + Строка(нп);
    Запрос1.УстановитьПараметр("ЗначениеПараметра" + Строка(нп), ЖурналДокументовСписок.Отбор[ЭлементНастройкиОтбора.Имя].Значение);
    нп = нп + 1;
    ИначеЕсли ВидСравненияЭлементаОтбора = ВидСравнения.НеВИерархии Тогда
    ТекстОтбора = ТекстОтбора + Символы.ПС + "    И (НЕ угпЖурналТекущееСостояние." + ЭлементНастройкиОтбора.Имя + " В ИЕРАРХИИ(&ЗначениеПараметра" + Строка(нп) + "))";
    Запрос1.УстановитьПараметр("ЗначениеПараметра" + Строка(нп), ЖурналДокументовСписок.Отбор[ЭлементНастройкиОтбора.Имя].Значение);
    нп = нп + 1;
    ИначеЕсли ВидСравненияЭлементаОтбора = ВидСравнения.НеВСписке Тогда
    ТекстОтбора = ТекстОтбора + Символы.ПС + "    И (НЕ угпЖурналТекущееСостояние." + ЭлементНастройкиОтбора.Имя + " В (&ЗначениеПараметра" + Строка(нп) + "))";
    Запрос1.УстановитьПараметр("ЗначениеПараметра" + Строка(нп), ЖурналДокументовСписок.Отбор[ЭлементНастройкиОтбора.Имя].Значение);
    нп = нп + 1;
    ИначеЕсли ВидСравненияЭлементаОтбора = ВидСравнения.НеВСпискеПоИерархии Тогда
    ТекстОтбора = ТекстОтбора + Символы.ПС + "    И (НЕ угпЖурналТекущееСостояние." + ЭлементНастройкиОтбора.Имя + " В ИЕРАРХИИ(&ЗначениеПараметра" + Строка(нп) + "))";
    Запрос1.УстановитьПараметр("ЗначениеПараметра" + Строка(нп), ЖурналДокументовСписок.Отбор[ЭлементНастройкиОтбора.Имя].Значение);
    нп = нп + 1;
    ИначеЕсли ВидСравненияЭлементаОтбора = ВидСравнения.НеРавно Тогда
    ТекстОтбора = ТекстОтбора + Символы.ПС + "    И угпЖурналТекущееСостояние." + ЭлементНастройкиОтбора.Имя + " <> &ЗначениеПараметра" + Строка(нп);
    Запрос1.УстановитьПараметр("ЗначениеПараметра" + Строка(нп), ЖурналДокументовСписок.Отбор[ЭлементНастройкиОтбора.Имя].Значение);
    нп = нп + 1;
    ИначеЕсли ВидСравненияЭлементаОтбора = ВидСравнения.НеСодержит Тогда
    ТекстОтбора = ТекстОтбора + Символы.ПС + "    И (НЕ угпЖурналТекущееСостояние." + ЭлементНастройкиОтбора.Имя + " ПОДОБНО &ЗначениеПараметра" + Строка(нп) + ")";
    Запрос1.УстановитьПараметр("ЗначениеПараметра" + Строка(нп), ЖурналДокументовСписок.Отбор[ЭлементНастройкиОтбора.Имя].Значение);
    нп = нп + 1;
    ИначеЕсли ВидСравненияЭлементаОтбора = ВидСравнения.Равно Тогда
    ТекстОтбора = ТекстОтбора + Символы.ПС + "    И угпЖурналТекущееСостояние." + ЭлементНастройкиОтбора.Имя + " = &ЗначениеПараметра" + Строка(нп);
    Запрос1.УстановитьПараметр("ЗначениеПараметра" + Строка(нп), ЖурналДокументовСписок.Отбор[ЭлементНастройкиОтбора.Имя].Значение);
    нп = нп + 1;
    ИначеЕсли ВидСравненияЭлементаОтбора = ВидСравнения.Содержит Тогда
    ТекстОтбора = ТекстОтбора + Символы.ПС + "    И угпЖурналТекущееСостояние." + ЭлементНастройкиОтбора.Имя + " ПОДОБНО &ЗначениеПараметра" + Строка(нп);
    Запрос1.УстановитьПараметр("ЗначениеПараметра" + Строка(нп), ЖурналДокументовСписок.Отбор[ЭлементНастройкиОтбора.Имя].Значение);
    нп = нп + 1;
    КонецЕсли;
    
    КонецЕсли;
    
    КонецЦикла;
    
    Если ТекстОтбора <> "" Тогда
    ТекстОтбора = "ГДЕ" + Символы.ПС + "    " + Сред(ТекстОтбора, 8);
    КонецЕсли;
    
    ТекстЗапроса =
    "ВЫБРАТЬ
    |    угпЖурналТекущееСостояние.Ссылка
    |ИЗ
    |    ЖурналДокументов.угпЖурналТекущееСостояние КАК угпЖурналТекущееСостояние"
    + Символы.ПС + ТекстОтбора;
    
    Запрос1.Текст = ТекстЗапроса;
    Выборка = Запрос1.Выполнить().Выбрать();
    
    КоличествоСтрок = Выборка.Количество();
    

Поделиться этой страницей