8.х Здравствуйте! помогите решить задачу

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 8"", создана пользователем nwo666, 8 янв 2020.

  1. nbIpKuH_BaH9I
    Online

    nbIpKuH_BaH9I Модераторы Команда форума Модератор

    Регистрация:
    16 сен 2009
    Сообщения:
    8.125
    Симпатии:
    550
    Баллы:
    204
    Мне очень интересно зачем Вам дают такие задачи. Расскажите свою историю, может мы вам что-нибудь посоветуем.
    --- Объединение сообщений, 14 янв 2020 ---
    Да, оперативный учет. Номер задачи назвать не могу. Но точно не в первых такая задача.
  2. TopicStarter Overlay
    nwo666
    Offline

    nwo666

    Регистрация:
    8 янв 2020
    Сообщения:
    18
    Симпатии:
    0
    Баллы:
    1
    История такая.
    На 1с подсел недавно, за практическую часть - буквально с середины декабря 2019.
    Учу сам. Экзамен на профа по платформе сдал так же в декабре.

    Это задание мне прислали из одной очень известной 1с:франчайзи.

    Дело было так.
    Два этапа собеседования прошел. Всё норм.
    Прислали тестовое задание. Но почему именно по уровню спеца я не понял?

    Основную часть я сделал за один день, без кнопки "Заполнить", и отправил.

    Мне написали, что нужно кнопку "Заполнить" доделать, и фифо, так же доделать, и отправить.

    Но, так как опыта нет. Я сделал вместо кнопки "Заполнить" ввод на основании, и отправил. Естественно фифо я так и не смог сделать.

    Теперь уже больше 10 дней молчат.
    Сам не звоню.
    Но задача засосала)
    Вот параллельно откликаюсь на вакансии, и ковыряюсь в этом задании. Также смотрю видеоуроки и почитываю Практическое пособие разработчика и Язык запросов.

    Ну, буду считать, что это задание - начало подготовки к спецу по платформе)
    --- Объединение сообщений, 14 янв 2020 ---
    Всё сразу запомнить и освоить невозможно)
    --- Объединение сообщений, 14 янв 2020 ---
    Модератор, а можно как-то процедуру ОбработкаЗаполнения (ввод на основании) модифицировать, и вставить в обработчик кнопки"Заполнить"?

    Я хочу хотя бы увидеть что что-то происходит на форме)

    Раньше пробовал так:

    Код:
    &НаКлиенте
    Процедура Заполнить(ДанныеЗаполнения)
        Если ТипЗнч(ДанныеЗаполнения) = Тип("ДокументСсылка.БанковскаяВыписка") Тогда
            //Заполнение шапки
            Клиент = ДанныеЗаполнения.Клиент;
            Склад = ДанныеЗаполнения.Склад;
            Для Каждого ТекСтрокаЗаказы Из ДанныеЗаполнения.Заказы Цикл
                НоваяСтрока = Объект.Заказы.Добавить();
                НоваяСтрока.Количество = ТекСтрокаЗаказы.Количество;
                НоваяСтрока.Сумма = ТекСтрокаЗаказы.Сумма;
                НоваяСтрока.Товар = ТекСтрокаЗаказы.Товар;
                НоваяСтрока.Цена = ТекСтрокаЗаказы.Цена;
            КонецЦикла;
        КонецЕсли;
    
    КонецПроцедуры
    Но не идет.
    Последнее редактирование модератором: 14 янв 2020
  3. TopicStarter Overlay
    nwo666
    Offline

    nwo666

    Регистрация:
    8 янв 2020
    Сообщения:
    18
    Симпатии:
    0
    Баллы:
    1
    С кнопкой "Заполнить" вопрос надо решить. хотя бы на подобии "ОбработкиЗаполнения".

    Мне просто нужно увидеть что чем-то эта форма, или хотя бы реквизит формы заполнился бы)
  4. nbIpKuH_BaH9I
    Online

    nbIpKuH_BaH9I Модераторы Команда форума Модератор

    Регистрация:
    16 сен 2009
    Сообщения:
    8.125
    Симпатии:
    550
    Баллы:
    204
    Можно многое сделать. Я просто не знаю как вам объяснить еще. Другими словами больше не могу. К сожалению, у вас нет минимального набора знаний, чтобы начать выполнять подобного рода задачи. Практическое пособие разработчика вам даст хороший старт. Но просто читать ее недостаточно. Нужно выполнять задания, что дает автор. На счет спеца, я думаю пока очень рано говорить. Курсы по 1с.рф очень хорошо преподносят материал. Пройдите обучение у них.
  5. TopicStarter Overlay
    nwo666
    Offline

    nwo666

    Регистрация:
    8 янв 2020
    Сообщения:
    18
    Симпатии:
    0
    Баллы:
    1
    Приветствую, Модератор!

    Изменил код

    Код:
    &НаСервере
    Функция ПолучитьТоварыЗаказаНаСервере() 
        Запрос = Новый Запрос;
        Запрос.Текст = "ВЫБРАТЬ
                        |   БанковскаяВыпискаЗаказы.Товар,
                        |   БанковскаяВыпискаЗаказы.Количество,
                        |    БанковскаяВыпискаЗаказы.Цена,
                        |   БанковскаяВыпискаЗаказы.Сумма
                        |ИЗ
                        |    Документ.БанковскаяВыписка.Заказы КАК БанковскаяВыпискаЗаказы
                        |ГДЕ
                        |    БанковскаяВыпискаЗаказы.Ссылка = &Документ";
                        //|    БанковскаяВыпискаЗаказы.Колеровка = ИСТИНА
                        //|    И БанковскаяВыпискаЗаказы.ВариантОбеспечения = ЗНАЧЕНИЕ(Перечисление.ВариантыОбеспечения.Требуется)
                        //|    И БанковскаяВыпискаЗаказы.Ссылка = &БанковскаяВыпискаЗаказы
                        //|    ";
        Запрос.УстановитьПараметр("Документ", "&Ссылка.Документ"); 
        РезультатЗапроса =  Запрос.Выполнить();
          //РезультатЗапроса = Запрос.Выполнить().Выгрузить();
        Если РезультатЗапроса.Пустой() Тогда
            сообщить("Нечего добавлять!");
        Иначе
            Результат = РезультатЗапроса.Выгрузить();
            Объект.Заказы.Очистить();
            Для каждого Стр из Результат Цикл
                НоваяСтрока  = Объект.Заказы.Добавить();
                НоваяСтрока.Товар = Стр.Товар;
                НоваяСтрока.Количество = Стр.Количество;
                НоваяСтрока.Цена = Стр.Цена;
                НоваяСтрока.Сумма = Стр.Сумма;
            КонецЦикла;
        Конецесли
    
    КонецФункции
    
    &НаКлиенте
    Процедура Заполнить()
        ПолучитьТоварыЗаказаНаСервере(); 
    КонецПроцедуры
    Ошибок не выдает.

    В режиме Предприятия выдал сообщение: "Нечего добавлять!"

    Скрин с сообщением: https://yadi.sk/i/CJyWW3pKX-z88g

    Что мне дальше делать, чтобы данные добавились?

    Или мне надо сначала организовать партионный учет, и только потом доделывать заполнение?
    Последнее редактирование модератором: 15 янв 2020
  6. TopicStarter Overlay
    nwo666
    Offline

    nwo666

    Регистрация:
    8 янв 2020
    Сообщения:
    18
    Симпатии:
    0
    Баллы:
    1
  7. nbIpKuH_BaH9I
    Online

    nbIpKuH_BaH9I Модераторы Команда форума Модератор

    Регистрация:
    16 сен 2009
    Сообщения:
    8.125
    Симпатии:
    550
    Баллы:
    204
    Я Вам уже говорил. В конкретно Вашем примере не нужен партионный учет. Если Вы не понимаете, что написано в этой строке
    Код:
    Запрос.УстановитьПараметр("Документ", "&Ссылка.Документ");
    то задачка вам пока не по зубам.
  8. TopicStarter Overlay
    nwo666
    Offline

    nwo666

    Регистрация:
    8 янв 2020
    Сообщения:
    18
    Симпатии:
    0
    Баллы:
    1
    Скажите что вписать туда?
  9. nbIpKuH_BaH9I
    Online

    nbIpKuH_BaH9I Модераторы Команда форума Модератор

    Регистрация:
    16 сен 2009
    Сообщения:
    8.125
    Симпатии:
    550
    Баллы:
    204
  10. TopicStarter Overlay
    nwo666
    Offline

    nwo666

    Регистрация:
    8 янв 2020
    Сообщения:
    18
    Симпатии:
    0
    Баллы:
    1
    Я табличную часть хочу заполнить, причем тут реквизит?
    --- Объединение сообщений, 15 янв 2020 ---
    Я это по примерам делаю. У других я не увидел, чтобы указывали реквизиты
  11. nbIpKuH_BaH9I
    Online

    nbIpKuH_BaH9I Модераторы Команда форума Модератор

    Регистрация:
    16 сен 2009
    Сообщения:
    8.125
    Симпатии:
    550
    Баллы:
    204
    Любопытно, с какого раза Вы поймете это.
    Еще раз.
    Вы в запросе устанавливаете параметр вот в этой строке
    Код:
    Запрос.УстановитьПараметр("Документ", "&Ссылка.Документ");
    "Документ" - это имя параметра в тексте запроса
    "&Ссылка.Документ" - это значение параметра.
    Код:
    |ГДЕ БанковскаяВыпискаЗаказы.Ссылка = &Документ";
    В этой секции запроса Вы пытаетесь отобрать по ссылке.
    А передаете строку. Результат вашего запроса ВСЕГДА будет пустой. Если Вы не понимаете этого, то мой вам совет такой.
    Изучите для начала эту книгу.
    https://www.1c-interes.ru/catalog/all6964/17612400/
    Затем эту
    https://online.1c.ru/books/book/17269783/

    После этого только станет ясно, что изучить дальше.
  12. TopicStarter Overlay
    nwo666
    Offline

    nwo666

    Регистрация:
    8 янв 2020
    Сообщения:
    18
    Симпатии:
    0
    Баллы:
    1
    Спасибо!
    --- Объединение сообщений, 15 янв 2020 ---
    Эти книги у меня есть.
    Я их почитываю.
    Все равно туго идет.
    Последнее редактирование: 15 янв 2020