8.х ОБМЕН Зависает 1С8 при автоматическом обмене. Помогите

Тема в разделе "Обмен данными в "1С:Предприятие 8"", создана пользователем alex-79, 18 фев 2010.

  1. TopicStarter Overlay
    alex-79
    Offline

    alex-79 Опытный в 1С

    Регистрация:
    21 сен 2006
    Сообщения:
    643
    Симпатии:
    1
    Баллы:
    29
    Добрый день! Не знаю в какой ветке форума задать вопрос. Для обмена с центральным узлом в подчинённом узле я написал скрипт на WSH.
    Параметр "/CEXIT" - это выход из 1С в режиме предприятия после загрузки/выгрузки.

    Запускаю скрипт в течении дня работает нормально. Если скрипт выполняется автоматически ночью, то на утро в процессах висит 1C, но окна на экране не видно. Причём висит на строке

    WshShell.Run """C:\Program Files (x86)\1cv81\bin\1CV8.EXE"" ENTERPRISE /S 192.168.1.2\Pronto8 /N Загрузка /P ---- /DisableStartupMessages /CEXIT",1, TRUE

    Скрипт запускается на сервере. На сервере установлена Windows 2003 Std. Сервер не является контроллером домена. Сеть не является доменной. В журналах событий Windows никаких ошибок нет.

    Платформа 1С8: 1С:Предприятие 8.1 (8.1.15.14)
    Конфигурация базы: Бухгалтерия предприятия, редакция 1.6 (1.6.23.2)

    Я не знаю как исправить это.

    Процедура обработки закрытия 1С после обмена.

    Код:
    
    Процедура ПроверкаОбменаДанными() Экспорт
    
    Если глЗначениеПеременной("глОбработкаАвтоОбменДанными") = Неопределено Тогда
    Возврат;
    КонецЕсли;		
    
    ОтключитьОбработчикОжидания("ПроверкаОбменаДанными");
    
    // проводим обмен данными
    глЗначениеПеременной("глОбработкаАвтоОбменДанными").ПровестиОбменДанными(); 
    Если ПараметрЗапуска="EXIT"	Тогда   
    ЗавершитьРаботуСистемы(Ложь);
    КонецЕсли;
    ПодключитьОбработчикОжидания("ПроверкаОбменаДанными", глЗначениеПеременной("глКоличествоСекундОпросаОбмена"));
    
    КонецПроцедуры
    
    

    Код скрипта

    Set WshShell=CreateObject("WScript.Shell")
    WshShell.Run """C:\Program Files (x86)\1cv81\bin\1CV8.EXE"" ENTERPRISE /S 192.168.1.2\Pronto8 /N Загрузка /P ---- /DisableStartupMessages /CEXIT",1, TRUE
    WScript.Sleep 60000
    WshShell.Run """C:\Program Files (x86)\1cv81\bin\1CV8.EXE"" CONFIG /S 192.168.1.2\Pronto8 /N Загрузка /P ------ /UpdateDBCfg /DisableStartupMessages",1,TRUE
    WScript.Sleep 60000
    WshShell.Run """C:\Program Files (x86)\1cv81\bin\1CV8.EXE"" ENTERPRISE /S 192.168.1.2\Pronto8 /N Загрузка /P ----- /DisableStartupMessages /CEXIT",1, TRUE
    WScript.Sleep 60000
    WshShell.Run """C:\Program Files (x86)\1cv81\bin\1CV8.EXE"" ENTERPRISE /S 192.168.1.2\Pronto8 /N Выгрузка /P jhbjycnfh /DisableStartupMessages /CEXIT",1, TRUE

Поделиться этой страницей