7.7 Запутался с поиском элемента

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 7.7"", создана пользователем n_h, 7 фев 2011.

  1. TopicStarter Overlay
    n_h
    Offline

    n_h Опытный в 1С

    Регистрация:
    21 янв 2011
    Сообщения:
    59
    Симпатии:
    0
    Баллы:
    26
    Сейчас пробую вот так
    Код:
    Процедура Тест();
    Спр = СоздатьОбъект ("Справочник.Позиция");
    ТЗ = СоздатьОбъект ("ТаблицаЗначений");
    ТЗ1 = СоздатьОбъект ("ТаблицаЗначений");
    ТЗ.НоваяКолонка("Продукция"); 
    ТЗ.НоваяКолонка("Количество"); 
    ТЗ.НоваяКолонка("Дата"); 
    ТЗ.НоваяКолонка("Позиция");
    ТЗ1.НоваяКолонка("Продукция"); 
    ТЗ1.НоваяКолонка("Количество"); 
    ТЗ1.НоваяКолонка("Дата"); 
    ТЗ1.НоваяКолонка("Позиция");
    Спр.ВыбратьЭлементы();
    
    
    Пока Спр.ПолучитьЭлемент()<>0 Цикл
    ТЗ.НоваяСтрока();
    ТЗ.Продукция = спр.Продукция;
    ТЗ.Количество = спр.Количество;
    ТЗ.Дата = Спр.Дата;
    ТЗ.Позиция = Спр.ТекущийЭлемент(); 
    КонецЦикла;
    ТЗ.Сортировать("Продукция,Дата");	
    ВыбратьСтроки();
    Пока ПолучитьСтроку() = 1 Цикл
    Примечание = "Нужное Количество";
    а=0;  
    Если ТЗ.НайтиЗначение(Продукция, а,"Продукция") = 0 Тогда             
    Продолжить;
    КонецЕсли;
    Для к=а По ТЗ.КоличествоСтрок() Цикл
    ТЗ.ПолучитьСтрокуПоНомеру(к); 
    //проверка на продукцию 
    Если ТЗ.Продукция<>Продукция Тогда
    Прервать;
    КонецЕсли; 	 
    //аккумулируем элементы
    
    ТЗ1.НоваяСтрока();
    ТЗ1.Продукция = ТЗ.Продукция;
    ТЗ1.Количество = ТЗ.Количество;
    ТЗ1.Дата = ТЗ.Дата;
    ТЗ1.Позиция = ТЗ.Позиция; 
    
    
    КонецЦикла;
    
    
    ТЗ1.Сортировать("Продукция,Дата");
    ТЗ1.ВыбратьЭлементы();
    Пока ТЗ1.ПолучитьЭлемент() <> 0 Цикл
    НоваяСтрока();
    Продукция = ТЗ1.Продукция;
    Количество = ТЗ1.Количество;
    Дат = ТЗ1.Дата;
    Позиция = ТЗ1.Позиция; 
    КонецЦикла;
    КонецЦикла;
    КонецПроцедуры
    
    
    получаю для ТЗ1.ВыбратьЭлементы() "Поле Агрегатногообъекта не обноружено (ВыбратьЭлементы)"
  2. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.523
    Симпатии:
    407
    Баллы:
    104
    вынесите код
    Код:
    ТЗ1.Сортировать("Продукция,Дата");	
    ТЗ1.ВыбратьЭлементы();		
    Пока ТЗ1.ПолучитьЭлемент() <> 0 <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/цикл')">Цикл		</span>
    НоваяСтрока();			
    Продукция = ТЗ1.Продукция;			
    Количество = ТЗ1.Количество;			
    Дат = ТЗ1.Дата;			
    Позиция = ТЗ1.Позиция; 		
    КонецЦикла;
    
    
    ЗА цикл выборки строк....
  3. TopicStarter Overlay
    n_h
    Offline

    n_h Опытный в 1С

    Регистрация:
    21 янв 2011
    Сообщения:
    59
    Симпатии:
    0
    Баллы:
    26
    Результат тот же:
    Тз1.ВыбратьЭлементы();
    {Документ.Расх.Форма.Модуль(318)}: Поле агрегатного объекта не обнаружено (ВыбратьЭлементы)
  4. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.523
    Симпатии:
    407
    Баллы:
    104
    Использовали не тот метод....
    Извините что сразу не заметил - корейцы отвлекли.
    Код:
    Тз1.ВыбратьСтроки();
    Пока ТЗ1.ПолучитьСтроку() <> 0 Цикл
    
    

Поделиться этой страницей