[РЕШЕНО] Запуск дополнительной обработки по расписанию

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 8"", создана пользователем Казбек05даг, 29 июл 2017.

  1. TopicStarter Overlay
    Казбек05даг
    Offline

    Казбек05даг Опытный в 1С

    Регистрация:
    5 авг 2012
    Сообщения:
    262
    Симпатии:
    2
    Баллы:
    29
    Всех приветствую. Только учусь программировать поэтому сильно не ругайте за неправильные вопросы. 1С Розница 2.2.5.27 Создал внешнюю обработку которая при нажатии на кнопку загружает данные из файла в регистр сведений. Вручную все работает хорошо, но теперь стоит задача сделать так, чтобы эта обработка запускалась по расписанию и без открытия формы. Тоесть в фоновом режиме чтоб работала.
    Обработка подключена в форме "Дополнительные отчеты и обработки" [​IMG]
    [​IMG]

    https://cloud.mail.ru/public/9nNz/No48KEDDX
    Код в модуле формы
    Код:
    Функция СведенияОВнешнейОбработке() Экспорт
        ПараметрыРегистрации = Новый Структура;
        ПараметрыРегистрации.Вставить("Вид", "ДополнительнаяОбработка");
    
        ПараметрыРегистрации.Вставить("Наименование", "Загрузка остатков (PCService(C))");
        ПараметрыРегистрации.Вставить("Версия", "1.0");
        ПараметрыРегистрации.Вставить("БезопасныйРежим", Ложь);
        ПараметрыРегистрации.Вставить("Информация", "Загрузка Остатков");
        ПараметрыРегистрации.Вставить("ВерсияБСП", "2.3.2.33");
        ТаблицаКоманд = ПолучитьТаблицуКоманд();
        ДобавитьКоманду(ТаблицаКоманд,
        "Загрузка остатков (PCService(C))",
        "1",
        "ОткрытиеФормы",
        Истина,""
      
    
        );
        ДобавитьКоманду(ТаблицаКоманд,
        "Загрузка остатков (PCService(C))",
        "2",
        "ВызовСерверногоМетода",
        Истина,""
      
    
        );
        ИдентификаторКоманды = "2";
        ПараметрыРегистрации.Вставить("Команды", ТаблицаКоманд);
        Возврат ПараметрыРегистрации;
    КонецФункции
    
    Функция ПолучитьТаблицуКоманд()
        Команды = Новый ТаблицаЗначений;
        Команды.Колонки.Добавить("Представление", Новый ОписаниеТипов("Строка"));
        Команды.Колонки.Добавить("Идентификатор", Новый ОписаниеТипов("Строка"));
        Команды.Колонки.Добавить("Использование", Новый ОписаниеТипов("Строка"));
        Команды.Колонки.Добавить("ПоказыватьОповещение", Новый ОписаниеТипов("Булево"));
        Команды.Колонки.Добавить("Модификатор", Новый ОписаниеТипов("Строка"));
        Возврат Команды;
    КонецФункции
    
    Процедура ДобавитьКоманду(ТаблицаКоманд, Представление, Идентификатор, Использование, ПоказыватьОповещение = Ложь, Модификатор = "")
        НоваяКоманда = ТаблицаКоманд.Добавить();
        НоваяКоманда.Представление = Представление;
        НоваяКоманда.Идентификатор = Идентификатор;
        НоваяКоманда.Использование = Использование;
        НоваяКоманда.ПоказыватьОповещение = ПоказыватьОповещение;
        НоваяКоманда.Модификатор = Модификатор;
    КонецПроцедуры
    &НаСервере
    Процедура ВыполнитьКоманду(ИдентификаторКоманды, ОбъектыНазначения) Экспорт
    
    КонецПроцедуры
    При нажатии на кнопку выполнить с вариантом запуска "Открытие формы" форма открывается и сразу выполняется программа (сразу выполняется потому что на форме в событиях "ПриСозданииНаСервере" указано чтоб выполнила основной код программы)
    При нажатии на кнопку выполнить с вариантом запуска "ВызовСерверногоМетода" ошибок не выдает но и результата никакого.
    Что я делаю не так??
  2. 1с-ник
    Offline

    1с-ник Профессионал в 1С Заблокирован

    Регистрация:
    5 окт 2014
    Сообщения:
    998
    Симпатии:
    162
    Баллы:
    104
  3. TopicStarter Overlay
    Казбек05даг
    Offline

    Казбек05даг Опытный в 1С

    Регистрация:
    5 авг 2012
    Сообщения:
    262
    Симпатии:
    2
    Баллы:
    29
  4. TopicStarter Overlay
    Казбек05даг
    Offline

    Казбек05даг Опытный в 1С

    Регистрация:
    5 авг 2012
    Сообщения:
    262
    Симпатии:
    2
    Баллы:
    29
    Что нужно вписать вот сюда:
    Код:
    &НаСервере
    Процедура ВыполнитьКоманду(ИдентификаторКоманды, ОбъектыНазначения) Экспорт
    
    КонецПроцедуры
    Чтобы он запустил обработку без открытия формы?
  5. TopicStarter Overlay
    Казбек05даг
    Offline

    Казбек05даг Опытный в 1С

    Регистрация:
    5 авг 2012
    Сообщения:
    262
    Симпатии:
    2
    Баллы:
    29
    Все вкурил. Сюда и надо было скопировать код который я хотел чтоб выполнялся без открытия формы
  6. ЕкатеринаНик
    Offline

    ЕкатеринаНик Опытный в 1С

    Регистрация:
    8 ноя 2010
    Сообщения:
    717
    Симпатии:
    1
    Баллы:
    29
    Будьте добры, поделиться примером, обработки, которая будет работать по расписанию.

Поделиться этой страницей