7.7 Запрос

Тема в разделе "Отчеты и обработки для "1С:Предприятие 7.7"", создана пользователем Cooper-Mixal, 5 сен 2008.

  1. TopicStarter Overlay
    Cooper-Mixal
    Offline

    Cooper-Mixal Опытный в 1С

    Регистрация:
    29 июн 2008
    Сообщения:
    193
    Симпатии:
    0
    Баллы:
    26
    Добрый день!!!

    Есть запрос

    Код:
    ТекстЗапроса = 
    "//{{ЗАПРОС(Сформировать)
    |Период с (НачМесяца(ДатаДок)) по (КонМесяца(ДатаДок));
    |Работа = Документ.ВыполнениеЭтапаРабот.Работа, Документ.ОказаниеУслуг.Услуга;
    |Часы = Документ.ВыполнениеЭтапаРабот.Часы , Документ.ОказаниеУслуг.Часы;   
    |Сум = Документ.ВыполнениеЭтапаРабот.Сумма, Документ.ОказаниеУслуг.Сумма; 
    |Подразделение = Документ.ВыполнениеЭтапаРабот.Подразделение, Документ.ОказаниеУслуг.Подразделение;   
    |ВидНоменклатуры = Документ.ВыполнениеЭтапаРабот.Работа.ВидНоменклатуры, Документ.ОказаниеУслуг.Услуга.ВидНоменклатуры;
    |Контрагент = Документ.ВыполнениеЭтапаРабот.Контрагент, Документ.ОказаниеУслуг.Контрагент;
    |Функция ЧасыСумма = Сумма(Часы);
    |Функция СумСумма = Сумма(Сум);
    |Группировка ВидНоменклатуры;  
    |Группировка Подразделение;  
    |"//}}ЗАПРОС
    
    Есть 4 группы: ЭМП, ЦЕТЛ, РМЦ, ЭРП

    Код:
    Пока Запрос.Группировка(1) = 1 Цикл  
    
    Если Запрос.ВидНоменклатуры.ЭтоГруппа() = 1 Тогда
    Продолжить;
    КонецЕсли;  
    
    Пока Запрос.Группировка(2) = 1 Цикл  
    
    Если (Запрос.Подразделение.ЭтоГруппа() = 1) тогда 	
    Продолжить;	
    КонецЕсли;   
    
    НоваяСтрока();
    Если <Условие> Тогда  // Как  определить, что за группа???
    ВидНоменклатуры = Запрос.ВидНоменклатуры;
    Подразделение = Запрос.Подразделение;
    
    Количество = Запрос.ЧасыСумма; //Вот в этом месте надо проставить если группа ЭРП то СумСумма, 
    // если остальные группы, то ЧасыСумма
    Контрагент = Запрос.Контрагент;
    КонецЕсли;
    КонецЦикла;	
    КонецЦикла;
    
    Как определить группу в запросе?
  2. Stado_adama
    Offline

    Stado_adama Модераторы Модератор

    Регистрация:
    27 ноя 2007
    Сообщения:
    1.086
    Симпатии:
    0
    Баллы:
    26
    Родитель
    Синтаксис:
    Родитель
    Назначение:
    Доступ к значению родительской группы выбранного элемента справочника.
    Атрибут может быть изменен только для объектов, созданных функцией СоздатьОбъект.
    Подробнее см. в документации, глава 'Работа со Справочниками'
  3. TopicStarter Overlay
    Cooper-Mixal
    Offline

    Cooper-Mixal Опытный в 1С

    Регистрация:
    29 июн 2008
    Сообщения:
    193
    Симпатии:
    0
    Баллы:
    26
    Ок. Спасибо. Сделал.

    Просто я незнал что надо использовать!

Поделиться этой страницей