7.7 Запрос

Тема в разделе "Типовые решения "1С:Предприятие 7.7"", создана пользователем ya-wanes, 18 июл 2007.

  1. TopicStarter Overlay
    ya-wanes
    Offline

    ya-wanes

    Регистрация:
    21 дек 2006
    Сообщения:
    23
    Симпатии:
    0
    Баллы:
    1
    Как из документа ЗаказНаряд вытянуть адрес контогентов чтоб сделать запрос по области

    //*******************************************
    // Процедура генерации запроса Сформировать.
    //
    Процедура Сформировать()
    Перем Запрос, ТекстЗапроса, Таб;
    //Создание объекта типа Запрос
    Запрос = СоздатьОбъект("Запрос");
    ТекстЗапроса =
    "//{{ЗАПРОС(Сформировать)
    |Период с ВыбНачПериода по ВыбКонПериода;
    |ОбрабатыватьДокументы все;
    |Контрагент = Документ.ЗаказНаряд.Контрагент;
    |Группировка Контрагент упорядочить по Контрагент.Наименование без групп;
    |"//}}ЗАПРОС
    ;
    // Если ошибка в запросе, то выход из процедуры
    Если Запрос.Выполнить(ТекстЗапроса) = 0 Тогда
    Возврат;
    КонецЕсли;

    // Подготовка к заполнению выходных форм данными запроса
    Таб = СоздатьОбъект("Таблица");
    Таб.ИсходнаяТаблица("Сформировать");
    // Заполнение полей "Заголовок"
    Таб.ВывестиСекцию("Заголовок");
    Состояние("Заполнение выходной таблицы...");
    Таб.Опции(0, 0, Таб.ВысотаТаблицы(), 0);
    Пока Запрос.Группировка(1) = 1 Цикл
    // Заполнение полей Контрагент
    Таб.ВывестиСекцию("Контрагент");
    КонецЦикла;
    // Вывод заполненной формы
    Таб.ТолькоПросмотр(1);
    Таб.Показать("Сформировать", "");
    КонецПроцедуры



    помогите я не могу понять.. Зарание спасибо.. :unsure:
  2. Steel Rain
    Offline

    Steel Rain Опытный в 1С

    Регистрация:
    29 сен 2006
    Сообщения:
    408
    Симпатии:
    2
    Баллы:
    29
    Ну вот выбрали вы запросом всех контрагентов и теперь можете обращаться к их реквизитам. Наример есть у контрагента реквизит "Адрес", тогда его значение можно получить к примеру так:

    Код:
      Элем=Запрос.Контрагент;
    Адрес=Элем.Адрес;
    

Поделиться этой страницей