8.х Запрос

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 8"", создана пользователем check, 16 ноя 2011.

  1. TopicStarter Overlay
    check
    Offline

    check

    Регистрация:
    29 ноя 2010
    Сообщения:
    5
    Симпатии:
    0
    Баллы:
    1
    Добрый вечер! Подскажите пожалуйста,создаю запрос в 8.2 ошибок нет, но ничего не выводится, подскажите пожалуйста в чем проблема

    код следующий!

    &НаКлиенте
    Процедура КлиентПриИзменении(Элемент)
    КлиентПриИзмененииНаСервере()
    КонецПроцедуры

    &НаСервере
    Процедура КлиентПриИзмененииНаСервере()
    Запрос=Новый Запрос;
    Запрос.Текст="ВЫБРАТЬ
    | КлиентыТабличнаяЧасть1.КонтактноеЛицо
    |ИЗ
    | Справочник.Клиенты.ТабличнаяЧасть1 КАК КлиентыТабличнаяЧасть1";
    Результат=Запрос.Выполнить();
    КонецПроцедуры
  2. TopicStarter Overlay
    check
    Offline

    check

    Регистрация:
    29 ноя 2010
    Сообщения:
    5
    Симпатии:
    0
    Баллы:
    1
    каким образом осуществить выгрузку данных
  3. n.s.gnedash
    Offline

    n.s.gnedash Опытный в 1С Команда форума

    Регистрация:
    15 авг 2010
    Сообщения:
    1.358
    Симпатии:
    5
    Баллы:
    29
    Запрос.Выполнить.Выгрузить() ?
  4. uza
    Offline

    uza 1С, VBA (EXCEL), VB (.NET + WEB)

    Регистрация:
    10 июл 2007
    Сообщения:
    1.845
    Симпатии:
    1
    Баллы:
    29
    Но выгружать в ТЗ не есть кошерно.
    Кошерно обходить сформированную выборку:
    Код:
    Выборка1С = Запрос.Выполнить().Выбрать();
    //или в вашем случае так:
    //Результат = Запрос.Выполнить();
    //Выборка1С = Результат.Выбрать();
    
    //и потом строим обход
    Пока Выборка1С.Следующий() Цикл
    Сообщить(Выборка1С.КонтактноеЛицо);
    КонецЦикла;
    

Поделиться этой страницей