8.х Запрос

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 8"", создана пользователем Rita7777, 8 сен 2009.

  1. TopicStarter Overlay
    Rita7777
    Offline

    Rita7777

    Регистрация:
    29 май 2009
    Сообщения:
    17
    Симпатии:
    0
    Баллы:
    1
    Есть запрос:
    ПостроительОтчетаКонтрольнаяВедомостьСменыПрессформы.Текст =
    "ВЫБРАТЬ
    | ПростоиТПАОбороты.ТПА КАК ТПА,
    | ПростоиТПАОбороты.ВидПростоя,
    | ПростоиТПАОбороты.Смена.ВидСмены КАК ВидСмены,
    | ПростоиТПАОбороты.КоличествоЧасовОборот КАК ВремяПростоя,
    | ПростоиТПАОбороты.Регистратор КАК ДокПростоя,
    | ПростоиТПАОбороты.Регистратор.Дата КАК ДатаПростоя,
    | ПростоиТПАОбороты.ТПА.СокрНаименование КАК НаименованиеТПА,
    | ПростоиТПАОбороты.Период КАК Период
    |{ВЫБРАТЬ
    | ТПА.*,
    | ВидПростоя.*,
    | ВидСмены.*,
    | ВремяПростоя,
    | ДокПростоя.*,
    | ДатаПростоя,
    | НаименованиеТПА}
    |ИЗ
    | РегистрНакопления.ПростоиТПА.Обороты(&НачалоПериода, &КонецПериода, Регистратор, ) КАК ПростоиТПАОбороты
    |{ГДЕ
    | ПростоиТПАОбороты.ТПА.*,
    | ПростоиТПАОбороты.ВидПростоя.*,
    | ПростоиТПАОбороты.Смена.ВидСмены.* КАК ВидСмены,
    | ПростоиТПАОбороты.КоличествоЧасовОборот КАК ВремяПростоя,
    | ПростоиТПАОбороты.Регистратор.* КАК ДокПростоя,
    | ПростоиТПАОбороты.Регистратор.Дата КАК ДатаПростоя,
    | ПростоиТПАОбороты.ТПА.СокрНаименование КАК НаименованиеТПА}
    |
    |УПОРЯДОЧИТЬ ПО
    | ВидСмены,
    | ДокПростоя
    |ИТОГИ
    | СУММА(ВремяПростоя)
    |ПО
    | ТПА,
    | Период ПЕРИОДАМИ(ДЕНЬ, &НачалоПериода, &КонецПериода),
    | ДокПростоя
    |АВТОУПОРЯДОЧИВАНИЕ";
    //***
    ВыборкаТПА=ПостроительОтчетаКонтрольнаяВедомостьСменыПрессформы.Результат.Выбрать(ОбходРезультатаЗапроса.ПоГруппировкам,"ТПА");
    Пока ВыборкаТПА.Следующий() Цикл
    ОбластьСтрокиТПА.Параметры.Заполнить(ВыборкаТПА);
    ТабДок.Вывести(ОбластьСтрокиТПА);

    ВыборкаПериод=ВыборкаТПА.Выбрать(ОбходРезультатаЗапроса.ПоГруппировкам,"Период");
    Пока ВыборкаПериод.Следующий() Цикл

    ВыборкаДок=ВыборкаПериод.Выбрать(ОбходРезультатаЗапроса.ПоГруппировкам,"ДокПростоя");
    Пока ВыборкаДок.Следующий() Цикл
    ОбластьСтрокиДок.Параметры.Заполнить(ВыборкаДок);
    ТабДок.Вывести(ОбластьСтрокиДок);
    КонецЦикла;
    КонецЦикла;
    КонецЦикла;

    ////**
    И при обходе выдает ошибку
    {Отчет.КонтрольнаяВедомостьСменыПрессформы.Форма.КонтрольнаяВедомостьСменыПрессформы(75)}: Ошибка при вызове метода контекста (Выбрать): Измерение не найдено "Период"
    ВыборкаПериод=ВыборкаТПА.Выбрать(ОбходРезультатаЗапроса.ПоГруппировкам,"Период");
    по причине:
    Измерение не найдено "Период"
  2. tirk
    Offline

    tirk Опытный в 1С

    Регистрация:
    1 сен 2008
    Сообщения:
    1.142
    Симпатии:
    0
    Баллы:
    26
    ну т.. ты же не группируешь по периодам.. в ошибки же так и написано
  3. mialord
    Offline

    mialord Модераторы Команда форума Модератор

    Регистрация:
    31 июл 2009
    Сообщения:
    5.398
    Симпатии:
    40
    Баллы:
    54
  4. TopicStarter Overlay
    Rita7777
    Offline

    Rita7777

    Регистрация:
    29 май 2009
    Сообщения:
    17
    Симпатии:
    0
    Баллы:
    1
    Не помогло. Какой-то глюк. Сделала новый отчет с таким-же запросом и все работает

Поделиться этой страницей