7.7 Запрос в справочнике

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 7.7"", создана пользователем gopsmile, 11 авг 2011.

  1. TopicStarter Overlay
    gopsmile
    Offline

    gopsmile

    Регистрация:
    11 авг 2011
    Сообщения:
    5
    Симпатии:
    0
    Баллы:
    1
    Код:
    Процедура Сформировать()
    Перем Запрос, ТекстЗапроса, Таб;
    //Создание объекта типа Запрос
    Запрос = СоздатьОбъект("Запрос");
    ТекстЗапроса = 
    "//{{ЗАПРОС(Сформировать)
    |Наименование = Справочник.Покупатели.Наименование;
    |Группировка Наименование;
    |Условие(Наименование в ВыбНаименование);
    |"//}}ЗАПРОС
    ;
    // Если ошибка в запросе, то выход из процедуры
    Если Запрос.Выполнить(ТекстЗапроса) = 0 Тогда
    Возврат;
    КонецЕсли;
    
    // Подготовка к заполнению выходных форм данными запроса
    Таб = СоздатьОбъект("Таблица");
    Таб.ИсходнаяТаблица("Сформировать");
    // Заполнение полей "Заголовок"
    Таб.ВывестиСекцию("Заголовок");
    Состояние("Заполнение выходной таблицы...");
    Таб.Опции(0, 0, Таб.ВысотаТаблицы(), 0);
    Пока Запрос.Группировка(1) = 1 Цикл
    // Заполнение полей Наименование
    Таб.ВывестиСекцию("Наименование");
    КонецЦикла;
    // Вывод заполненной формы
    Таб.ТолькоПросмотр(1);
    Таб.Показать("Сформировать", "");
    КонецПроцедуры
    
    Чтот у меня лыжи не едут уж совсем.
    Вот самый элементарный запрос. Как я понимаю этот отчет должен мне вывести наименования покупателей находящихся в группе ВыбНаименование. Ну нет пустая строка. ВыбНаименование справочник.покупатели.
  2. WaRDeR
    Offline

    WaRDeR Модераторы Команда форума Модератор

    Регистрация:
    23 ноя 2006
    Сообщения:
    3.263
    Симпатии:
    14
    Баллы:
    29
    Разность типов.
    Тут будет:
    ВыбНаименование - Справочник
    Наименование - Строка

    Вот поэтому и пусто.

    Нужно так:

    Код:
    "//{{ЗАПРОС(Сформировать)
    |Наименование = Справочник.Покупатели;
    |Группировка Наименование;
    |Условие(Наименование в ВыбНаименование);
    |"//}}ЗАПРОС
    
    
  3. Asttoxa
    Offline

    Asttoxa Опытный в 1С

    Регистрация:
    18 май 2010
    Сообщения:
    525
    Симпатии:
    0
    Баллы:
    26

    Или так :)

    Код:
    "//{{ЗАПРОС(Сформировать)
    |Наименование = Справочник.Покупатели.Наименование;
    |Группировка Наименование;
    |Условие(Наименование в ВыбНаименование.Наименование);
    |"//}}ЗАПРОС
    
    
    
  4. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.523
    Симпатии:
    407
    Баллы:
    104
    второй вариант не пойдет... строки так не сравниваются на вхождение. Юзайте первый
  5. WaRDeR
    Offline

    WaRDeR Модераторы Команда форума Модератор

    Регистрация:
    23 ноя 2006
    Сообщения:
    3.263
    Симпатии:
    14
    Баллы:
    29
    Не думаю....
    Привязывать объекты к текстовым строкам - это самое последнее, что можно сделать, если уже нет других (нормальных) выходов.

    К тому же, например, группа может содержать название "ЮрЛица"... С какими названиями будут отбираться элементы?

    [off]Угодник как обычно опередил :angry:[/off]
  6. TopicStarter Overlay
    gopsmile
    Offline

    gopsmile

    Регистрация:
    11 авг 2011
    Сообщения:
    5
    Симпатии:
    0
    Баллы:
    1
    Ребята, Спасибо Вам )) Все оказывается работает, да уж типы, типы. И еще такой вопрос может кто сталкивался. Можно вытащить покупателей из другого справочника, там все по группам, т.е. покупателей которые находятся в другом справочнике и распределены по группам, но наименование у них одинаковые . или я сейчас каккую то фигню написал.
  7. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.523
    Симпатии:
    407
    Баллы:
    104
    Похоже что все же фигню...
    Конфу назовите если типовая. Связаны ли справочики между собой (хоть какой нибудь общий реквизит или подчиненность)?
  8. WaRDeR
    Offline

    WaRDeR Модераторы Команда форума Модератор

    Регистрация:
    23 ноя 2006
    Сообщения:
    3.263
    Симпатии:
    14
    Баллы:
    29
    ...и самый главный вопрос, а в чем смысл хранения в разных справочниках одинаковых (по описанию) данных?
  9. TopicStarter Overlay
    gopsmile
    Offline

    gopsmile

    Регистрация:
    11 авг 2011
    Сообщения:
    5
    Симпатии:
    0
    Баллы:
    1
    Там как то все закручено, ну ладно, и на самом деле фигню написал. Конфа не типовая. WaRDeR: а фиг их знает, понаделают, а ты разбирайся.
  10. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.523
    Симпатии:
    407
    Баллы:
    104
    Хм.... Выкладывайте суть задачи и МДшник

Поделиться этой страницей