8.х Запрос Унив. перед. док.

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 8"", создана пользователем Ildar Ziganshin, 23 июн 2014.

  1. TopicStarter Overlay
    Ildar Ziganshin
    Offline

    Ildar Ziganshin Опытный в 1С

    Регистрация:
    2 окт 2013
    Сообщения:
    527
    Симпатии:
    0
    Баллы:
    26
    Здравствуйте, не могу найти текст самого запроса.

    Функция ПечатьУниверсальныхПередаточныхДокументов(МассивОбъектов, ОбъектыПечати)

    ТабДокумент = Новый ТабличныйДокумент;

    // Устанавливаем параметры печати и колонтитулы
    ТабДокумент.ОриентацияСтраницы = ОриентацияСтраницы.Ландшафт;
    ТабДокумент.ПолеСверху = 12;
    ТабДокумент.ПолеСлева = 0;
    ТабДокумент.ПолеСнизу = 0;
    ТабДокумент.ПолеСправа = 0;
    ТабДокумент.АвтоМасштаб = Истина;
    ТабДокумент.ИмяПараметровПечати = "ПАРАМЕТРЫ_ПЕЧАТИ_УниверсальныйПередаточныйДокумент";

    ПервыйДокумент = Истина;
    ВыводитьКолонтитул = МассивОбъектов.Количество() = 1;
    ТабДокументНеВыводитьНаПечать = Истина;
    ДокументыСчетФактураНеТребуется = ОпределитьСчетФактураТребуются(МассивОбъектов);

    Для каждого Ссылка Из МассивОбъектов Цикл

    Если Не ПервыйДокумент Тогда
    ТабДокумент.ВывестиГоризонтальныйРазделительСтраниц();
    КонецЕсли;
    ПервыйДокумент = Ложь;
    НомерСтрокиНачало = ТабДокумент.ВысотаТаблицы + 1;

    РеквизитыДокумента = ОбщегоНазначения.ПолучитьЗначенияРеквизитов(Ссылка, "Ссылка, Дата, Номер, Организация,
    |ВидОперации, Контрагент, ДоговорКонтрагента, ОтпускРазрешил, ГлавныйБухгалтер, Подразделение,
    |ДоверенностьНомер, ДоверенностьДата, ДоверенностьВыдана, ДоверенностьЧерезКого");

    ДанныеДокумента = Новый Структура();
    ДанныеДокумента.Вставить("ДокументСсылка", РеквизитыДокумента.Ссылка);
    ДанныеДокумента.Вставить("Номер", РеквизитыДокумента.Номер);
    ДанныеДокумента.Вставить("Дата", РеквизитыДокумента.Дата);
    ДанныеДокумента.Вставить("Ссылка", Документы.СчетФактураВыданный.ПустаяСсылка());
    ДанныеДокумента.Вставить("ДокументОснование", РеквизитыДокумента.Ссылка);
    ДанныеДокумента.Вставить("Организация", РеквизитыДокумента.Организация);
    ДанныеДокумента.Вставить("Контрагент", РеквизитыДокумента.Контрагент);
    ДанныеДокумента.Вставить("ДоговорКонтрагента", РеквизитыДокумента.ДоговорКонтрагента);
    ДанныеДокумента.Вставить("Руководитель", РеквизитыДокумента.ОтпускРазрешил);
    ДанныеДокумента.Вставить("ГлавныйБухгалтер", РеквизитыДокумента.ГлавныйБухгалтер);
    ДанныеДокумента.Вставить("ВалютаРегламентированногоУчета", глЗначениеПеременной("ВалютаРегламентированногоУчета"));
    ДанныеДокумента.Вставить("Подразделение", РеквизитыДокумента.Подразделение);

    Если ЗначениеЗаполнено(РеквизитыДокумента.ДоверенностьНомер) ИЛИ ЗначениеЗаполнено(РеквизитыДокумента.ДоверенностьДата)
    ИЛИ ЗначениеЗаполнено(РеквизитыДокумента.ДоверенностьВыдана) ИЛИ ЗначениеЗаполнено(РеквизитыДокумента.ДоверенностьЧерезКого) Тогда
    Доверенность = СтроковыеФункцииКлиентСервер.ПодставитьПараметрыВСтроку(
    НСтр("ru = 'по доверенности №%1 от %2 выданной %3 %4'"),
    РеквизитыДокумента.ДоверенностьНомер, Формат(РеквизитыДокумента.ДоверенностьДата, "ДЛФ=ДД"),
    РеквизитыДокумента.ДоверенностьВыдана, РеквизитыДокумента.ДоверенностьЧерезКого);
    ДанныеДокумента.Вставить("Доверенность", Доверенность);
    КонецЕсли;

    ВидДоговора = ОбщегоНазначения.ЗначениеРеквизитаОбъекта(РеквизитыДокумента.ДоговорКонтрагента, "ВидДоговора");
    ПередачаНаРеализациюПоКомиссии = (ВидДоговора = Перечисления.ВидыДоговоровКонтрагентов.СКомиссионером);
    ДанныеДокумента.Вставить("ПередачаНаРеализациюПоКомиссии", ПередачаНаРеализациюПоКомиссии);

    СчетФактураТребуется = (ДокументыСчетФактураНеТребуется.Найти(Ссылка) = Неопределено);

    СтруктураОтбораСчетаФактуры = Новый Структура;
    СтруктураОтбораСчетаФактуры.Вставить("ПометкаУдаления", Ложь);

    Если УчетНДС.ПечатьУниверсальногоПередаточногоДокумента(ДанныеДокумента, СчетФактураТребуется, ТабДокумент, СтруктураОтбораСчетаФактуры) = Неопределено Тогда
    Продолжить;
    КонецЕсли;

    ТабДокумент.ВерхнийКолонтитул.Выводить = ВыводитьКолонтитул;

    ТабДокументНеВыводитьНаПечать = Ложь;
    УправлениеПечатью.ЗадатьОбластьПечатиДокумента(ТабДокумент, НомерСтрокиНачало, ОбъектыПечати, Ссылка);

    КонецЦикла;

    Если ТабДокументНеВыводитьНаПечать Тогда
    Макет = ПолучитьОбщийМакет("УниверсальныйПередаточныйДокумент");
    ОбластьМакета = Макет.ПолучитьОбласть("Ошибка");
    ТабДокумент.Вывести(ОбластьМакета);
    КонецЕсли;

    Возврат ТабДокумент;

    КонецФункции
  2. rshakiro
    Offline

    rshakiro Профессионал в 1С Команда форума

    Регистрация:
    17 мар 2011
    Сообщения:
    2.236
    Симпатии:
    144
    Баллы:
    104
    УПД печатается из документа счет-фактура...
    см. функции:
    Код:
    ПечатьУниверсальногоПередаточногоДокумента
    // и
    ПодготовитьДанныеДляПечатиУниверсальногоПередаточногоДокумента

Поделиться этой страницей