7.7 Запрос по продажам

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 7.7"", создана пользователем Димыч28, 19 янв 2015.

  1. TopicStarter Overlay
    Димыч28
    Offline

    Димыч28 Опытный в 1С

    Регистрация:
    10 янв 2013
    Сообщения:
    112
    Симпатии:
    0
    Баллы:
    26
    Доброго времени суток! мне нужны цифры на кон дату, но сравнивая с отчетом по продажам, в запросе цифра в два раза больше чем в отчете, подскажите как правильно написать запрос
    Код:
    ТекстЗапроса=
        "//{{ЗАПРОС(Продажи)
        |Период с НачДата по КонДатаЗ;
        |Менеджер = Регистр.Продажи.ТекущийДокумент.Автор;
        |Фирма = Регистр.Продажи.Фирма;
        |Склад = Регистр.Продажи.ТекущийДокумент.ВозвратОтПокупателя.Склад, Регистр.Продажи.ТекущийДокумент.ОтчетККМ.Склад, Регистр.Продажи.ТекущийДокумент.Реализация.Склад, Регистр.Продажи.ТекущийДокумент.РеализацияРозница.Склад;
        |Договор = Регистр.Продажи.ТекущийДокумент.ВозвратОтПокупателя.Договор, Регистр.Продажи.ТекущийДокумент.ОтчетККМ.Договор, Регистр.Продажи.ТекущийДокумент.Реализация.Договор, Регистр.Продажи.ТекущийДокумент.РеализацияРозница.Договор;
        |Номенклатура = Регистр.Продажи.Номенклатура;  
        |Контрагент = Регистр.Продажи.Покупатель;
        |ТекДокумент = Регистр.Продажи.ТекущийДокумент;  
        |КоличПрод = Регистр.Продажи.Количество;
        |КоличВозвр = Регистр.Продажи.КоличествоВ;
        |СумПрод = Регистр.Продажи.ПродСтоимость;
        |СумВозв = Регистр.Продажи.ПродСтоимостьВ;
        |СебПрод = Регистр.Продажи.Себестоимость;
        |СебВозв = Регистр.Продажи.СебестоимостьВ;
        |Функция Кол = Сумма(КоличПрод);
        |Функция КолВ = Сумма(КоличВозвр);
        |Функция Сум = Сумма(СумПрод);
        |Функция СумВ = Сумма(СумВозв);
        |Функция Себ = Сумма(СебПрод);
        |Функция СебВ = Сумма(СебВозв);
        |"//}}ЗАПРОС
        ;
    Последнее редактирование модератором: 19 янв 2015
  2. LordMaverick
    Online

    LordMaverick Профессионал в 1С

    Регистрация:
    17 мар 2014
    Сообщения:
    3.443
    Симпатии:
    376
    Баллы:
    104
    КОД оформляте тегами плиз


    дуплит бывает когда склад в группе, фирма не одна
    у вас ведь нет условия отбора
    Последнее редактирование: 19 янв 2015
  3. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.523
    Симпатии:
    407
    Баллы:
    104
    1) Если вам нужны конечные цифры, то воспользуйтесь функцией запроса КонОст....
    2) Зачем вам переменные в запросе, которые вы нигде не применяете?

    Поясните какая стоит задача более развернуто. - поможем составить правильный запрос
  4. TopicStarter Overlay
    Димыч28
    Offline

    Димыч28 Опытный в 1С

    Регистрация:
    10 янв 2013
    Сообщения:
    112
    Симпатии:
    0
    Баллы:
    26
    Нужны продажи по номенклатуре на кон дату и нач ост, кон ост, по кол и сумме
  5. LordMaverick
    Online

    LordMaverick Профессионал в 1С

    Регистрация:
    17 мар 2014
    Сообщения:
    3.443
    Симпатии:
    376
    Баллы:
    104
    продажи могут быть за период, если вы говорите на "кон дату" то это значит что [с "НачДата" по "КонДатаЗ"]
    а начальный и конечный остаток вы даже не заложили в запрос
  6. LordMaverick
    Online

    LordMaverick Профессионал в 1С

    Регистрация:
    17 мар 2014
    Сообщения:
    3.443
    Симпатии:
    376
    Баллы:
    104
    конфигурация у вас какая?

    вот такой например есть запрос
    Код:
        ТекстЗапроса="
        |ПЕРИОД С ДатаНачала По ДатаКонец;
        |Фирма=Регистр.Реализация.Фирма;
        |Товар=Регистр.Реализация.Товар;
        |Контрагент=Регистр.Реализация.Клиент;
        |СуммаТовара=Регистр.Реализация.Сумма;
        |ОстатокТовара=Регистр.Реализация.Остаток;
        |ТекДокумент=Регистр.Реализация.ТекущийДокумент;
        |Группировка Фирма;
        |Группировка Контрагент;
        |Группировка Товар Без групп;
        |Функция НачОстКолич=НачОст(ОстатокТовара);
        |Функция НачОстСумма=НачОст(СуммаТовара);
        |Функция КонОстКолич=КонОст(ОстатокТовара);
        |Функция КонОстСумма=КонОст(СуммаТовара);
        |Функция ПриходКолич=Приход(ОстатокТовара);
        |Функция ПриходСумма=Приход(СуммаТовара);
        |Функция РасходКолич=Расход(ОстатокТовара);
        |Функция РасходСумма=Расход(СуммаТовара);
        |Условие (Фирма=ВыбФирма);
        |";
    
        Если ВыбФирма.Выбран()=0 Тогда
            Заг=Заг+"По всем фирмам"+". ";
        Иначе
            Заг=Заг+"По фирме: "+СокрП(ВыбФирма.Наименование)+". ";
        КонецЕсли;
    
        Если ВыбТовар.Выбран()=0 Тогда
            Заг=Заг+"По всем товарам"+". ";
        ИначеЕсли ВыбТовар.ЭтоГруппа()=1 Тогда
            ТекстЗапроса=ТекстЗапроса+"Условие(Товар В ВыбТовар);";
            Заг=Заг+"По товарам группы: "+СокрП(ВыбТовар.Наименование)+". ";
        Иначе
            ТекстЗапроса=ТекстЗапроса+"Условие(Товар=ВыбТовар);";
            Заг=Заг+"По товару: " + СокрП(ВыбТовар.Наименование)+". ";
        КонецЕсли;
      
        Если ВыбКлиент.Выбран()=0 Тогда
            Заг=Заг+"По всем клиентам"+". ";
        ИначеЕсли ВыбКлиент.ЭтоГруппа()=1 Тогда
            ТекстЗапроса=ТекстЗапроса+"Условие(Контрагент В ВыбКлиент);";
            Заг=Заг+"По клиентам группы: "+СокрП(ВыбКлиент.Наименование)+". ";
        Иначе
            ТекстЗапроса=ТекстЗапроса+"Условие(Контрагент=ВыбКлиент);";
            Заг=Заг+"По клиенту: " + СокрП(ВыбКлиент.Наименование)+". ";
        КонецЕсли;
    
    
        Флаг=Запрос.Выполнить(ТекстЗапроса);
        Если Флаг=0 тогда
            Предупреждение("Запрос по движению товара не выполнился!!!");
            Возврат;
        КонецЕсли;
    
    upload_2015-1-20_16-26-56.png
    upload_2015-1-20_16-27-33.png
  7. TopicStarter Overlay
    Димыч28
    Offline

    Димыч28 Опытный в 1С

    Регистрация:
    10 янв 2013
    Сообщения:
    112
    Симпатии:
    0
    Баллы:
    26
    У меня сумма продаж не сходится, а нач и кон остаток я вытаскиваю из другого запроса
    --- Объединение сообщений, 20 янв 2015 ---
    конфа торговля и склад
  8. LordMaverick
    Online

    LordMaverick Профессионал в 1С

    Регистрация:
    17 мар 2014
    Сообщения:
    3.443
    Симпатии:
    376
    Баллы:
    104
    Склад у вас не в группе?
  9. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.523
    Симпатии:
    407
    Баллы:
    104
    Чем не устраивает типовой отчет по продажам ТМЦ?

Поделиться этой страницей