7.7 Запрос по основным средствам

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 7.7"", создана пользователем kogor, 11 фев 2014.

  1. TopicStarter Overlay
    kogor
    Offline

    kogor Опытный в 1С

    Регистрация:
    5 фев 2010
    Сообщения:
    412
    Симпатии:
    0
    Баллы:
    26
    Добрый день

    Помогите написать запрос - нет опыта работы с 7.7.

    В результате должна выйти таблица с колонками:

    Наименование ОС | Дата поступления | Дата продажи

    где

    Наименование ОС - из справочника Основные средства

    Дата поступления - из документа "Поступление ОС и НМА"

    Дата продажи - из документа "Передача ОС"

    На 8ке я бы это сделал ЛЕВЫМ СОЕДИНЕНИЕМ справочника Основные средства с документами ПО Основному средству, а вот как это сделать на 7.7 не понимаю!
  2. Катюфка
    Offline

    Катюфка Профессионал в 1С

    Регистрация:
    3 июн 2013
    Сообщения:
    412
    Симпатии:
    72
    Баллы:
    54
    Здравствуйте.
    Для начала хотя бы укажите, какую конфигурацию используете.
    Если речь о типовой Бухгалтерии, то основные средства хранятся на 01 счете с соответствующим субконто. Можно получить движения (поступление и передача) с помощью объекта БухгалтерскиеИтоги.
    В типовых есть ОтчетПоОС (или подобные). Там много лишнего для поставленной задачи, но понять логику работы не слишком сложно.
  3. TopicStarter Overlay
    kogor
    Offline

    kogor Опытный в 1С

    Регистрация:
    5 фев 2010
    Сообщения:
    412
    Симпатии:
    0
    Баллы:
    26
    Конфигурация комплексная ред. 4.5

    Вот так создаю БухгалтерскиеИтоги

    Код:
    БИ = СоздатьОбъект("БухгалтерскиеИтоги");
    НачДата = ?(ВариантФормирования = 1, ДатаНач, ДокументНачисленияАмортизации);
    КонДата = ?(ВариантФормирования = 1, ДатаКон, ДокументНачисленияАмортизации);
    
    Если ПустоеЗначение(Значение)=0 Тогда
    флОбъектОСЭтоГруппа=1;
    БИ.ИспользоватьСубконто(ВидыСубконто.ОсновныеСредства, Значение);
    Иначе
    БИ.ИспользоватьСубконто(ВидыСубконто.ОсновныеСредства);
    КонецЕсли;
    
    Если БИ.ВыполнитьЗапрос(НачДата,КонДата,"01.1,01.2,02.1,010,Н05.01,Н05.02",,,3) = 0 Тогда  
    Предупреждение("Не удается выполнить запрос к бухгалтерским итогам!");
    Возврат;
    КонецЕсли;
    (
    как дальше из них выбрать даты поступления и продажи?
  4. TopicStarter Overlay
    kogor
    Offline

    kogor Опытный в 1С

    Регистрация:
    5 фев 2010
    Сообщения:
    412
    Симпатии:
    0
    Баллы:
    26
    решил пока попробовать запросом:

    Код:
    Запрос = СоздатьОбъект("Запрос");
    ТекстЗапроса = "
    |Период с (НачДата) по (КонДата);
    |ОС = Документ.ВводВЭксплуатациюОС.ОсновноеСредство;
    |ДатаПоступления = Документ.ВводВЭксплуатациюОС.ДатаДок;
    |Группировка ОС;
    |Условие(ОС = БИ.Субконто());";
    
    
    Если Запрос.Выполнить(ТекстЗапроса) = 0 Тогда
    Возврат;
    КонецЕсли;
    
    Пока Запрос.Группировка("ОС")=1 Цикл
    Сообщить(""+Запрос.ОС+ " - "+ Запрос.ДатаПоступления);
    КонецЦикла;
    как сюда присоединить еще документ "ПередачаОС", чтобы в одной строке у меня было: Наименование ОС, дата поступления и дата передачи?
  5. Катюфка
    Offline

    Катюфка Профессионал в 1С

    Регистрация:
    3 июн 2013
    Сообщения:
    412
    Симпатии:
    72
    Баллы:
    54
    Здравствуйте.
    Я предлагала примерно следующее:


    Код:
    БИ = СоздатьОбъект("БухгалтерскиеИтоги");
    НачДата = Дата("01.01.2013");
    КонДата = Дата("31.12.2013");
    БИ.ИспользоватьСубконто(ВидыСубконто.ОсновныеСредства);
    Если БИ.ВыполнитьЗапрос(НачДата,КонДата,"01.1,01.2",,,2,"Операция",) = 0 Тогда
    Предупреждение("Не удается выполнить запрос к бухгалтерским итогам!");
    Возврат;
    КонецЕсли;
    БИ.ВыбратьСубконто();
    Пока БИ.ПолучитьСубконто() = 1 Цикл
    БИ.ВыбратьПериоды();
    Пока БИ.ПолучитьПериод() = 1 Цикл
    Сообщить(Би.Операция.Документ);
    Сообщить(БИ.Субконто().Наименование+" "+Строка(БИ.ДО())+" "+Строка(БИ.КО()));
    КонецЦикла;
    КонецЦикла;
    Вы получите обороты по 01 счету и виды документов, делающих эти движения. Можно отфильтровать только необходимые.
    По-хорошему, основными средствами они становятся после ввода в эксплуатацию. Поступление же идет на 08 счет. Там же собирается и малоценка.

Поделиться этой страницей