7.7 запрос по документам

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 7.7"", создана пользователем crysalis, 19 июн 2013.

  1. TopicStarter Overlay
    crysalis
    Offline

    crysalis

    Регистрация:
    26 мар 2012
    Сообщения:
    38
    Симпатии:
    0
    Баллы:
    1
    Утро доброе)

    Все никак не могу разобраться с запросами:(

    Что надо: выборку документов за определенный период и связанные определенным проектом ("проект" - реквизит документа).
    Т.е. получить отчет, где в первой строке будет проект, а в строках ниже, документы связанные с этим проектом.


    Код:
    СпрПроекты=СоздатьОбъект("Справочник.Проекты");
    спрПроекты.ВыбратьЭлементы();
    Запрос = СоздатьОбъект("Запрос");
    
    ТекстЗапроса = 
    "
    |Период с ВыбНачПериода по ВыбКонПериода;
    |Обрабатывать НеПомеченныеНаУдаление;
    |ОбрабатыватьДокументы Проведенные;
    |Документ=Документ.ЗаявкаПокупателя.ТекущийДокумент, Документ.Реализация.ТекущийДокумент;
    |Группировка Документ"
    ; 
    Если Запрос.Выполнить(ТекстЗапроса) = 0 Тогда
    Возврат;
    КонецЕсли;
    
    Пока Запрос.Группировка()=1 Цикл
    Пока спрПроекты.ПолучитьЭлемент()=1 цикл
    Если (спрПроекты.ЭтоГруппа()=0) и (спрПроекты.ПометкаУдаления()=0) тогда
    Таб.ВывестиСекцию("ТабПроект");
    Если Запрос.Документ.Проект=СпрПроекты тогда
    Таб.ВывестиСекцию("Документ");	
    КонецЕсли;  
    КонецЕсли;
    КонецЦикла;
    КонецЦикла;   
    
    на выходе почему-то получаю только список проектов, без документов :(
    Документы точно там есть, косяк явно в запросе, но никак не могу понять где именно:(

    Ткните меня носом в мою ошибку :blush:
  2. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
    У вас же нет группировки по проекту
    Код:
    Процедура Сформировать()
    Перем Запрос, ТекстЗапроса, Таб;
    //Создание объекта типа Запрос
    Запрос = СоздатьОбъект("Запрос");
    ТекстЗапроса =
    "//{{ЗАПРОС(Сформировать)
    |Период с ВыбНачПериода по ВыбКонПериода;
    |Проект =  Документ.ЗаявкаПокупателя.Проект, Документ.Реализация.Проект;
    |ТекущийДокумент = Документ.ЗаявкаПокупателя.ТекущийДокумент, Документ.Реализация.ТекущийДокумент;
    |Группировка Проект без групп;
    |Группировка ТекущийДокумент;
    |Условие(Проект в ВыбПроект);
    |"//}}ЗАПРОС
    ;
    // Если ошибка в запросе, то выход из процедуры
    Если Запрос.Выполнить(ТекстЗапроса) = 0 Тогда
    Возврат;
    КонецЕсли;
    // Подготовка к заполнению выходных форм данными запроса
    Таб = СоздатьОбъект("Таблица");
    Таб.ИсходнаяТаблица("Сформировать");
    // Заполнение полей "Заголовок"
    Таб.ВывестиСекцию("Заголовок");
    Состояние("Заполнение выходной таблицы...");
    Таб.Опции(0, 0, Таб.ВысотаТаблицы(), 0);
    Пока Запрос.Группировка(1) = 1 Цикл
    // Заполнение полей Проект
    Таб.ВывестиСекцию("Проект");
    Пока Запрос.Группировка(2) = 1 Цикл
    // Заполнение полей ТекущийДокумент
    Таб.ВывестиСекцию("ТекущийДокумент");
    КонецЦикла;
    КонецЦикла;
    // Вывод заполненной формы
    Таб.ТолькоПросмотр(1);
    Таб.Показать("Сформировать", "");
    КонецПроцедуры
    где ВыбПроект - реквизит формы типа Справочник.Проекты
  3. TopicStarter Overlay
    crysalis
    Offline

    crysalis

    Регистрация:
    26 мар 2012
    Сообщения:
    38
    Симпатии:
    0
    Баллы:
    1
    как это не смешно, но даже с вашим вариантом ничего не выводит %))))
    ща голова вскипит)
  4. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
    выложите ваш отчет в виде файла. Конфа какая? ТиС?
  5. TopicStarter Overlay
    crysalis
    Offline

    crysalis

    Регистрация:
    26 мар 2012
    Сообщения:
    38
    Симпатии:
    0
    Баллы:
    1
    "ТиС", ага.
    отчет снизу

    в комментариях то, что я пытался сделать))))

    Вложения:

  6. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104

    Вложения:

    • 12121212.ert
      Размер файла:
      36 КБ
      Просмотров:
      23
  7. TopicStarter Overlay
    crysalis
    Offline

    crysalis

    Регистрация:
    26 мар 2012
    Сообщения:
    38
    Симпатии:
    0
    Баллы:
    1
    мда...
    спасибо, но не уж-то косяк был в передвинутой переменной "проект" в запросе? оО
  8. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
    нужно было убрать "без итогов". Там цикл по запросу тогда иной
  9. TopicStarter Overlay
    crysalis
    Offline

    crysalis

    Регистрация:
    26 мар 2012
    Сообщения:
    38
    Симпатии:
    0
    Баллы:
    1
    хм...
    всё равно спасибо)
    уже все сделал красиво и быстро))
    Можно в "решено" воткнуть, ну и для желающих выложу тут эту шнягу)

    Внешний отчет, считающий количество заявок клиентов (счетов) и реализаций по всем имеющимся проектам с выводом документов + разбивка на проведенные и непроведенные.

    Вложения:

  10. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104

Поделиться этой страницей