7.7 Запрос на остаток в дбф файл.

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 7.7"", создана пользователем scc, 13 окт 2009.

  1. TopicStarter Overlay
    scc
    Offline

    scc

    Регистрация:
    13 окт 2009
    Сообщения:
    8
    Симпатии:
    0
    Баллы:
    1
    Люди я не програмист 1с, но возникла проблема которую необходимо решить,из за недостаточности знаний возникают проблемы.Пытаюсь вот создать запрос с выгрузкой в файл дбф ,остаток не оплаченого на конец месяца по тарифам.Подскажите пожайлуста ...
    Код:
    Процедура ПриОткрытии()
    //{{ИНИЦИАЛИЗАЦИЯ БУХГАЛТЕРСКОГО ЗАПРОСА(обсчет)
    ВыбНачПериода = НачалоМесяцаБИ();
    ВыбКонПериода = КонецМесяцаБИ();
    //{{ИНИЦИАЛИЗАЦИЯ БУХГАЛТЕРСКОГО ЗАПРОСА
    КонецПроцедуры
    Процедура экспорт()
    ФС.УстТекКаталог("d:\");  
    ИмяПути = ФС.ТекКаталог();        
    
    ИмяФайла = "baza" + ДатаМесяц(ДатаСоздания)+".dbf";
    ФайлЭкспорта = ИмяПути + ИмяФайла;
    ..............
    Тб.ДобавитьПоле("ul"      ,2,20,);    // Адрес:улица
    Тб.ДобавитьПоле("dom"     ,2,10,);    // Адрес:дом
    Тб.ДобавитьПоле("kv"      ,2,10,);    // Адрес:квартира
    Тб.ДобавитьПоле("dolg"    ,1,10,);    // долг на начало месеца
    ...........................
    Тб.ul  = Спр.Улица.Наименование;
    Тб.dom= Спр.Дом;
    Тб.kv  = Спр.Квартира;
    БИ=СоздатьОбъект("БухгалтерскиеИтоги");
    БИ.ИспользоватьСубконто("Контрагенты",Спр.ТекущийЭлемент(),2);    
    БИ.ВыполнитьЗапрос(НачМесяца(ТекущаяДата()),КонМесяца(ТекущаяДата()),СчетПоКоду("62.1"),1,);    
    БИ.ВыбратьСубконто();
    Пока БИ.ПолучитьСубконто()=1 Цикл
    Тб.dolg =БИ.ДО();
    КонецЕсли;
    Тб.Записать();
    КонецЦикла;
    
    
    Не считает не как остаток при таком запросе ,подскажите может кто сталкивался,а то тяжеловато чота. :unsure:
  2. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
    Код:
    Ит.ИспользоватьСубконто(ВидыСубконто.Контрагенты, Спр.ТекущийЭлемент(), 1);
    Ит.ВыполнитьЗапрос(НачМесяца(ТекущаяДата()), ТекущаяДата(),, "62.1",,, 1,, "С");
    Ит.ВыбратьСубконто(ВидыСубконто.Контрагенты);
    Пока Ит.ПолучитьСубконто(ВидыСубконто.Контрагенты) = 1 Цикл
    Тб.dolg =БИ.ДО();
    Тб.Записать();
    КонецЦикла;
    
    
    
Похожие темы
  1. Gangster
    Ответов:
    1
    Просмотров:
    1.687
  2. MaxTi
    Ответов:
    2
    Просмотров:
    1.392
  3. Сандра
    Ответов:
    12
    Просмотров:
    2.557
  4. GREEENS
    Ответов:
    6
    Просмотров:
    900
  5. materiy_boec
    Ответов:
    7
    Просмотров:
    1.201
Загрузка...

Поделиться этой страницей