7.7 Запрос на остаток и вычитание

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 7.7"", создана пользователем MaxTi, 24 авг 2007.

  1. TopicStarter Overlay
    MaxTi
    Offline

    MaxTi

    Регистрация:
    23 авг 2007
    Сообщения:
    7
    Симпатии:
    0
    Баллы:
    1
    Есть обработка, которая перносит из торговли 9.0 в бух4.5 приходную накладную, но нужно туда вставить функцию вычитания товара из переносимой накладной кол-ва товара уже имеющегося на складе в бух4.5:

    Ит=V7.CreateObject("БухгалтерскиеИтоги");
    Ит.ИспользоватьСубконто("Номенклатура");
    Ит.ВыполнитьЗапрос(ДатаНачала,ДатаКонца,"41.1");
    Ит.ВыбратьСчета();
    Пока Ит.ПолучитьСчет() = 1 Цикл
    Ит.ВыбратьСубконто(1) ;
    Пока Ит.ПолучитьСубконто() = 1 Цикл
    Сообщить("Счет " + Ит.Счет.Код + " " + Ит.Субконто(1)
    + Строка(Ит.СКД()));
    КонецЦикла;
    КонецЦикла;
    НовыйДок.Количество=ТекущийДок.Количество-Ит;
    Если НовыйДок.Количество<=0 Тогда
    НовыйДок.УдалитьСтроку();
    КонецЕсли;
    что сдесь не так?
  2. Kirya
    Offline

    Kirya Опытный в 1С

    Регистрация:
    3 авг 2006
    Сообщения:
    106
    Симпатии:
    0
    Баллы:
    26
    Помойму, очень много чего не так.

    Код:
    НовыйДок.Количество=ТекущийДок.Количество-Ит;
    
    В конце помойму должно быть ИТ.СКД().

    А вообще какая ошибка выдается? или что происходит при запуске этой обработки? :unsure:
  3. TopicStarter Overlay
    MaxTi
    Offline

    MaxTi

    Регистрация:
    23 авг 2007
    Сообщения:
    7
    Симпатии:
    0
    Баллы:
    1
    не пойму, вчера обработка работала, сегодня пишет, что неудачная попытка создания объекта "бухгалтерские итоги"
Похожие темы
  1. Gangster
    Ответов:
    1
    Просмотров:
    1.687
  2. noway
    Ответов:
    2
    Просмотров:
    1.924
  3. scc
    Ответов:
    1
    Просмотров:
    362
  4. GREEENS
    Ответов:
    6
    Просмотров:
    900
  5. TODD22
    Ответов:
    5
    Просмотров:
    293
Загрузка...

Поделиться этой страницей