7.7 Запрос к бухгалтерским итогам. Почему задваиваются строки?

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 7.7"", создана пользователем Tolikv, 10 окт 2006.

  1. Amishechka
    Offline

    Amishechka Опытный в 1С

    Регистрация:
    8 сен 2006
    Сообщения:
    361
    Симпатии:
    1
    Баллы:
    26
    А нафига тебе перебирать строки конкретных документов? Ты ведь используешь запрос!
    для получения суммы достаточно написать:
    БИ.ВыбратьПериоды();
    Пока БИ.ПолучитьПериод() = 1 Цикл
    Сумма=БИ.КО(1) (ну или БИ.ДО(1) в зависимости от того, куда делается проводка)
    Количество=БИ.КО(3) (ну или БИ.ДО(3) в зависимости от того, куда делается проводка, правда, если счет количественный)
    КонецЦикла;

    Если счет не количественный, то тогда делай запрос до операций и смотри, когда у тебя месяц закончится и выводи в таблицу накопленную сумму, например
    БИ.ВыполнитьЗапрос(....."Операция");
    ....
    Сум=0;Кол=0;Дт=Дата1;
    БИ.ВыбратьПериоды(-1,0,1,0);
    пока БИ.ПолучитьПериод()=1 Цикл
    Если ДатаМесяц(БИ.Операция.Докумет.ДатаДок)<>ДатаМесяц(Дт) тогда
    присоединить секцию с месяцем;
    Сум=0;Кол=0;
    КонецЕсли;
    здесь твой кусок перебора строк
    КонецЦикла;
  2. TopicStarter Overlay
    Tolikv
    Offline

    Tolikv

    Регистрация:
    4 июл 2006
    Сообщения:
    25
    Симпатии:
    0
    Баллы:
    1
    Ага а если у меня первый документ допустим есть только в июне, а второй например в феврале, то у меня сначала выведется июнь а потом февраль, а мне нужны месяцы по порядку.
  3. Amishechka
    Offline

    Amishechka Опытный в 1С

    Регистрация:
    8 сен 2006
    Сообщения:
    361
    Симпатии:
    1
    Баллы:
    26
    Тогда включи свою башку в режим "думать" и не задавай глупых вопросов. Думаю не проблема узнать есть у тебя пропуск в месяцах или нет

Поделиться этой страницей