7.7 Запрос из одного документаи и справочника

Тема в разделе "Отчеты и обработки для "1С:Предприятие 7.7"", создана пользователем 17cross76, 11 июн 2008.

  1. TopicStarter Overlay
    17cross76
    Offline

    17cross76

    Регистрация:
    10 июн 2008
    Сообщения:
    5
    Симпатии:
    0
    Баллы:
    1
    Задача:
    Составить реестр закуп. и отпускных цен по приходным накладным за определенный диапазон,
    те. №, Номен., Ед.Изм., Кол-во, ЦенаЗакуп, СуммаЗакуп +(ЦенаРозн)
    То что в скобках надо вытащить из справочника Цен (интересуют Розничная цена, вычисляемая как процент от закупочной). И еще: Если я вытащил кол-во и цену как их перемножить в запросе и вставить в Сумму?
    Код:
    Процедура РеестрЦен()
    Перем Запрос, ТекстЗапроса, Таб;
    //Создание объекта типа Запрос
    Запрос = СоздатьОбъект("Запрос");
    ТекстЗапроса = 
    "//{{ЗАПРОС(РеестрЦен)
    |Период с ВыбНачПериода по ВыбКонПериода;
    |ПоступлениеТМЦ = Документ.ПоступлениеТМЦ.ТекущийДокумент;
    |Наимен = Документ.ПоступлениеТМЦ.Номенклатура;
    |ЕдИзм = Документ.ПоступлениеТМЦ.Единица;
    |КолВо = Документ.ПоступлениеТМЦ.Количество;
    |СвободЦена = Документ.ПоступлениеТМЦ.Цена;
    |СуммаСв = Документ.ПоступлениеТМЦ.Сумма;
    |РознЦена = Документ.ПоступлениеТМЦ.Номенклатура.ТипыЦен.Наименование; // Не работает........
    |Группировка ПоступлениеТМЦ; 
    |Группировка Наимен Без Групп;
    |"//}}ЗАПРОС
    ;
    // Если ошибка в запросе, то выход из процедуры
    Если Запрос.Выполнить(ТекстЗапроса) = 0 Тогда
    Возврат;
    КонецЕсли;
    
    // Подготовка к заполнению выходных форм данными запроса
    Таб = СоздатьОбъект("Таблица");
    Таб.ИсходнаяТаблица("РеестрЦен");
    // Заполнение полей "Заголовок"
    Таб.ВывестиСекцию("Заголовок");
    Состояние("Заполнение выходной таблицы...");
    Таб.Опции(0, 0, Таб.ВысотаТаблицы(), 0);
    Пока Запрос.Группировка(1) = 1 Цикл
    Пока Запрос.Группировка(2) = 1 Цикл
    // Заполнение полей ПоступлениеТМЦ
    Таб.ВывестиСекцию("ПоступлениеТМЦ");
    КонецЦикла;
    КонецЦикла;  
    
    // Вывод заполненной формы
    Таб.ТолькоПросмотр(1);
    Таб.Показать("РеестрЦен", "");
    КонецПроцедуры
    
    
  2. Steel Rain
    Offline

    Steel Rain Опытный в 1С

    Регистрация:
    29 сен 2006
    Сообщения:
    408
    Симпатии:
    2
    Баллы:
    29
    В запросе:
    Код:
    |Функция Переменная=Сумма(Переменная1*Переменная2);
    

Поделиться этой страницей