8.х Запрос для вывода напечать инфы

Тема в разделе "Общие вопросы "1С:Предприятие 8"", создана пользователем Graf1000, 8 фев 2012.

  1. TopicStarter Overlay
    Graf1000
    Offline

    Graf1000

    Регистрация:
    1 фев 2012
    Сообщения:
    41
    Симпатии:
    0
    Баллы:
    1
    Доброго времени суток!!!
    Сейчас я занимаюсь внедрением 1С УНФ. Это мое первое внедрение. И я дорабатываю конфу под организацию ( не хватало некоторых документов для работы и печатные формы) . Документы я создал и макеты печатных форм тоже. Вся загвоздка у меня начинается при выводе инфы на печать.
    Как положено Код запроса был написан, но главная трудность у меня возникает при выводе Табельного Номера. Реквизита «Табельный номер» у меня нет, т.к. Я его взял здесь.
    (Если у вас время есть,я буду рад ,если Вы мне напишите на почту kira754@mail.ru)
    А код запроса след:

    Код:
    Макет = Документы.СлужебноеЗадание.ПолучитьМакет("Печать");
    Запрос = Новый Запрос;
    Запрос.Текст =
    "ВЫБРАТЬ
    // Какой код нужно дописать, чтобы  табельный номер выходил напечать в этот макет?
    |		   СлужебноеЗадание.Дата,
    |		   СлужебноеЗадание.Работник.Ссылка.Код,
    |		   СлужебноеЗадание.ДатаОт,
    |		   СлужебноеЗадание.Комментарий,
    |		   СлужебноеЗадание.Номер,
    |		   СлужебноеЗадание.РуководительОрганизации,
    |		   СлужебноеЗадание.РуководительПодразделения,
    |		   СлужебноеЗадание.ЦельКомандировки,
    |   СлужебноеЗадание.Участник.(
    |	   Работник,
    |					   КолДней,
    |					   С,
    |					   По,
    |					   Должность,
    |					   СтруктураПодразделения,
    |		   СлужебноеЗадание.МестоНазначение,
    |		   СлужебноеЗадание.Основание,
    |		    )
    |ИЗ
    |		   Документ.СлужебноеЗадание КАК СлужебноеЗадание
    |ГДЕ
    |		   СлужебноеЗадание.Ссылка В (&Ссылка)";
    Запрос.Параметры.Вставить("Ссылка", Ссылка);
    Выборка = Запрос.Выполнить().Выбрать();
    ОбластьЗаголовок = Макет.ПолучитьОбласть("Шапка");
    ОбластьУчастник = Макет.ПолучитьОбласть("Участник");
    ОбластьТаблица = Макет.ПолучитьОбласть("Таблица");	   
    ОбластьПодвал = Макет.ПолучитьОбласть("Подвал");
    ТабДок.Очистить();
    ВставлятьРазделительСтраниц = Ложь;
    Пока Выборка.Следующий() Цикл
    Если ВставлятьРазделительСтраниц Тогда
    ТабДок.ВывестиГоризонтальныйРазделительСтраниц();
    КонецЕсли;
    
    //Вывод информации
    ОбластьЗаголовок.Параметры.Заполнить(Выборка);// доработка
    ТабДок.Вывести(ОбластьЗаголовок, Выборка.Уровень());
    
    ВыборкаУчастник = Выборка.Участник.Выбрать();
    Пока ВыборкаУчастник.Следующий() Цикл
    ОбластьУчастник.Параметры.Заполнить(ВыборкаУчастник);
    ТабДок.Вывести(ОбластьУчастник, ВыборкаУчастник.Уровень());
    КонецЦикла;
    ОбластьТаблица.Параметры.Заполнить(Выборка);// доработка
    ТабДок.Вывести(ОбластьТаблица, Выборка.Уровень());
    
    ОбластьПодвал.Параметры.Заполнить(Выборка);// доработка
    ТабДок.Вывести(ОбластьПодвал, Выборка.Уровень());
    
    ВставлятьРазделительСтраниц = Истина;
    КонецЦикла;
    //}}
    КонецПроцедуры

    Вложения:

  2. -devICE-
    Offline

    -devICE- Опытный в 1С

    Регистрация:
    3 авг 2010
    Сообщения:
    68
    Симпатии:
    0
    Баллы:
    26
    замени
    Код:
    СлужебноеЗадание.Работник.Ссылка.Код
    на
    Код:
    СлужебноеЗадание.Работник.Ссылка.Код КАК ТН
    и проверь
  3. TopicStarter Overlay
    Graf1000
    Offline

    Graf1000

    Регистрация:
    1 фев 2012
    Сообщения:
    41
    Симпатии:
    0
    Баллы:
    1
    Спасибо получилось)))

Поделиться этой страницей