7.7 Запрос без группировок

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 7.7"", создана пользователем leoit, 5 дек 2013.

  1. TopicStarter Overlay
    leoit
    Offline

    leoit

    Регистрация:
    22 ноя 2013
    Сообщения:
    19
    Симпатии:
    0
    Баллы:
    1
    Добрый день, подскажите пожайлуста можно ли выполнить данный запрос (перебор документов отгрузки) без группировок?
    Код:
    Процедура Сформировать()
    Перем Запрос, ТекстЗапроса, Таб;
    //Создание объекта типа Запрос
    Запрос = СоздатьОбъект("Запрос");
    ТекстЗапроса =
    "//{{ЗАПРОС(Сформировать)
    |Период с ВыбНачПериода по ВыбКонПериода;
    |Обрабатывать НеПомеченныеНаУдаление;
    |Покупатель = Документ.РасходнаяНакладная.Контрагент;
    |Товар = Документ.РасходнаяНакладная.Товар;
    |Количество = Документ.РасходнаяНакладная.Количество;
    |Цена = Документ.РасходнаяНакладная.Цена;
    |Всего = Документ.РасходнаяНакладная.Всего;
    |ТекущийДокумент = Документ.РасходнаяНакладная.ТекущийДокумент;
    |Функция КоличествоСумма = Сумма(Количество);
    |Функция ВсегоСумма = Сумма(Всего);
    
    |"//}}ЗАПРОС
    ;
    // Если ошибка в запросе, то выход из процедуры
    Если Запрос.Выполнить(ТекстЗапроса) = 0 Тогда
    Возврат;
    КонецЕсли;
    // Подготовка к заполнению выходных форм данными запроса
    Таб = СоздатьОбъект("Таблица");
    Таб.ИсходнаяТаблица("Сформировать");
    // Заполнение полей "Заголовок"
    Таб.ВывестиСекцию("Заголовок");
    Состояние("Заполнение выходной таблицы...");
    Таб.Опции(0, 0, Таб.ВысотаТаблицы(), 0);
    
    Пока Запрос.Группировка() = 1 Цикл
    Таб.ВывестиСекцию("Строка");
    КонецЦикла
    
    
    // Заполнение полей "Итого"
    Таб.ВывестиСекцию("Итого");
    // Вывод заполненной формы
    Таб.ТолькоПросмотр();
    Таб.Показать("Сформировать", "");
    КонецПроцедуры
    
  2. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
    Ну все равно нужна группировка по документу!

Поделиться этой страницей