[РЕШЕНО] Запретить печатать неоплаченную реализацию

Тема в разделе "Общие вопросы "1С:Предприятие 8"", создана пользователем cnupum, 10 июн 2018.

  1. TopicStarter Overlay
    cnupum
    Offline

    cnupum

    Регистрация:
    16 окт 2009
    Сообщения:
    12
    Симпатии:
    0
    Баллы:
    1
    1С:Предприятие 8.3 (8.3.10.2561)
    Управление торговлей, редакция 11 (11.3.4.124)

    Эти менеджеры бесят уже, не могут в конце рабочего дня кассу собрать нормально, ищут долги по реализациям в отчетах.
    Вот и появилась идея не выводить на печать не оплаченные документы.
    Пока придумал так:

    1. ПодменюПечать видимость в конфигураторе убираю галочку
    2. в процедуру "Процедура ПровестиДокумент(Команда)"
    добавить условие типа такого: Если поле "Расчеты" содержит текст 100% тогда ПодменюПечать.видимость = истина
    Есть минус: чтобы распечатать реализацию придётся два раза кнопку провести нажимать, зато проблем с оплатами не будет.
    В общем помогите перевести с моего кривого языка на язык 1с, чтобы можно было вставить в процедуру это условие.
    Заранее спасибо.
  2. LordMaverick
    Offline

    LordMaverick Профессионал в 1С

    Регистрация:
    17 мар 2014
    Сообщения:
    3.950
    Симпатии:
    463
    Баллы:
    104
    в УТ не проведённый документ РТиУ не печатается
    upload_2018-6-11_1-47-19.png

    а не оплаченный можно задать чтоб не проводился, пока не будет документа оплаты.
  3. TopicStarter Overlay
    cnupum
    Offline

    cnupum

    Регистрация:
    16 окт 2009
    Сообщения:
    12
    Симпатии:
    0
    Баллы:
    1
    Можно подробнее?
  4. Dem0lisher
    Offline

    Dem0lisher Профессионал в 1С

    Регистрация:
    4 авг 2009
    Сообщения:
    1.252
    Симпатии:
    100
    Баллы:
    104
    Более того, некоторые заполнения документов на основании не работают из непроведенных документов.
    А чтобы не проводился неоплаченный - нужно редактировать график платежей. Ставить в графике не кредит 100% на 100 дней, а предоплата 100%.
    Гиперссылка "К оплате"
  5. TopicStarter Overlay
    cnupum
    Offline

    cnupum

    Регистрация:
    16 окт 2009
    Сообщения:
    12
    Симпатии:
    0
    Баллы:
    1
    Сделал так:

    Процедура ПровестиДокумент(Команда)
    Если Прав(Расчеты,4) = "100%" Тогда Элементы.ПодменюПечать.Видимость = Истина;
    Иначе ОбщегоНазначенияКлиентСервер.СообщитьПользователю("Нет оплаты");
    КонецЕсли;
    ОбщегоНазначенияУТКлиент.Провести(ЭтаФорма, Истина);

    КонецПроцедуры

    Вот почему то сообщение пустое выходит... в чем проблема ?
    Последнее редактирование: 11 июн 2018
  6. Dem0lisher
    Offline

    Dem0lisher Профессионал в 1С

    Регистрация:
    4 авг 2009
    Сообщения:
    1.252
    Симпатии:
    100
    Баллы:
    104
    что это за самодеятельность? У вас что типовой кнопки "Провести и закрыть" нет?
  7. TopicStarter Overlay
    cnupum
    Offline

    cnupum

    Регистрация:
    16 окт 2009
    Сообщения:
    12
    Симпатии:
    0
    Баллы:
    1
    И что мне даст эта кнопка? сабж изучайте.
  8. Dem0lisher
    Offline

    Dem0lisher Профессионал в 1С

    Регистрация:
    4 авг 2009
    Сообщения:
    1.252
    Симпатии:
    100
    Баллы:
    104
    Любезный, я за себя сам разберусь, что мне изучать.
  9. TopicStarter Overlay
    cnupum
    Offline

    cnupum

    Регистрация:
    16 окт 2009
    Сообщения:
    12
    Симпатии:
    0
    Баллы:
    1
    Так ты сначала разберись, а потом пиши свои неуместные каменты. Лучше бы по делу что-то написал.
    Из-за таких Алексеев как ты, пришлось самому всё делать.
  10. Dem0lisher
    Offline

    Dem0lisher Профессионал в 1С

    Регистрация:
    4 авг 2009
    Сообщения:
    1.252
    Симпатии:
    100
    Баллы:
    104
    Алексея ты в зеркале увидишь =)
    Ну конечно самому делать! А ты хотел у воспитательницы спросить?
  11. TopicStarter Overlay
    cnupum
    Offline

    cnupum

    Регистрация:
    16 окт 2009
    Сообщения:
    12
    Симпатии:
    0
    Баллы:
    1
    Еще добавил в процедуру "при открытии":

    Если Прав(Расчеты,4) = "100%" Тогда Элементы.ПодменюПечать.Видимость = Истина;
    Иначе Элементы.ПодменюПечать.Видимость = Ложь;
    КонецЕсли;

    и тоже самое добавил к элементу "Расчеты" на "При Изменении"
    т.е. при открытии старого оплаченного документа или при поступлении оплаты его сразу можно печатать.

Поделиться этой страницей