8.х Запрет редактирования чужого документа

Тема в разделе "Общие вопросы "1С:Предприятие 8"", создана пользователем Nord178, 14 окт 2009.

  1. TopicStarter Overlay
    Nord178
    Offline

    Nord178

    Регистрация:
    2 сен 2009
    Сообщения:
    9
    Симпатии:
    0
    Баллы:
    1
    В УТ несколько пользователей могут вводить "заказ покупателя". Так и не нашел как ограничить возможность редактирования пользователем чужих заказов.

    Возможно ли это сделать через Роли и там Роли права?
  2. mialord
    Offline

    mialord Модераторы Команда форума Модератор

    Регистрация:
    31 июл 2009
    Сообщения:
    5.398
    Симпатии:
    40
    Баллы:
    54
    Здраствуйте!

    Не замарачивайтесь напишите так...

    Код:
    // Процедура - обработчик события "ПередОткрытием" формы.
    //
    Процедура ПередОткрытием(Отказ, СтандартнаяОбработка)
    
    Если НЕ РольДоступна("ПолныеПрава") И НЕ ПараметрыСеанса.ТекущийПользователь = ЭтотОбъект.Ответственный Тогда
    
    ЭтаФорма.ТолькоПросмотр = Истина;
    
    КонецЕсли; 
    
    Где процедура ПередОткрытием - это процедура формы документа ЗаказПокупателя

    Удачи!
  3. TopicStarter Overlay
    Nord178
    Offline

    Nord178

    Регистрация:
    2 сен 2009
    Сообщения:
    9
    Симпатии:
    0
    Баллы:
    1
    Спасибо, сейчас попробую
  4. TopicStarter Overlay
    Nord178
    Offline

    Nord178

    Регистрация:
    2 сен 2009
    Сообщения:
    9
    Симпатии:
    0
    Баллы:
    1
    А если надо запретить открытие этого документа другим пользователем вообще?


    И вопрос немного в другую тему

    В счете на оплату, хочу убрать графы скидки (УТ)

    Сделал это закомментировав

    Код:
    //Для каждого ВыборкаСтрокТовары Из ЗапросТовары Цикл 
    //	Если ЗначениеЗаполнено(ВыборкаСтрокТовары.Скидка) Тогда
    //		ЕстьСкидки = Истина;
    //		Прервать;
    //	КонецЕсли; 
    //КонецЦикла;
    
    Но мне надо чтоб в графе сумма выводилась сумма без учета скидки.
    попробовал так:

    Код:
    Скидка = Ценообразование.ПолучитьСуммуСкидки(ВыборкаСтрокТовары.Сумма, ВыборкаСтрокТовары.Скидка);
    
    Если ЕстьСкидки Тогда
    ОбластьСкидок.Параметры.Скидка         = Скидка;
    ОбластьСкидок.Параметры.СуммаБезСкидки = ВыборкаСтрокТовары.Сумма + Скидка;
    ТабДокумент.Присоединить(ОбластьСкидок);
    КонецЕсли;
    
    ОбластьСуммы.Параметры.Заполнить(ВыборкаСтрокТовары);
    ТабДокумент.Присоединить(ОбластьСуммы);
    Сумма          = Сумма       + ВыборкаСтрокТовары.Сумма    + Скидка;
    СуммаНДС       = СуммаНДС    + ВыборкаСтрокТовары.СуммаНДС;
    ВсегоСкидок    = ВсегоСкидок + Скидка;
    ВсегоБезСкидок = Сумма       + ВсегоСкидок;
    
    Добавил к строке Сумма = Сумма + ВыборкаСтрокТовары.Сумма + Скидка;
    В счете все равно сумма идет уже со скидкой.

    Не понимаю в чем дело :(
  5. TopicStarter Overlay
    Nord178
    Offline

    Nord178

    Регистрация:
    2 сен 2009
    Сообщения:
    9
    Симпатии:
    0
    Баллы:
    1
    Так и не разобрался, может кто подскажет?
  6. tirk
    Offline

    tirk Опытный в 1С

    Регистрация:
    1 сен 2008
    Сообщения:
    1.142
    Симпатии:
    0
    Баллы:
    26
    просто перед открытием()
    отказ = Ответственный = ТекущийПользователь;

    Поставь есть скидки = ложь
    и Скидка = 0;

Поделиться этой страницей