[РЕШЕНО] Запрет изменения дополнительных реквизитов

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 8"", создана пользователем rosveta, 9 ноя 2015.

  1. TopicStarter Overlay
    rosveta
    Offline

    rosveta Опытный в 1С

    Регистрация:
    22 май 2015
    Сообщения:
    152
    Симпатии:
    7
    Баллы:
    29
    Добрый день. Есть ут 11. Документ реализация товаров и услуг. У этого документа есть доп реквизит. Необходимо сделать запрет изменения этого реквизита, если есть подчиненные расходники и нет полных прав. Если бы это был обычный реквизит объекта или формы, тот мне понятно как сделать, При изменении или при создании на сервере можно было бы сделать все проверки и запретить. А как быть в случае с доп реквизитом? Как ограничивать его доступность?
  2. alexburn
    Online

    alexburn Модераторы Команда форума Модератор

    Регистрация:
    5 янв 2009
    Сообщения:
    14.756
    Симпатии:
    509
    Баллы:
    204
    Дополнительные реквизиты, вроде, хранятся в справочнике, может там что нужно колдовать :), тоже ниразу с этим не сталкивался :), свои добавлял во избежания подобных ситуевин :)
  3. TopicStarter Overlay
    rosveta
    Offline

    rosveta Опытный в 1С

    Регистрация:
    22 май 2015
    Сообщения:
    152
    Симпатии:
    7
    Баллы:
    29
    получилось вот так

    &НаСервере
    Процедура ПриСозданииНаСервере(Отказ, СтандартнаяОбработка)
    ............................................

    ДопРеквизит = "ДополнительныйРеквизитЗначение_8D085C63x92DFx4981x9420xDF87CE6ECCC3_3E566993x9081x11E2x9DBBx3085A9A0DC01"; //Обратиться можно только так
    Если ПолучитьСписокПодчиненныхДокументов(Объект.Ссылка) > 0 Тогда
    Если НЕ РольДоступна("ПолныеПрава") Тогда
    Элементы[ДопРеквизит].Доступность = Ложь;
    КонецЕсли;
    КонецЕсли;


    КонецПроцедуры
    alexburn и Ktyf нравится это.
  4. Yuriy_Alexandrovich
    Offline

    Yuriy_Alexandrovich Профессионал в 1С Команда форума

    Регистрация:
    15 сен 2011
    Сообщения:
    1.275
    Симпатии:
    76
    Баллы:
    54
    Доброго всем,
    Кому будет интересно как формируется имя :
    Элемент формы "Дополнительный реквизит", имя складывается из Уникального идентификатора элемента справочника "НаборыДополнительныхРеквизитовИСведений"
    и уникального идентификатора записи плана видов характеристик "ДополнительныеРеквизитыИСведения", соответствующей "дополнительному реквизиту".
    upload_2015-11-10_13-26-5.png
    получается по следующей логике -
    Код:
    ИмяРеквизитаЗначение = "ДополнительныйРеквизитЗначение_" + СтрЗаменить(ВРег(Строка(ОписаниеСвойства.Набор.УникальныйИдентификатор())), "-", "x") + "_" + СтрЗаменить(ВРег(Строка(ОписаниеСвойства.Свойство.УникальныйИдентификатор())), "-", "x");
    
    alexburn и rosveta нравится это.
  5. TopicStarter Overlay
    rosveta
    Offline

    rosveta Опытный в 1С

    Регистрация:
    22 май 2015
    Сообщения:
    152
    Симпатии:
    7
    Баллы:
    29
    Спасибо за информацию

Поделиться этой страницей