8.х запрашивает общий модуль

Тема в разделе "Отчеты и обработки для "1С:Предприятие 8"", создана пользователем wertklop, 15 май 2008.

  1. TopicStarter Overlay
    wertklop
    Offline

    wertklop Опытный в 1С

    Регистрация:
    12 май 2008
    Сообщения:
    321
    Симпатии:
    0
    Баллы:
    26
    я написал внешнюю обработку, при сохранении ошибок не выдаёт, а вот при вывполнении выдаёт:{ОбщийМодуль.зфЗащищенныеФункции(2390)}: Ошибка при вызове метода контекста: Ошибка при выполнении метода объекта компоненты
    причём ОбщийМодуль.зфЗащищенныеФункции пуст!
    что мне делать и зачем он к этому модулю обращается?помогите
  2. lazy
    Offline

    lazy Модераторы Команда форума Модератор

    Регистрация:
    1 сен 2007
    Сообщения:
    2.127
    Симпатии:
    4
    Баллы:
    29
    А сам код нам не хочешь показать?
  3. TopicStarter Overlay
    wertklop
    Offline

    wertklop Опытный в 1С

    Регистрация:
    12 май 2008
    Сообщения:
    321
    Симпатии:
    0
    Баллы:
    26
    Код:
    перем Всего,СумВсего;
    перем СуммаСтавкаНДС;
    перем СуммаЗапчасти;
    Процедура КнопкаВыполнитьНажатие(Кнопка)
    Макет = ПолучитьМакет("Заказ");
    Шапка=макет.ПолучитьОбласть("Шапка");
    Авто=Макет.ПолучитьОбласть("Авто");
    Операции=макет.ПолучитьОбласть("Операции");
    ИтогиОперации=Макет.ПолучитьОбласть("ИтогиОперации");
    Детали=Макет.ПолучитьОбласть("Детали");
    ИтогиДетали=макет.ПолучитьОбласть("ИтогиДеталей");
    Подвал=Макет.ПолучитьОбласть("Подвал");
    док=ПолеВвода1.ПолучитьОбъект();
    Автомобиль=док.Автомобиль.ПолучитьОбъект();
    Шапка.Параметры.Пробег=Автомобиль.Пробег;
    Шапка.Параметры.Дата=Автомобиль.Дата;
    исполнитель=док.Организация.ПолучитьОбъект();
    Шапка.Параметры.Исполнитель=исполнитель.НаименованиеПолное;
    //Шапка.Параметры.Адресисполнителя=
    киПолучитьПредставлениеКИ(исполнитель,
    Справочники.ВидыКонтактнойИнформации.АдресЮридический);
    //Шапка.Параметры.Телефонисполнителя=
    киПолучитьПредставлениеКИ(исполнитель, 
    Справочники.ВидыКонтактнойИнформации.ТелефонКонтактный);
    Шапка.Параметры.НомерЗаказа=Док.Номер;
    Шапка.Параметры.КодПричины=Док.ПричинаОбращения;
    макет.Вывести(шапка);
    заказчик=док.Заказчик.ПолучитьОбъект();
    Авто.Параметры.заказчик=заказчик.НаименованиеПолное;
    //Авто.Параметры.Адресзаказчик=киПолучитьПредставлениеКИ(заказчик, Справочники.ВидыКонтактнойИнформации.АдресЮридический);
    //Авто.Параметры.Телзаказчик=киПолучитьПредставлениеКИ(заказчик, Справочники.ВидыКонтактнойИнформации.ТелефонКонтактный);
    ФИОДовЛицо=
    Справочники.КонтактныеЛица.ПолучитьСсылку().Фамилия+
    " "+Справочники.КонтактныеЛица.ПолучитьСсылку().Имя+" 
    "+Справочники.КонтактныеЛица.ПолучитьСсылку().Отчество;
    Авто.Параметры.доверлицо=ФИОДовЛицо;
    Авто.Параметры.МодельАвто=Автомобиль.Модель;
    Авто.Параметры.VIN=Автомобиль.VIN;
    Авто.Параметры.регномер=Автомобиль.ГосНомер;
    Авто.Параметры.номердвигателя=Автомобиль.НомерДвигателя;
    макет.Вывести(Авто);
    запрос=Новый Запрос;
    запрос.Текст="ВЫБРАТЬ
    |    ЗаказНаряд.Работы.(
    |        НомерСтроки,
    |        Работа,
    |        Количество,
    |        Цена,
    |        СуммаВсего
    |    )
    |ИЗ
    |    Документ.ЗаказНаряд КАК ЗаказНаряд
    |ГДЕ
    |    ЗаказНаряд.Номер = &номер";
    запрос.УстановитьПараметр("номер",док.Номер);
    работы=запрос.Выполнить().Выгрузить();
    Всего=0;
    Работы=док.Работы.Выгрузить();
    Для Каждого ТекущаяСтрока из Работы Цикл 
    Операции.Параметры.Номер=ТекущаяСтрока.НомерСтроки;
    Операции.Параметры.описаниеоперации=ТекущаяСтрока.Работа;
    Операции.Параметры.количество=ТекущаяСтрока.Количество;
    Операции.Параметры.Цена=ТекущаяСтрока.Цена;
    Операции.Параметры.Сумма=ТекущаяСтрока.СуммаВсего;
    Всего=Всего+ТекущаяСтрока.СуммаВсего;
    //Сообщить(Работы.ВыбратьСтроку());    
    КонецЦикла;
    ИтогиОперации.Параметры.Всего=Всего;
    макет.Вывести(ИтогиОперации);
    СумВсего=0;
    СуммаЗапчасти=0;
    СуммаСтавкаНДС=0;
    запрос.Текст="ВЫБРАТЬ
    |    ЗаказНаряд.Товары.(
    |        НомерСтроки,
    |        Номенклатура,
    |        Количество,
    |        ЕдиницаИзмерения,
    |        Цена,
    |        СтавкаНДС,
    |        СуммаНДС,
    |        СуммаВсего
    |    )
    |ИЗ
    |    Документ.ЗаказНаряд КАК ЗаказНаряд
    |ГДЕ
    |    ЗаказНаряд.Номер = &номер";
    запрос.УстановитьПараметр("номер",док.Номер);
    Деталь=запрос.Выполнить().Выгрузить();
    Товары=док.Товары.Выгрузить();
    Для Каждого Текстр из Товары Цикл 
    Детали.Параметры.ДетНомер=Текстр.Номерстроки;
    Детали.Параметры.Деталь=Текстр.номенклатура;
    Детали.Параметры.Количество=Текстр.Количество;
    Детали.Параметры.ЕдИзм=Текстр.ЕденицаИзмерения;
    Детали.Параметры.ЦенаДеталь=Текстр.Цена;
    Детали.Параметры.Суммадеталь=СумВсего;
    Детали.Параметры.НДС18=Текстр.СтавкаНДС;
    Детали.Параметры.СуммаЗапчасти=Текстр.СуммаНДС;
    СумВсего=СумВсего+Текстр.СуммаВсего;
    СуммаЗапчасти=СуммаЗапчасти+Текстр.Суммавсего;
    СуммаСтавкаНДС=СуммаСтавкаНДС+Текстр.СтавкаНДС;
    КонецЦикла;
    Детали.Параметры.СуммаДеталь=сумвсего;
    Детали.Параметры.НДС18=СуммаСтавкаНДС;
    Детали.Параметры.СуммаЗапчасти=СуммаЗапчасти;
    макет.Вывести(Детали);
    ИтогиДетали.Параметры.СуммаДеталиВсего=СумВсего;
    ИтогиДетали.Параметры.НдсДеталиВсего=СуммаСтавкаНДС;
    ИтогиДетали.Параметры.СумЗапчпстейВсегоСНалогом=СуммаЗапчасти;
    макет.Вывести(ИтогиДетали);
    Подвал.Параметры.СтоимостьВыполненныхРабот=Всего;
    Подвал.Параметры.СтоимостьЗапЧастей=СуммаЗапчасти;
    Подвал.Параметры.ВТЧНДС=СуммаСтавкаНДС;
    Подвал.Параметры.ПодвалИтоги=СуммаЗапчасти+Всего;
    макет.Вывести(Подвал);
    
    Печать("Заказ");
    КонецПроцедуры
    
    
    

    данная обработка банально выбирает из документа данные и выводин в макет
  4. murat
    Offline

    murat

    Регистрация:
    6 сен 2007
    Сообщения:
    48
    Симпатии:
    0
    Баллы:
    1
    Судя по всему, похоже на очередную конфигурацию от РАРУСА по автотранспорту на 1С 8...

    "ОбщийМодуль.зфЗащищенныеФункции" - это скомпилированный модуль, реализованный чаще в виде внешней компонеты и как правило защищенный ключом.

    Можно предположить, что ошибка выдается потому что происходит обращение к защищенным разработчиком объектам конфигурации.

    А внешняя компонента при этом уже загружена???
Похожие темы
  1. russlix
    Ответов:
    0
    Просмотров:
    451
  2. Trainee
    Ответов:
    3
    Просмотров:
    1.138
Загрузка...

Поделиться этой страницей