8.х Заполнить список выбора справочника

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 8"", создана пользователем MarAvet, 21 дек 2015.

  1. TopicStarter Overlay
    MarAvet
    Offline

    MarAvet

    Регистрация:
    21 дек 2015
    Сообщения:
    3
    Симпатии:
    0
    Баллы:
    1
    Здравствуйте. Есть такая задача: есть справочник Факультеты с табличной частью НаправленияПодготовки и есть справочник Студенты, в котором в табличной части заполняется факультет и направление подготовки. При выборе в справочнике Студенты факультета, необходимо для направления подготовки давать выборку из табличной части справочника Факультеты. Платформа 1С 8.2. В данный момент сделано так: при изменении поля "факультет" список выбора "направления подготовки" заполняется данными из всех табличных частей. Как сделать так, чтобы для каждого факультета был свой набор значений.
  2. 1cUserAndrew
    Offline

    1cUserAndrew Профессионал в 1С Команда форума

    Регистрация:
    27 май 2010
    Сообщения:
    4.948
    Симпатии:
    149
    Баллы:
    104
    Покажите код, которым сейчас заполняете список выбора.
    Скорее всего, надо просто условие на факультет поставить.
  3. bajiepka
    Offline

    bajiepka Опытный в 1С

    Регистрация:
    26 сен 2014
    Сообщения:
    328
    Симпатии:
    22
    Баллы:
    29
    в настройках реквизитов есть поля "связи параметров выбора, параметры выбора", по которым можно настроить отбор по значениям. (пример: для конкретного контрагента при отображении выводятся только его договоры из соответствующего справочника). Если отбор более сложный то я бы также делал запросом...
  4. TopicStarter Overlay
    MarAvet
    Offline

    MarAvet

    Регистрация:
    21 дек 2015
    Сообщения:
    3
    Симпатии:
    0
    Баллы:
    1
    Код:
    &НаСервере
    Функция   ПолучитьНаправление(Фак)
        Запрос = Новый Запрос;
        Запрос.Текст = "Выбрать Напр.* ИЗ Справочник.Факультеты.Направления КАК Напр ";
        //Запрос.УстановитьПараметр("Фак",Фак);
        Рез = Запрос.Выполнить();
        Выборка=Рез.Выбрать();
        Массив = Новый Массив;
        Пока Выборка.Следующий() Цикл
            Массив.Добавить(Выборка.НаправлениеПодготовки);
        КонецЦикла;
        Возврат Массив;
    КонецФункции
    &НаКлиенте
    Процедура ФакультетФакультетПриИзменении(Элемент)
        // Вставить содержимое обработчика.    
        ТекДанные = ЭтаФорма.ТекущийЭлемент.ТекущиеДанные;
        Выборка = ПолучитьНаправление(ТекДанные.Факультет);
        ЭтаФорма.Элементы.ФакультетНаправлениеПодготовки.СписокВыбора.ЗагрузитьЗначения(Выборка);
    КонецПроцедуры
    
  5. 1cUserAndrew
    Offline

    1cUserAndrew Профессионал в 1С Команда форума

    Регистрация:
    27 май 2010
    Сообщения:
    4.948
    Симпатии:
    149
    Баллы:
    104
    Добавьте в запрос:
    Код:
    "
    ГДЕ
        Напр.Ссылка = &Фак"
    и раскомментируйте установку параметра.
  6. TopicStarter Overlay
    MarAvet
    Offline

    MarAvet

    Регистрация:
    21 дек 2015
    Сообщения:
    3
    Симпатии:
    0
    Баллы:
    1
    Большое спасибо! Буду пробовать
Похожие темы
  1. Bajik
    Ответов:
    7
    Просмотров:
    1.865
  2. PavelA
    Ответов:
    1
    Просмотров:
    242
Загрузка...

Поделиться этой страницей