8.х Заполнения много строчной строке значением из справочника

Тема в разделе "Общие вопросы "1С:Предприятие 8"", создана пользователем IDOL, 27 май 2012.

  1. TopicStarter Overlay
    IDOL
    Offline

    IDOL

    Регистрация:
    8 июл 2010
    Сообщения:
    17
    Симпатии:
    0
    Баллы:
    1
    Как заполнить многострочное поле, при выборе наименования элементов из справочника через запятую.
    Пример

    Наименование1, Наименование2, Наименование3……..
  2. ТатьянаМерлин
    Offline

    ТатьянаМерлин

    Регистрация:
    26 май 2012
    Сообщения:
    8
    Симпатии:
    0
    Баллы:
    1
    Поставить в справочнике не равно, а в списке. см. Настройка и тогда можешь выбрать несколько перечислений номенклатуры
  3. TopicStarter Overlay
    IDOL
    Offline

    IDOL

    Регистрация:
    8 июл 2010
    Сообщения:
    17
    Симпатии:
    0
    Баллы:
    1
    А где Это устанавливается справочнике не равно?
  4. ТатьянаМерлин
    Offline

    ТатьянаМерлин

    Регистрация:
    26 май 2012
    Сообщения:
    8
    Симпатии:
    0
    Баллы:
    1
    в справочнике или в любом отчете надо выбрать не равно, а в списке

    в каком именно справочнике?
  5. 1cUserAndrew
    Offline

    1cUserAndrew Профессионал в 1С Команда форума

    Регистрация:
    27 май 2010
    Сообщения:
    4.948
    Симпатии:
    149
    Баллы:
    104
    Если я правильно понял задачу, Вам надо для многострочного поля создать два события: "Начало выбора" и "Обработка выбора".

    Код примерно такой:

    Код:
    Процедура МногострочноеПолеНачалоВыбора(Элемент, СтандартнаяОбработка)
    
    ФормаВыбора = Справочники.ИмяСправочника.ПолучитьФормуВыбора(, Элемент);
    ФормаВыбора.ЗакрыватьПриВыборе = Ложь;
    
    ФормаВыбора.Открыть();
    
    КонецПроцедуры
    
    
    
    Процедура МногострочноеПолеОбработкаВыбора(Элемент, ВыбранноеЗначение, СтандартнаяОбработка)
    
    СтандартнаяОбработка = Ложь;
    
    Если ПустаяСтрока(МногострочноеПоле) Тогда
    МногострочноеПоле = ВыбранноеЗначение;
    Иначе
    МногострочноеПоле = МногострочноеПоле + ", " + ВыбранноеЗначение;
    КонецЕсли;
    
    КонецПроцедуры
    
  6. TopicStarter Overlay
    IDOL
    Offline

    IDOL

    Регистрация:
    8 июл 2010
    Сообщения:
    17
    Симпатии:
    0
    Баллы:
    1
    Огромное спасибо 1cUserAndrew Выручил все работает так как надо!!!

Поделиться этой страницей