8.х Заполнение табличной части с выбором значений

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 8"", создана пользователем Coolpix83, 5 фев 2016.

  1. TopicStarter Overlay
    Coolpix83
    Offline

    Coolpix83

    Регистрация:
    5 фев 2016
    Сообщения:
    2
    Симпатии:
    0
    Баллы:
    1
    Необходимо решить проблему, не могу дойти..
    8.3 Клиент серверный вариант
    Справочники: Абоненты, Тарифы, СтатусАбонента


    &НаКлиенте
    Процедура Заполнить(Команда)

    ЗаполнитьТабличнуюЧастьСписокАбонентов();


    КонецПроцедуры


    &НаСервере
    Процедура ЗаполнитьТабличнуюЧастьСписокАбонентов()
    Запрос = Новый Запрос;
    Запрос.Текст =
    //"ВЫБРАТЬ
    //| Абоненты.Ссылка
    //|ИЗ
    //| Справочник.Абоненты КАК Абоненты";
    "ВЫБРАТЬ
    | Абоненты.Ссылка,
    | Абоненты.Статус
    |ИЗ
    | Справочник.Абоненты КАК Абоненты";
    //
    // "ВЫБРАТЬ
    // | Сотрудники.Ссылка
    // |ИЗ
    // | Справочник.Сотрудники КАК Сотрудники";
    //
    РезультатЗапроса = Запрос.Выполнить().Выгрузить();

    Для каждого Стр из РезультатЗапроса Цикл
    НоваяСтрока = Объект.АбонентыСписком.Добавить();

    НоваяСтрока.ФИО = Стр.Ссылка;
    НоваяСтрока.АбонПлата = Объект.АбоненскаяПлата.СуммаТарифа;
    НоваяСтрока.СтатусАбонента = Стр.Статус;
    НоваяСтрока.СтатусТарифа = "Списание";

    КонецЦикла
    КонецПроцедуры

    Обработка работа способна и все загружает, но нужно
    Удаление строк из табличной части по отбору из справочника или жестко
    Статус абонента нужно допустим поставить Активный чтоб в табличной части были только Активные по статусу.

    Либо Лучше всего чтоб при заполнении табличной части можно было выбирать из группы Абонентов..

    Скажите как проще сделать.. Уже все варианты переабрал ни чего не помогает, может изначально не в ту строну..ПОМОГИТЕ...
  2. TopicStarter Overlay
    Coolpix83
    Offline

    Coolpix83

    Регистрация:
    5 фев 2016
    Сообщения:
    2
    Симпатии:
    0
    Баллы:
    1
    Все решил всем спасибо
    Запрос.УстановитьПараметр("Статус", Объект.СтатусАбонента);

Поделиться этой страницей