8.х Заполнение реквизита

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 8"", создана пользователем Sepegka, 1 окт 2008.

  1. TopicStarter Overlay
    Sepegka
    Offline

    Sepegka Опытный в 1С

    Регистрация:
    18 июн 2008
    Сообщения:
    67
    Симпатии:
    0
    Баллы:
    26
    Как сделать,что бы при заполнении реквизита Наименования(ФИО),автоматически заполнялись три реквизита Фамилия Имя Отчество расположенных на данной форме?

    Вложения:

    • 2.jpg
      2.jpg
      Размер файла:
      95,9 КБ
      Просмотров:
      26
  2. opkc
    Offline

    opkc Опытный в 1С

    Регистрация:
    28 янв 2008
    Сообщения:
    149
    Симпатии:
    0
    Баллы:
    26
    В типовой:

    Код:
     
    
    Процедура НаименованиеПриИзменении(Элемент)
    
    ФИО = Наименование;
    
    Если ПустаяСтрока(Фамилия) ИЛИ ЭтоНовый() Тогда
    Фамилия  = ВыделитьСлово(ФИО);
    Имя      = ВыделитьСлово(ФИО);
    Отчество = ВыделитьСлово(ФИО);
    КонецЕсли;
    
    КонецПроцедуры
    
    
    Функция ВыделитьСлово(ИсходнаяСтрока)
    
    Буфер = СокрЛ(ИсходнаяСтрока);
    ПозицияПослПробела = Найти(Буфер, " ");
    
    Если ПозицияПослПробела = 0 Тогда
    ИсходнаяСтрока = "";
    Возврат Буфер;
    КонецЕсли;
    
    ВыделенноеСлово = СокрЛП(Лев(Буфер, ПозицияПослПробела));
    ИсходнаяСтрока = Сред(ИсходнаяСтрока, ПозицияПослПробела + 1);
    
    Возврат ВыделенноеСлово;
    
    КонецФункции
    
    
    
    

Поделиться этой страницей