[РЕШЕНО] Заполнение Регистра Сведений метаданными документ

Тема в разделе "Отчеты и обработки для "1С:Предприятие 8"", создана пользователем GAMI1991, 20 мар 2015.

  1. TopicStarter Overlay
    GAMI1991
    Offline

    GAMI1991 Опытный в 1С

    Регистрация:
    5 фев 2015
    Сообщения:
    71
    Симпатии:
    1
    Баллы:
    29
    Всем Привет, прошу вашей помощи. У меня есть задача: создать Регистр Сведений в форме записи которого будут выводиться все имеющиеся документы и динамический список напротив каждого документа. Я создала регистр и форму записи: Измерением яв-ся ТипОбъекта (строка) - сюда нужно выводить все документы и ресурс Статус(Перечисление) - здесь будет задаваться динамический список.Пишу код(смотрите ниже) но никак не могу добиться вывода всех имен документов в форму записи....
    Я только месяц занимаюсь программирование 1с прошу помощи в начинании.

    Код:
    Процедура ЗаписатьСтатусДокумента() Экспорт
    Для каждого Док Из Метаданных.Документы Цикл
    Запрос = новый запрос;
    Запрос.Текст = Запрос.Текст + ?(Запрос.Текст = "","", "ОБЪЕДИНИТЬ ВСЕ") + "
        |
         | ВЫБРАТЬ ПЕРВЫЕ 1
         |    Документ" + Док.Имя + ".Ссылка
         |ИЗ
         |    Документ." + Док.Имя + "КАК" + "Документ" + Док.Имя + "
         |";
       
         КонецЦикла;
         Попытка
           РезультатЗапроса = Запрос.Выполнить();
           ЕстьДокументы = НЕ РезультатЗапроса.Пустой();
         Исключение
           ЕстьДокументы = Истина;
         КонецПопытки;
         ВыборкаДетальныеЗаписи = РезультатЗапроса.Выбрать();
       
              Пока ВыборкаДетальныеЗаписи.Следующий() Цикл
                НаборЗаписей = РегистрСведений.НастройкаУстановкиСтатусаДокумента.СоздатьМенеджерЗаписи();
                НаборЗаписей.ТипОбъекта = Док.Имя;
                НаборЗаписей.Записать();
           КонецЦикла;
         КонецПроцедуры
    Последнее редактирование модератором: 21 мар 2015
  2. TopicStarter Overlay
    GAMI1991
    Offline

    GAMI1991 Опытный в 1С

    Регистрация:
    5 фев 2015
    Сообщения:
    71
    Симпатии:
    1
    Баллы:
    29
    В книгах и подобных темах форума ответа не нашла, прошу помочь!
  3. nickpugachev
    Offline

    nickpugachev Профессионал в 1С Команда форума

    Регистрация:
    28 май 2012
    Сообщения:
    3.266
    Симпатии:
    131
    Баллы:
    104
    статусы должны быть у конкретных документов или у типов документов?
  4. TopicStarter Overlay
    GAMI1991
    Offline

    GAMI1991 Опытный в 1С

    Регистрация:
    5 фев 2015
    Сообщения:
    71
    Симпатии:
    1
    Баллы:
    29
    Добрый вечер. Статусы должны быть у типов документов.
    Нужно вывести в форму записи две колонки: все типы документов и динамический список "Статус документа" :В работе, Утвержден, Проверен.
    Последнее редактирование: 21 мар 2015
  5. nickpugachev
    Offline

    nickpugachev Профессионал в 1С Команда форума

    Регистрация:
    28 май 2012
    Сообщения:
    3.266
    Симпатии:
    131
    Баллы:
    104
    базовая конфигурация какая? или самопис полный? БСП есть?
  6. TopicStarter Overlay
    GAMI1991
    Offline

    GAMI1991 Опытный в 1С

    Регистрация:
    5 фев 2015
    Сообщения:
    71
    Симпатии:
    1
    Баллы:
    29
    Это базовая конфигурация КУСХП. Я нашла решение моей задачи:

    Процедура ЗаписатьСтатусДокумента() Экспорт
    Для каждого Док Из Метаданные.Документы Цикл
    НаборЗаписей = РегистрСведений.НастройкаУстановкиСтатусаДокумента.СоздатьМенеджерЗаписи();
    НаборЗаписей.ТипОбъекта = Док.Имя;
    НаборЗаписей.Записать();
    КонецЦикла;
    КонецПроцедуры

    Всем Спасибо!

Поделиться этой страницей