8.х Заполнение нескольких реквизитов в ТЧ.("ПриИзменении".)

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 8"", создана пользователем kaaasteeen, 14 июл 2017.

  1. TopicStarter Overlay
    kaaasteeen
    Offline

    kaaasteeen

    Регистрация:
    5 июл 2017
    Сообщения:
    19
    Симпатии:
    0
    Баллы:
    1
    (8.3, УФ)
    Приветствую.
    Прошу помощи. Хочу разобраться как реализовать: автоматическое заполнение нескольких реквизитов( Количество, Размер) в ТЧ(Состав) при выборе реквизита в этой же ТЧ (Предмет), используя СоставПриИзменении( Элемент)...
    Хочу разобраться, но никак не доходит.
    Я знаю как заполнить один реквизит в ТЧ, но вот, чтобы несколько.

    Код:
    &НаКлиенте
    Процедура ВыполненныеРаботыВидРаботыПриИзменении(Элемент)
        ТекСтрока = Элементы.ВыполненныеРаботы.ТекущиеДанные;
        ТекСтрока.Стоимость = ПолучитьСтоимость(ТекСтрока.ВидРаботы);
    КонецПроцедуры
    
    &НаСервереБезКонтекста
    Функция ПолучитьСтоимость(ВидРаботы)
        Возврат ВидРаботы.Стоимость
       
    КонецФункции
  2. nomad_irk
    Online

    nomad_irk Гуру в 1С

    Регистрация:
    20 окт 2008
    Сообщения:
    9.407
    Симпатии:
    973
    Баллы:
    204
    В чем сложность сделать

    Код:
    &НаКлиенте
    Процедура ВыполненныеРаботыВидРаботыПриИзменении(Элемент)
        ТекСтрока = Элементы.ВыполненныеРаботы.ТекущиеДанные;
        ТекСтрока.Стоимость = ПолучитьСтоимость(ТекСтрока.ВидРаботы);
        .......
        ТекСтрока.<Реквизит1> = ПолучитьЗначение(Текстрока.<Реквизит0>);
        ТекСтрока.<Реквизит2> = ПолучитьЗначение(Текстрока.<Реквизит3>);
         .................
    КонецПроцедуры
    ?
    kaaasteeen нравится это.
  3. TopicStarter Overlay
    kaaasteeen
    Offline

    kaaasteeen

    Регистрация:
    5 июл 2017
    Сообщения:
    19
    Симпатии:
    0
    Баллы:
    1
    О поверьте сложность есть. Когда до конца не понимаешь алгоритмы.
    --- Объединение сообщений, 14 июл 2017 ---
    Сложно дается понимание алгоритмов. Не подскажите, что почитать? Чтобы я такие глупые вопросы не задавал здесь...
    Сейчас я я на таком этапе, что узнаю код правильный, разбираю его и пытаюсь понять, что и для чего применяется. Что-то исключительно своё еще так и ни разу и не написал. Стыдно...
    Последнее редактирование: 14 июл 2017
  4. LordMaverick
    Offline

    LordMaverick Профессионал в 1С

    Регистрация:
    17 мар 2014
    Сообщения:
    3.951
    Симпатии:
    463
    Баллы:
    104
    тогда к обязательному прочтению :)

    "Разработка управляемого интерфейса" - http://v8.1c.ru/metod/books/book.jsp?id=231http://v8.1c.ru/metod/books/book.jsp?id=231

    https://its.1c.ru/db/pubmanagedui#content:260:hdoc


    там как раз на станице 623 аналог вашей задачи начинается
    при обращении к справочнику товары получить три реквизита :)

Поделиться этой страницей