8.х Заполнение макета из Таблицы значений

Тема в разделе "Отчеты и обработки для "1С:Предприятие 8"", создана пользователем Ivan2014, 6 фев 2016.

  1. TopicStarter Overlay
    Ivan2014
    Offline

    Ivan2014 Опытный в 1С

    Регистрация:
    10 апр 2014
    Сообщения:
    384
    Симпатии:
    2
    Баллы:
    29
    Здравствуйте. Бьюсь с задачей - не могу решить. Есть таблица значений - в ней название колонок меняется в зависимости от других данных.
    Так вот, мне необходимо эту таблицу отобразить в макете.
    Для этого на макете создал ячейку - назначил ей имя Строка, имя ячейки Строка.
    Путем использования Вывести + Присоединить хочу вывести таблицу.
    Строка таблицы значений - это не структура, ни массив - никак не могу в цикле перебрать все колонки. Сами колонки известны - перебираю в цикле - получаю их, а что дальше??? В общем - замкнутый круг. Как такие задачи решаются?
    Спасибо большущее.
    --- Объединение сообщений, 6 фев 2016 ---
    УРА!!!
    Вроде что-то получилось:
    Код:
    Для Каждого Элемент Из ТаблицаТ Цикл
            Сч = 0;
            Для Каждого Колонка Из ТаблицаТ.Колонки Цикл
                ОбластьСтрока.Параметры.Строка = Элемент[Колонка.Имя];
                Если Сч = 0 Тогда
                    ТабДок.Вывести(ОбластьСтрока);
                Иначе
                    ТабДок.Присоединить(ОбластьСтрока);
                КонецЕсли;
                Сч = Сч + 1;
            КонецЦикла;
        КонецЦикла;
    Насколько это грамотно? Как правильно такие задачи решаются?
    Последнее редактирование: 6 фев 2016

Поделиться этой страницей