[РЕШЕНО] Записать список элементов справочника

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 8"", создана пользователем User, 3 апр 2015.

  1. TopicStarter Overlay
    User
    Offline

    User Опытный в 1С

    Регистрация:
    4 фев 2013
    Сообщения:
    146
    Симпатии:
    0
    Баллы:
    26
    Здравствуйте! Помогите, пожалуйста решить проблемку. Есть справочник, в котором ПередЗаписью пересчитываются данные в ТЧ. Для того чтобы пересчитать данные создаю обработку, выгружаю туда список справочника и при выполнении хочу, чтобы справочник каждой строки перезаписался. Для выполнения записи пишу так:
    Код:
    Процедура КнопкаВыполнитьНажатие(Кнопка)   
            СтрокаТЧ=ЭлементыФормы.СписокСправочников.ТекущиеДанные;
            ЗаписатьДанные(СтрокаТЧ);
    КонецПроцедуры
    
    Процедура ЗаписатьДанные(СтрокаТЧ)
        Для Каждого Ссылка из СписокСправочников Цикл
        СправочникОбъект = СтрокаТЧ.Нормы.Ссылка.ПолучитьОбъект();
        СправочникОбъект.Записать();
        КонецЦикла;
    КонецПроцедуры
    ... но при выполнении ПередЗаписью в самом справочнике не происходит. Подскажите, пожалуйста, что не так?
  2. TopicStarter Overlay
    User
    Offline

    User Опытный в 1С

    Регистрация:
    4 фев 2013
    Сообщения:
    146
    Симпатии:
    0
    Баллы:
    26
    Решено!

Поделиться этой страницей