8.х Запись результата обработки в документ

Тема в разделе "Отчеты и обработки для "1С:Предприятие 8"", создана пользователем НатальяНат, 22 сен 2012.

  1. TopicStarter Overlay
    НатальяНат
    Offline

    НатальяНат

    Регистрация:
    20 сен 2012
    Сообщения:
    10
    Симпатии:
    0
    Баллы:
    1
    И снова Здравствуйте!
    Помогите пожалуйста, подскажите, как можно результат обработки записать в документ?Вот тут процедура "Записать" :

    Код:
    Процедура Записать(ПроводитьДокумент) Экспорт
    
    ДокОб = ДокументСсылка.ПолучитьОбъект();
    
    //работа с таблицами документа
    
    Для каждого ТекРеквизита из ТЧТабЧасти Цикл
    ДокОб = ТЧТабЧасти.ВыгрузитьКолонки("Цена,КоличествоУпаковокФакт,СтавкаНДС");
    КонецЦикла;
    ДокОб.Записать(РежимЗаписиДокумента.Запись);
    //ИЗМЕНЕНИЕ ДОКУМЕНТА
    
    Если ПроводитьДокумент Тогда
    РежимПроведения=РежимЗаписиДокумента.Проведение;  
    Иначе
    РежимПроведения=РежимЗаписиДокумента.Запись;
    КонецЕсли;
    
    Попытка
    ДокОб.Записать(РежимПроведения);
    Исключение
    Сообщить(""+ОписаниеОшибки());
    КонецПопытки;
    
    КонецПроцедуры
    
    Мне нужно в документ Отчет о розничных продажах, в Товары, записать табличную часть выводимую из обработки. Вот как раз те колонки которые выгружаются из табличной части. а почему то он не хочет записывать..=( почему то.?
    Обработу прилагаю.

    Вложения:

  2. TopicStarter Overlay
    НатальяНат
    Offline

    НатальяНат

    Регистрация:
    20 сен 2012
    Сообщения:
    10
    Симпатии:
    0
    Баллы:
    1
    Когда на кнопку "записать" нажимаю он выдает ошибку "Метод объекта не обнаружен (Записать)".
  3. Dmitriy_76
    Offline

    Dmitriy_76 Опытный в 1С Команда форума

    Регистрация:
    26 мар 2011
    Сообщения:
    2.175
    Симпатии:
    13
    Баллы:
    29
    после выполнения ДокОб = ДокументСсылка.ПолучитьОбъект(); , докОб какой тип имеет ? и значение
  4. TopicStarter Overlay
    НатальяНат
    Offline

    НатальяНат

    Регистрация:
    20 сен 2012
    Сообщения:
    10
    Симпатии:
    0
    Баллы:
    1
    После выполнения ДокОб = ДокументСсылка.ПолучитьОбъект(); ДокОб имеетДокументСсылка.ОтчетОРозничныхПродажах - вот этот тип.=)
  5. TopicStarter Overlay
    НатальяНат
    Offline

    НатальяНат

    Регистрация:
    20 сен 2012
    Сообщения:
    10
    Симпатии:
    0
    Баллы:
    1
    О Боже! все получилось!=))) Спасибо всем за внимание.

Поделиться этой страницей