7.7 запись не срабатывает

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 7.7"", создана пользователем ZEMA, 16 окт 2007.

  1. TopicStarter Overlay
    ZEMA
    Offline

    ZEMA Опытный в 1С

    Регистрация:
    5 окт 2007
    Сообщения:
    231
    Симпатии:
    0
    Баллы:
    26
    Вот имеется процедурка, и проблемка в том, ЧТО В СПРАВОЧНИКЕ-КЛИЕНТОВ ИМЕЕТСЯ 2 РЕКИЗИТА,ОДИН РЕГИЕН,А 2-ОЙ МЕНЕДЖЕР. И ЕСЛИ ПРОСЛЕДИТЬ ВЕСЬ ХОД СОБЫТИЙ, ТО КОГДА ИДЕТ СРАВНЕНИЕ (НАПРИМЕР: Лев(Регион,3)="Южн"), ПРИ НАЖАТИИ НА КНОПКУ СОХРАНИТЬ,ПРОИСХОДИТ СОХРАНЕНИЕ,т.к вошла в справ.регионы, но не сохраняется (Менеджер.Наименование="Беньковская";),видимо из-за того,что не захожу в справ.сотрудники.Вот это я и не понимаю.Помогите!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!(надеюсь понятно написано) :unsure:



    Процедура приоткрытиирегиона()

    Спр=СоздатьОбъект("Справочник.Клиенты");


    Сообщить("Если Да, то по Сибирскому фед.округу Олиф, иначе Юрг","I");
    Пер=Вопрос("Показать данные по "+Регион.Наименование,"Да+Нет");
    ОчиститьОкноСообщений();
    Спр.ВыбратьЭлементы();

    Пока Спр.ПолучитьЭлемент()=1 цикл
    Если Лев(Регион,3)="Южн" тогда
    Если Пер = "Да" Тогда
    Менеджер.Наименование="Беньк;
    иначеЕсли Пер = "Нет" Тогда СтатусВозврата(0);
    конецесли;
    иначеЕсли Лев(Регион,3)="Дал" тогда
    Если Пер = "Да" Тогда
    Менеджер.Наименование="Олиф";
    иначеЕсли Пер = "Нет" Тогда статусвозврата(0);
    конецесли;
    иначеЕсли Лев(Регион,3)="Цен" тогда
    Если Пер = "Да" Тогда
    Менеджер.Наименование="Первух";
    иначеЕсли Пер = "Нет" Тогда статусвозврата(0);
    конецесли;
    иначеЕсли Лев(Регион,3)="Сев" тогда
    Если Пер = "Да" Тогда
    Менеджер.Наименование="Первух";
    иначеЕсли Пер = "Нет" Тогда статусвозврата(0);
    конецесли;
    иначеЕсли Лев(Регион,3)="Ура" тогда
    Если Пер = "Да" Тогда
    Менеджер.Наименование="Юрг";
    иначеЕсли Пер = "Нет" Тогда статусвозврата(0);
    конецесли;
    иначеЕсли Лев(Регион,3)="При" тогда
    Если Пер = "Да" Тогда
    Менеджер.Наименование="Администратор";
    иначеЕсли Пер = "Нет" Тогда статусвозврата(0);
    конецесли;
    иначеЕсли Лев(Регион,3)="Сиб" тогда
    Если Пер = "Да" Тогда
    Менеджер.Наименование="Олиф";
    ИначеЕсли Пер = "Нет" Тогда
    Менеджер.Наименование="Юрг";
    КонецЕсли;
    КонецЕсли;
    КонецЦикла;
    КонецПроцедуры
  2. yourname
    Offline

    yourname Опытный в 1С

    Регистрация:
    15 июл 2007
    Сообщения:
    84
    Симпатии:
    0
    Баллы:
    26
    Кажется стоит в синтакс-помошника посмотреть метод справочника Записать().......
  3. aksenov_as
    Offline

    aksenov_as

    Регистрация:
    6 июн 2007
    Сообщения:
    30
    Симпатии:
    0
    Баллы:
    1
    неясно значение переменной "менеджер". Если она является представлением реквизина "менеджер" справочника "спр", то к нему следует обращаться так: спр.менеджер.наименование = "строка".
  4. MaxxaM
    Offline

    MaxxaM Опытный в 1С

    Регистрация:
    16 окт 2007
    Сообщения:
    288
    Симпатии:
    2
    Баллы:
    29
    Насколько я понял переменная менеджер - явлется реквизитом справочника типа - "Справочник сотрудников",
    для его изменения надо
    спр2=создать(Справочник.Сотрудников);
    Если спр2.НайтиПоНаименованию("Беньк")=1 тогда
    менеджер=спр2.ТекущийЭлемент();
    КонецЕсли;
    :unsure:

Поделиться этой страницей