7.7 Запись книги покупок

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 7.7"", создана пользователем roman_q, 27 фев 2009.

  1. TopicStarter Overlay
    roman_q
    Offline

    roman_q

    Регистрация:
    11 фев 2009
    Сообщения:
    7
    Симпатии:
    0
    Баллы:
    1
    После проведения обновления № 504, все старые доработки затерлись.
    Пришлось восстанавливать.
    Не могу разобраться с "Запись Книги Покупок".
    Счет-фактуры полученные - Новый документ - Запись книги покупок.
    Заполняем поле "Всего покупок, включая НДС:" и перемещаемся на поле "Сумма без НДС", АВТОЗАПОЛНЕНИЯ поле не происходит.
    Пожалуйста, подскажите, как ситуацию исправить?

    Вложения:

    • kp.JPG
      kp.JPG
      Размер файла:
      113,3 КБ
      Просмотров:
      26
  2. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
    А что, стандартный способ уже не подходит. Все автоматически формирутся если стоит соотвествующая галочка в договоре контрагента (кстати она и стоит у тебя - отсюда и проблемы)
  3. TopicStarter Overlay
    roman_q
    Offline

    roman_q

    Регистрация:
    11 фев 2009
    Сообщения:
    7
    Симпатии:
    0
    Баллы:
    1
    :smile:
    Спасибо, за ответ.
    Попытался убедить бухгалтеров пользоваться функционалом по умолчанию, попытка провалилась.
    К сожалению, им неудобно так действовать. Они хотят вводить сумму с НДС и получать расчетную сумму без НДС, и сумму НДС.
    Буду рад другим вариантам.
    Заранее спасибо.
    :unsure:
  4. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
    И такое допустимо. Реализовывал по просьбе трудящихся (правда на счете, но то же самое).
    Убери на форме в табличной части с колонки "всего" сделать недоступным. Пусть бухи радуются.
    Напиши процедурку расчета от обратного. (смотри процедуру Пересчет с точностью до наоборот)
  5. КондаковАлексей
    Offline

    КондаковАлексей

    Регистрация:
    26 фев 2009
    Сообщения:
    17
    Симпатии:
    0
    Баллы:
    1
    Не подскажете как это сделать на примере счета??? Очень надо!
  6. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
    Код:
    Процедура Рассчитать() 
    НдсСверху=1;
    Если ПустоеЗначение(ВариантРасчетаНалогов.СтавкаНДС)=0 Тогда
    Ставка=ВариантРасчетаНалогов.СтавкаНДС.Ставка;
    НдсСверху=ВариантРасчетаНалогов.СуммаВключаетНДС;
    Иначе
    Ставка=глСтавкаНалога(Контекст, "НДС").Ставка;
    КонецЕсли;		
    Если (Всего <>0)И(Количество<>0) Тогда 
    Если НДССверху=1 Тогда
    Сумма=Всего/(1+(Ставка/100));
    НДС=Всего-Сумма;
    Цена=Сумма/Количество;
    Иначе
    Сумма=Всего;
    НДС=Сумма*(1-1/(1+Ставка/100));
    Цена=Сумма/Количество;
    КонецЕсли;
    КонецЕсли;   
    КонецПроцедуры 
    
    
    Сделано коряво за 10 минут, но работает....
    [warn="Можно еще 2 минуты уделить оформлению"] Пользуемся тегами!!![/warn]
    Рассчитать() вставь в формулу реквизита Всего табличной части
  7. TopicStarter Overlay
    roman_q
    Offline

    roman_q

    Регистрация:
    11 фев 2009
    Сообщения:
    7
    Симпатии:
    0
    Баллы:
    1
    Спасибо большое, буду пробывать! :unsure:

Поделиться этой страницей