7.7 Замена значений в адресной строке

Тема в разделе "Отчеты и обработки для "1С:Предприятие 7.7"", создана пользователем serga71, 20 янв 2010.

  1. TopicStarter Overlay
    serga71
    Offline

    serga71

    Регистрация:
    20 янв 2010
    Сообщения:
    2
    Симпатии:
    0
    Баллы:
    1
    Подскажите пожалуйста Новичку!!
    В ЗиК загрузили новый КЛАДР.Там в адресе поменялся пгт. на рп. Так вот вопрос, как теперь у сотрудников в адресе поменять пгт на рп.?Может кто подскажет как написать обработку?
    Спасиб!!
  2. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
    Простым перебором элементов справочника в цикле.
    Адрес хранится в виде строки. Используйте СтрЗаменить
  3. TopicStarter Overlay
    serga71
    Offline

    serga71

    Регистрация:
    20 янв 2010
    Сообщения:
    2
    Симпатии:
    0
    Баллы:
    1
    А если не трудно можно кусок кода кинуть?
  4. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
    Вот процедура которая произведет замену....
    Код:
    Спр=СоздатьОбъект("Справочник.Сортудники");
    Спр.ВыбратьЭлементы();
    НачатьТранзакцию();
    Пока Спр.ПолучитьЭлемент()=1 Цикл
    Если Спр.ЭтоГруппа()=1 Тогда
    продолжить;
    КонецЦикла;
    Если Найти(Спр.АдресФакт,"пгт.")+Найти(Спр.АдресПрописка,"пгт.")<>0 Тогда
    Спр.АдресФакт=СтрЗаменить(Спр.АдресФакт,"пгт.", "рп.");
    Спр.АдресПрописка=СтрЗаменить(Спр.АдресПрописка,"пгт.", "рп.");
    Спр.Записать();
    КонецЕсли;
    КонецЦикла;
    ЗафиксироватьТранзакцию();
    
    
    

Поделиться этой страницей