7.7 ЗАМЕНА ПРОВОДОК В БАЗЕ ПО УСЛОВИЮ !!!!!!!!!!!!!!!!!!!!!!!

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 7.7"", создана пользователем zhurkin_yuri, 7 июн 2006.

  1. TopicStarter Overlay
    zhurkin_yuri
    Offline

    zhurkin_yuri

    Регистрация:
    7 июн 2006
    Сообщения:
    1
    Симпатии:
    0
    Баллы:
    1
    Сделал обработку по замене счета


    Процедура Сформировать()
    Опер = СоздатьОбъект("Операция");
    Опер.ВыбратьОперацииСПроводками(НачДата, КонДата,"МЦ.10",,ПланыСчетов.Основной,);
    Пока Опер.ПолучитьОперацию()=1 Цикл
    Опер.ВыбратьПроводки();
    Пока Опер.ПолучитьПроводку()=1 Цикл
    Опер.УдалитьПроводку();
    Если Опер.Дебет.Счет=СчетПоКоду("МЦ.10") тогда
    Опер.Дебет.Счет="МЦ.04";
    КонецЕсли;
    КонецЦикла;
    Опер.Записать();
    КонецЦикла;
    Сообщить("ГОТОВО");
    КонецПроцедуры

    Но при запуске ругается что невозможно менять записанные проводки
    Помогите!!!! Что делать?
  2. рамиль
    Offline

    рамиль Опытный в 1С

    Регистрация:
    12 мар 2006
    Сообщения:
    595
    Симпатии:
    0
    Баллы:
    26
    Это скорее всего проводки которые принадлежат документтту.надо документ перепроводить.
  3. Гость
    Offline

    Гость Гость Гость

    Опер.УдалитьПроводку(); - Это что такое ?
    См.Конфигурация/Операция/Редактировать операции документов
    если там "Запретить", то не получится.

Поделиться этой страницей