Курилка ЗАМЕНА КОДОВ СПРАВОЧНИКОВ

Тема в разделе "Курилка", создана пользователем _mirror, 24 июл 2007.

  1. TopicStarter Overlay
    _mirror
    Offline

    _mirror

    Регистрация:
    24 июл 2007
    Сообщения:
    11
    Симпатии:
    0
    Баллы:
    1
    Помогите, плиз

    как присвоить коду справочника новый код

    я хочу перебить индексацию справочников. пишу

    Перем Макси;
    Макси=0;
    Спр=СоздатьОбъект("Справочник.Номенклатура");
    Спр.ВыбратьЭлементы();
    Пока Спр.ПолучитьЭлемент()=1 Цикл
    Спр.Код=Макси;
    Макси=Макси+1;
    Спр.Записать();
    КонецЦикла;
    Спр.Код=Макси;


    программа выдает переменная не определена Спр
  2. o1eg
    Offline

    o1eg Опытный в 1С

    Регистрация:
    25 июн 2006
    Сообщения:
    235
    Симпатии:
    0
    Баллы:
    26
    Создаешь внешний отчет.
    Вбиваешь туда вот этот код - работает на ура.
    Процедура Сформировать()
    Перем Макси;
    Макси=0;
    Спр=СоздатьОбъект("Справочник.Номенклатура");
    Спр.ВыбратьЭлементы();
    Пока (Спр.ПолучитьЭлемент()=1) и (Спр.ЭтоГруппа() = 0) Цикл
    Спр.Код=Макси;
    Макси=Макси+1;
    Спр.Записать();
    КонецЦикла;
    КонецПроцедуры

    Если тебе нужно все элементы перенумеровать, даже группы, тогда вот так.
    Процедура Сформировать()
    Перем Макси;
    Макси=0;
    Спр=СоздатьОбъект("Справочник.Номенклатура");
    Спр.ВыбратьЭлементы();
    Пока Спр.ПолучитьЭлемент()=1 Цикл
    Спр.Код=Макси;
    Макси=Макси+1;
    Спр.Записать();
    КонецЦикла;
    КонецПроцедуры

Поделиться этой страницей