8.х БП Закрытие 97 счета

Тема в разделе ""1С:Бухгалтерия БП"", создана пользователем Lisenokk, 16 июн 2011.

  1. TopicStarter Overlay
    Lisenokk
    Offline

    Lisenokk

    Регистрация:
    16 сен 2010
    Сообщения:
    24
    Симпатии:
    0
    Баллы:
    1
    У меня есть РБП, которые в налоговом учете были зачтены полностью еще в 2010 году. Таким образом по ним остаток по счету 97.21 в БУ был, а в НУ равен 0.
    Сделали перевод базы на 2.0. С остатками все хорошо - БУ есть, НУ ноль.
    Делаю закрытие месяца за январь. Получаются проводки Дт 26 Кт 97.21 на сумму 12500 и в БУ и в НУ, хотя в НУ проводок быть не должно. Там получается остаток на конец января -12500. А когда делаю закрытие февраля, марта и т.д. делает в НУ проводки по 1122 рубля,а в БУ по 12500.
    Как добиться того, чтобы не списывалось ничего по этим РБП в НУ? Ведь остаток-то 0!
  2. 1cUserAndrew
    Offline

    1cUserAndrew Профессионал в 1С Команда форума

    Регистрация:
    27 май 2010
    Сообщения:
    4.949
    Симпатии:
    149
    Баллы:
    104
    И все-таки я думаю, что-то не так с вводом остатков. Попробуйте удалить тот документ ввода остатков по 97сч и создать новый вручную.
    И т.к. Вам по НУ остатки вводить не надо, вводите остатки не документом "Ввод начальных остатков", а документом "Операция (бух и нал учет)". Соответственно колонки БУ и НУ очистите.
    Потом перепроведите закрытия месяца.
  3. TopicStarter Overlay
    Lisenokk
    Offline

    Lisenokk

    Регистрация:
    16 сен 2010
    Сообщения:
    24
    Симпатии:
    0
    Баллы:
    1
    Это все не помогло.

    Мы уже даже залезли в отладчик, рассчитывает он все правильно. По этим РБП суммы списания в НУ получаются 0 (это же и отражается в регистре Расчет списания расходов будущих периодов).
    Но дальше после расчета сумма заменяется. Происходит это в процедуре ПередЗаписью()

    Код:
    Если СчетДт.НалоговыйУчет И Проводка.СуммаНУДт = 0 И Проводка.СуммаПРДт = 0 И Проводка.СуммаВРДт = 0 Тогда
    Проводка.СуммаНУДт = Проводка.Сумма;                  //ВОТ ТУТ
    КонецЕсли;
    
    Если СчетКт.НалоговыйУчет И Проводка.СуммаНУКт = 0 И Проводка.СуммаПРКт = 0 И Проводка.СуммаВРКт = 0 Тогда
    Проводка.СуммаНУКт = Проводка.Сумма;                 //И ВОТ ТУТ
    КонецЕсли;
    
    //А дальше они снова могут стать 0, если это непринимаемые доходы и расходы.
    
    Если СчетКт.НалоговыйУчет Тогда
    
    ЭтоНепринимаемыеДоходы = НалоговыйУчет.ОпределитьНеПринимаемыеДоходы(Проводка);
    Если ЭтоНепринимаемыеДоходы Тогда 
    Проводка.СуммаПРКт = Проводка.СуммаПРКт + Проводка.СуммаНУКт;
    Проводка.СуммаНУКт = 0;
    КонецЕсли;
    
    КонецЕсли;
    
    Если СчетДт.НалоговыйУчет Тогда
    
    ЭтоНепринимаемыеРасходы = НалоговыйУчет.ОпределитьНеПринимаемыеРасходы(Проводка);
    Если ЭтоНепринимаемыеРасходы Тогда 
    Проводка.СуммаПРДт = Проводка.СуммаПРДт + Проводка.СуммаНУДт;
    Проводка.СуммаНУДт = 0;
    КонецЕсли;
    
    КонецЕсли;
    
    Я попробовала в самих РБП в статье затрат(субконто 26 счета) выбрать вид расхода Не учитываемые в целях налогообложения. В этом случае он по дебету получает сумму 0 в НУ, а по кредиту (97.21) все равно остается сумма.
    Как мне быть? Может кто-нибудь сталкивался с этим?
  4. Наташа
    Offline

    Наташа Опытный в 1С

    Регистрация:
    14 авг 2010
    Сообщения:
    1.442
    Симпатии:
    2
    Баллы:
    29
    А вы раньше учет по ПБУ 18/02 вели? Я полагаю, если в НУ и в БУ разные суммы, то должен быть еще и ВР, т.к. на данный момент у вас правило БУ = НУ + ПР + ВР не выполняется.
  5. TopicStarter Overlay
    Lisenokk
    Offline

    Lisenokk

    Регистрация:
    16 сен 2010
    Сообщения:
    24
    Симпатии:
    0
    Баллы:
    1
    Нет, ПБУ 18/02 мы не применяем.
  6. Наташа
    Offline

    Наташа Опытный в 1С

    Регистрация:
    14 авг 2010
    Сообщения:
    1.442
    Симпатии:
    2
    Баллы:
    29
    А в учетной политике это указали?
  7. TopicStarter Overlay
    Lisenokk
    Offline

    Lisenokk

    Регистрация:
    16 сен 2010
    Сообщения:
    24
    Симпатии:
    0
    Баллы:
    1
    Конечно.
  8. 1cUserAndrew
    Offline

    1cUserAndrew Профессионал в 1С Команда форума

    Регистрация:
    27 май 2010
    Сообщения:
    4.949
    Симпатии:
    149
    Баллы:
    104
    Я специально попробовал сделать так, как я описал выше. Т.е. ввел Операцией остатки только по БУ. И всё нормально. Всё как надо: при закрытии месяца по БУ списывается, по НУ - нет. Странно, что у Вас не получается...
  9. Наташа
    Offline

    Наташа Опытный в 1С

    Регистрация:
    14 авг 2010
    Сообщения:
    1.442
    Симпатии:
    2
    Баллы:
    29
    Хм, у меня всё корректно отработало даже с Вводом остатков.. Посмотрите в регистре "Расчет списания РБП" в колонке "Остаток расходов на начало периода (НУ)" 0 стоит?
  10. Наташа
    Offline

    Наташа Опытный в 1С

    Регистрация:
    14 авг 2010
    Сообщения:
    1.442
    Симпатии:
    2
    Баллы:
    29
    А у вас конфигурация типовая? У меня перед записью ничего такого не происходит..
  11. TopicStarter Overlay
    Lisenokk
    Offline

    Lisenokk

    Регистрация:
    16 сен 2010
    Сообщения:
    24
    Симпатии:
    0
    Баллы:
    1
    В Регистре расчета данные абсолютно верные, там по всем этим РБП в НУ полностью 0 и остаток на начало и сумма списания и остаток на конец.




    Да, типовая...

    Может это как-то настроить надо?


    У меня получается абсолютно одинаковая картина, что с вводом остатков, что с операцией. :angry:
    А у вас вводом остатков тоже суммы выдает вместо 0, только операцией получается?
  12. Наташа
    Offline

    Наташа Опытный в 1С

    Регистрация:
    14 авг 2010
    Сообщения:
    1.442
    Симпатии:
    2
    Баллы:
    29
    Нашла, где этот код, который ПриЗаписи(). Это в регистре бухгалтерии в самом, а не в документе :)
    По идее, у вас отладчик до этого места доходить не должен, ибо ранее стоит проверка:

    Код:
    	ТипРегистратора = ТипЗнч(Регистратор);
    НеКорректироватьНалоговыеСуммыРегистратора = 
    ТипРегистратора = Тип("ДокументСсылка.ОперацияБух") 
    ИЛИ ТипРегистратора = Тип("ДокументСсылка.РегламентнаяОперация")
    ИЛИ ТипРегистратора = Тип("ДокументСсылка.МодернизацияОС")
    ИЛИ ТипРегистратора = Тип("ДокументСсылка.СписаниеОС")
    ИЛИ ТипРегистратора = Тип("ДокументСсылка.СписаниеНМА")
    ИЛИ ТипРегистратора = Тип("ДокументСсылка.ВводНачальныхОстатков");
    
    Если НеКорректироватьНалоговыеСуммыРегистратора Тогда
    Возврат;
    
    КонецЕсли;
    
    То есть для документа "Регламентная операция" налоговый суммы проводок корректироваться не будут..
  13. 1cUserAndrew
    Offline

    1cUserAndrew Профессионал в 1С Команда форума

    Регистрация:
    27 май 2010
    Сообщения:
    4.949
    Симпатии:
    149
    Баллы:
    104
    Когда вводишь остатки документом "Ввод нач. остатков", при попытке очистить колонку "НУ" сумма прыгает в колонку "ВР". Т.е. возникает временная разница и ее никак не убрать (я правда не долго ковырялся, но убрать не смог..поле не доступно). Поэтому потом при закрытии месяца происходят движения по ВР.
    А в "Операции" можно спокойно очистить данные НУ. Т.е. ввести остатки только по БУ.

    Хотя у Наташи, вроде, всё получилось "Вводом нач. остатков". Как уж, не знаю :)
  14. Наташа
    Offline

    Наташа Опытный в 1С

    Регистрация:
    14 авг 2010
    Сообщения:
    1.442
    Симпатии:
    2
    Баллы:
    29
    А я в учетной политике галочку "ПБУ 18/02" сняла, и у меня колонок ВР и ПР вобще нет : ))
  15. 1cUserAndrew
    Offline

    1cUserAndrew Профессионал в 1С Команда форума

    Регистрация:
    27 май 2010
    Сообщения:
    4.949
    Симпатии:
    149
    Баллы:
    104
    Ааа...понятно :)
  16. TopicStarter Overlay
    Lisenokk
    Offline

    Lisenokk

    Регистрация:
    16 сен 2010
    Сообщения:
    24
    Симпатии:
    0
    Баллы:
    1
    У меня галочки ПБУ 18\02 нет, поэтому колонок ВР тоже нет. А у вас движения получаются только по ВР? По НУ не получаются? Если остатками, а не операцией.

    Я попробую еще завтра понять почему у меня тогда доходит отладчик до этого места. Напишу свои наблюдения.

    А может быть проблема в чем-то другом, раз у меня ни операцией, ни вводом не получается...

    У меня просто таких РБП около сотни. И исправлять каждый месяц весь НУ по ним я бы не хотела. Хочется понять, что неправильно.
  17. 1cUserAndrew
    Offline

    1cUserAndrew Профессионал в 1С Команда форума

    Регистрация:
    27 май 2010
    Сообщения:
    4.949
    Симпатии:
    149
    Баллы:
    104
    По НУ нет. Только по ВР (и по БУ, конечно). И то это только потому, что у меня галочка "ПБУ 18\02" установлена. Если снять, то будет только по БУ.
    Вы попробуйте ради эксперимента новый РБП в справочнике создать и ввести по нему остатки. Не уверен, что поможет, но вдруг...:)
  18. TopicStarter Overlay
    Lisenokk
    Offline

    Lisenokk

    Регистрация:
    16 сен 2010
    Сообщения:
    24
    Симпатии:
    0
    Баллы:
    1
    А какой у вас релиз стоит? Дело в том, что у меня другой код:
    Код:
    
    НеКорректироватьНалоговыеСуммыРегистратора = 
    ТипРегистратора = Тип("ДокументСсылка.ОперацияБух") 
    ИЛИ ТипРегистратора = Тип("ДокументСсылка.МодернизацияОС")
    ИЛИ ТипРегистратора = Тип("ДокументСсылка.СписаниеОС")
    ИЛИ ТипРегистратора = Тип("ДокументСсылка.СписаниеНМА")
    ИЛИ ТипРегистратора = Тип("ДокументСсылка.ВводНачальныхОстатков")
    ИЛИ (ТипРегистратора = Тип("ДокументСсылка.РегламентнаяОперация") 
    И Регистратор.ВидОперации <> Перечисления.ВидыРегламентныхОпераций.КорректировкаСтоимостиНоменклатуры
    И Регистратор.ВидОперации <> Перечисления.ВидыРегламентныхОпераций.ЗакрытиеСчета97);
    
    Если НеКорректироватьНалоговыеСуммыРегистратора Тогда
    Возврат;
    
    КонецЕсли;
    
    
    И тут как раз получается, что закрытие 97 счета корректируется... К сожалению.
  19. Наташа
    Offline

    Наташа Опытный в 1С

    Регистрация:
    14 авг 2010
    Сообщения:
    1.442
    Симпатии:
    2
    Баллы:
    29
    На самом деле, я на каком-то древнем релизе проверяла, 2.0.17, кажется.. :angry: Мой косяк.
    Глянула в 2.0.23, там как у вас.. Видимо, остается или править конфигурацию, или править потом закрытие месяца руками.. Или разработчикам напишите.
  20. 1cUserAndrew
    Offline

    1cUserAndrew Профессионал в 1С Команда форума

    Регистрация:
    27 май 2010
    Сообщения:
    4.949
    Симпатии:
    149
    Баллы:
    104
    Хм...интересно. Я тоже сейчас проверил на 23-м релизе. Точно - суммы проходят по НУ.

Поделиться этой страницей